Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Link Local BGP peering between Cisco and Juniper (M-Series)

Hi,

has anybody successfully managed to get a working IPv6 session between a Cisco and a Juniper router using Link Local IPs?

I got it working between two cisco routers and two Juniper Routers but not with the two different vendors.

Configuration on the Juniper site:

...

   family inet6 {
       address FE80::1/64;
   }

...

  protocols {
      bgp {
...

          group customer_ipv6 {
              neighbor fe80::2 {
                  local-interface at-2/0/0.119;
                  peer-as 65300;
                  as-override;
              }
          }
      }
  }


Configuration on the Cisco site:

interface ATM0/0/0.1 point-to-point
bandwidth 2033
ip address 10.194.235.42 255.255.255.252
ip access-group AL-SECURITY-WAN out
ip mtu 1500
ipv6 address FE80::2 link-local
ipv6 enable
bfd interval 999 min_rx 999 multiplier 15
pvc 1/32
  vbr-nrt 2244 2244 1
  tx-ring-limit 3
  encapsulation aal5snap

!

router bgp 65300
bgp router-id 10.213.58.185
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor FE80::1%ATM0/0/0.1 remote-as 65300
neighbor FE80::1%ATM0/0/0.1 version 4
neighbor FE80::2%GigabitEthernet0/1 remote-as 65300
neighbor FE80::2%GigabitEthernet0/1 version 4
!
address-family ipv4
...

exit-address-family
!
address-family ipv6
  neighbor FE80::1%ATM0/0/0.1 activate

  neighbor FE80::1%ATM0/0/0.1 advertisement-interval 5
  neighbor FE80::1%ATM0/0/0.1 soft-reconfiguration inbound
  neighbor FE80::1%ATM0/0/0.1 route-map NH6 out
  neighbor FE80::2%GigabitEthernet0/1 activate
  neighbor FE80::2%GigabitEthernet0/1 advertisement-interval 5
  neighbor FE80::2%GigabitEthernet0/1 soft-reconfiguration inbound
  neighbor FE80::2%GigabitEthernet0/1 route-map NH6 out
exit-address-family

CE_HOSTNAME# show ip bgp ipv6 uni su
BGP router identifier 10.213.58.185, local AS number 65300
BGP table version is 7, main routing table version 7
4 network entries using 656 bytes of memory
4 path entries using 320 bytes of memory
1/1 BGP path/bestpath attribute entries using 128 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
2 BGP community entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1200 total bytes of memory
BGP activity 34/12 prefixes, 38/12 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
FE80::1%ATM0/0/0.1
                4        65300       0       0        1    0    0 never    Idle
FE80::2%GigabitEthernet0/1
                4        65300      15      16        7    0    0 00:10:59        4
CE_HOSTNAME#


The console monitoring states the following:

Nov 10 06:30:33.023 MET: %BGP-3-NOTIFICATION: sent to neighbor FE80::1%ATM0/0/0.1 active 2/7 (unsupported/disjoint capability) 0 bytes
Nov 10 06:30:33.023 MET: %BGP-4-MSGDUMP: unsupported or mal-formatted message received from FE80::1%ATM0/0/0.1:
FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 001D 0104 505A 005A 52D2 C023 00
Nov 10 06:30:33.023 MET: %BGP-3-NOTIFICATION: received from neighbor FE80::1%ATM0/0/0.1 active 2/5 (authentication failure) 0 bytes
de-ipc-ulmdon-ce-02#
Nov 10 06:30:33.023 MET: %BGP_SESSION-5-ADJCHANGE: neighbor FE80::1%ATM0/0/0.1 IPv6 Unicast topology base removed from session  BGP Notification sent


The Cisco Router is running IOS 15.2, the Juniper Site JunOS 10.4

Any Ideas how I can get this to work?

Thanks in advance!

6 REPLIES
Cisco Employee

Link Local BGP peering between Cisco and Juniper (M-Series)

Stefan,

At a glance (and the RP guys can make better comments here) it looks like the problem might be somethign like IPv6 address family not enabled on Juniper (not that I'm not aware of defaults).

I dug up some link:

http://www.occaid.org/tutorial-ipv6bgp.html#juniper

they enable:

  family inet6 {
     any;
it is most likely the equivalent of our

address-family ipv6

  neighbor FE80::1%ATM0/0/0.1 activate

Just a thought ;-)

M.

Community Member

Re: Link Local BGP peering between Cisco and Juniper (M-Series)

Thanks! The family inet6 indeed got lost during the debugging (I also think that this may be optional because I got a working session between both routers using global unicast IPs)

Another problem was a wrong AS number in the neighbor statement on the Cisco-Router (remote AS is 20570).

But it still isn't working. The debugging output now:

CE_HOSTNAME#

Nov 10 15:12:57.848 MET: BGP: FE80::1%ATM0/0/0.1 active went from Idle to Active

Nov 10 15:12:57.848 MET: BGP: FE80::1%ATM0/0/0.1 open active, local address FE80::2

Nov 10 15:12:57.852 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x3172CA60:0) act Adding topology IPv6 Unicast:base

Nov 10 15:12:57.852 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x3172CA60:0) act Send OPEN

Nov 10 15:12:57.852 MET: BGP: FE80::1%ATM0/0/0.1 active went from Active to OpenSent

Nov 10 15:12:57.852 MET: BGP: FE80::1%ATM0/0/0.1 active sending OPEN, version 4, my as: 65300, holdtime 180 seconds, ID AD53AB9

Nov 10 15:12:57.856 MET: BGP: FE80::1%ATM0/0/0.1 active rcv message type 1, length (excl. header) 10

Nov 10 15:12:57.856 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x3172CA60:0) act Receive OPEN

Nov 10 15:12:57.856 MET: BGP: FE80::1%ATM0/0/0.1 active rcv OPEN, version 4, holdtime 90 seconds

Nov 10 15:12:57.856 MET: BGP: FE80::1%ATM0/0/0.1 active rcv OPEN w/ OPTION parameter len: 0

Nov 10 15:12:57.856 MET: BGP: FE80::1%ATM0/0/0.1 active went from OpenSent to Closing

Nov 10 15:12:57.856 MET: %BGP-3-NOTIFICATION: sent to neighbor FE80::1%ATM0/0/0.1 active 2/7 (unsupported/disjoint capability) 0 bytes

Nov 10 15:12:57.856 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x3172CA60:0) act Send NOTIFICATION 2/7 (unsupported/disjoint capability) 0 bytes

Nov 10 15:12:57.856 MET: %BGP-4-MSGDUMP: unsupported or mal-formatted message received from FE80::1%ATM0/0/0.1:

FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 001D 0104 505A 005A 52D2 C023 00

Nov 10 15:12:57.856 MET: BGP: FE80::1%ATM0/0/0.1 active rcv message type 3, l

CE_HOSTNAME#ength (excl. header) 2

Nov 10 15:12:57.856 MET: %BGP-3-NOTIFICATION: received from neighbor FE80::1%ATM0/0/0.1 active 2/5 (authentication failure) 0 bytes

Nov 10 15:12:57.856 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x3172CA60:0) act Receive NOTIFICATION 2/5 (authentication failure) 0 bytes

Nov 10 15:12:57.856 MET: BGP: FE80::1%ATM0/0/0.1 active bad state change from Closing to Closing

Nov 10 15:12:57.856 MET: -Traceback= 21B3370Cz 21B33C74z 21B34258z

Nov 10 15:12:57.856 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x3172CA60:0) NSF delete stale NSF not active

Nov 10 15:12:57.856 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x3172CA60:0) NSF no stale paths state is NSF not active

Nov 10 15:12:57.856 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x3172CA60:0) Resetting ALL counters.

Nov 10 15:12:57.856 MET: BGP: FE80::1%ATM0/0/0.1 active closing

Nov 10 15:12:57.856 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x3172CA60:0) act Session close and reset neighbor FE80::1%ATM0/0/0.1 topostate

Nov 10 15:12:57.856 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x3172CA60:0) Resetting ALL counters.

Nov 10 15:12:57.856 MET: BGP: FE80::1%ATM0/0/0.1 active went from Closing to Idle

Nov 10 15:12:57.856 MET: %BGP_SESSION-5-ADJCHANGE: neighbor FE80::1%ATM0/0/0.1 IPv6 Unicast topology base removed from session  BGP Notification sent

Nov 10 15:12:57.856 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x3172CA60:0) act Removed topology IPv6 Unicast:base

Nov 10 15:12:57.856 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x3172CA60:0) act Removed last topology

Nov 10 15:12:57.856 MET: BGP: nbr global FE80::1%ATM0/0/0.1 Open active delayed 11264ms (35000ms max, 60% jitter)

Nov 10 15:12:57.856 MET: BGP: nbr global FE80::1%ATM0/0/0.1 Active open failed - open timer running

CE_HOSTNAME#

Cisco Employee

Link Local BGP peering between Cisco and Juniper (M-Series)

Stefan,

I don't like this part:

Nov 10 14:56:51.689 MET: %BGP-3-NOTIFICATION: received from neighbor  FE80::1%ATM0/0/0.1 active 2/5 (authentication failure) 0 bytes

Nov  10 14:56:51.689 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x283DA06C:0)  act Receive NOTIFICATION 2/5 (authentication failure) 0 bytes

0) Do you see similar scenario for working session? (Between two Cisco routers)

1) What verion of IOS are you running? Something failrly recent I hope?

2) Can we have some more info from Juniper side (logs/debugs).

3)

  debug [ip] bgp all

  debug [ip] bgp all eve

  debug [ip] bgp all keep

M.

Community Member

Re: Link Local BGP peering between Cisco and Juniper (M-Series)

Marcin,

I updated the debugging log, the previous one was created using override-capability-neg on the neighbor (experimental).

>>0) Do you see similar scenario for working session? (Between two Cisco routers)

The working connection between two cisco routers doesn't show any output

>>1) What verion of IOS are you running? Something failrly recent I hope?

Show Version:

Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.2(1)T1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Mon 19-Sep-11 16:24 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M9, RELEASE SOFTWARE (fc1)

CE_HOSTNAME uptime is 2 weeks, 5 days, 21 hours, 35 minutes
System returned to ROM by reload at 18:43:21 MET(S) Fri Oct 21 2011
System restarted at 18:44:50 MET(S) Fri Oct 21 2011
System image file is "flash:c1900-universalk9-mz.SPA.152-1.T1.bin"
Last reload type: Normal Reload
Last reload reason: Reload Command

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco CISCO1941/K9 (revision 1.0) with 446464K/77824K bytes of memory.
Processor board ID FCZ1504C0G8
1 DSL controller
2 Gigabit Ethernet interfaces
1 ATM interface
1 terminal line
DRAM configuration is 64 bits wide with parity disabled.
255K bytes of non-volatile configuration memory.
250880K bytes of ATA System CompactFlash 0 (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*0        CISCO1941/K9          FCZ1504C0G8

Technology Package License Information for Module:'c1900'

-----------------------------------------------------------------
Technology    Technology-package           Technology-package
              Current       Type           Next reboot
------------------------------------------------------------------
ipbase        ipbasek9      Permanent      ipbasek9
security      None          None           None
data          datak9        Permanent      datak9

Configuration register is 0x2102

>>2) Can we have some more info from Juniper side (logs/debugs).

Sadly not. The Juniper Traceoptions don't show anything

All I can offer you at this point is the neighbor show command:

user@Juniper> show bgp neighbor fe80::2 instance vrf-test

Peer: fe80::2 AS 65300         Local: unspecified AS 20570
  Type: External    State: Idle           Flags:
  Last State: NoState       Last Event: NoEvent
  Last Error: None
  Export: [ pol-standard-bgp-export ] Import: [ pol-standard-bgp-import ]
  Options:
  Options:
  Address families configured: inet6-unicast
  Path-attributes dropped:  128
  Holdtime: 90 Preference: 170
  Number of flaps: 0
  Trace options:  all
  Trace file: /var/log/bgp_ipv6_ll_20111110 size 131072 files 10

user@Juniper> show bgp summary instance vrf-test

Groups: 2 Peers: 2 Down peers: 1
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
vrf-2.inet.0          37         16          0          0          0          0
vrf-.inet6.0           0          0          0          0          0          0
vrf-24.mdt.0           0          0          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
10.194.235.42         65300       1149       1076       0       1     8:44:00 Establ
  vrf-test.inet.0: 6/7/7/0
fe80::2               65300          0          0       0       0     9:38:32 Idle

>>3)

CE_HOSTNAME#

Nov 10 15:35:49.574 MET: BGP: ses global 10.194.235.41 (0x2970EDA4:1) Keep alive timer fired.

Nov 10 15:35:49.574 MET: BGP: 10.194.235.41 KEEPALIVE requested (bgp_keepalive_timer_expired)

Nov 10 15:35:49.574 MET: BGP: ses global 10.194.235.41 (0x2970EDA4:1) service keepalive IO request.

Nov 10 15:35:49.574 MET: BGP: 10.194.235.41 KEEPALIVE write request serviced in BGP_IO

CE_HOSTNAME#

Nov 10 15:35:50.598 MET: BGP: ses global FE80::2%GigabitEthernet0/1 (0x316FBDDC:1) Keep alive timer fired.

Nov 10 15:35:50.598 MET: BGP: FE80::2%GigabitEthernet0/1 KEEPALIVE requested (bgp_keepalive_timer_expired)

Nov 10 15:35:50.598 MET: BGP: ses global FE80::2%GigabitEthernet0/1 (0x316FBDDC:1) service keepalive IO request.

Nov 10 15:35:50.598 MET: BGP: FE80::2%GigabitEthernet0/1 KEEPALIVE write request serviced in BGP_IO

CE_HOSTNAME#

Nov 10 15:35:52.850 MET: BGP: 10.194.235.41 received KEEPALIVE, length (excl. header) 0

CE_HOSTNAME#

Nov 10 15:35:54.694 MET: BGP: FE80::1%ATM0/0/0.1 active went from Idle to Active

Nov 10 15:35:54.694 MET: BGP: FE80::1%ATM0/0/0.1 open active, local address FE80::2

Nov 10 15:35:54.698 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Adding topology IPv6 Unicast:base

Nov 10 15:35:54.698 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Send OPEN

Nov 10 15:35:54.698 MET: BGP: FE80::1%ATM0/0/0.1 active went from Active to OpenSent

Nov 10 15:35:54.698 MET: BGP: FE80::1%ATM0/0/0.1 active sending OPEN, version 4, my as: 65300, holdtime 180 seconds, ID AD53AB9

Nov 10 15:35:54.698 MET: BGP: FE80::1%ATM0/0/0.1 active KEEPALIVE write request serviced in BGP_IO

Nov 10 15:35:54.698 MET: BGP: FE80::1%ATM0/0/0.1 active service 2 read request in BGP_IO

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active KEEPALIVE write request serviced in BGP_IO

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active service 2 read request in BGP_IO

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active service 2 read request in BGP_IO

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active rcv message type 1, length (excl. header) 10

Nov 10 15:35:54.702 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Receive OPEN

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active rcv OPEN, version 4, holdtime 90 seconds

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active rcv OPEN w/ OPTION parameter len: 0

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active went from OpenSent to Closing

Nov 10 15:35:54.702 MET: %BGP-3-NOTIFICATION: sent to neighbor FE80::1%ATM0/0/0.1 active 2/7 (unsupported/disjoint capability) 0 bytes

Nov 10 15:35:54.702 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Send NOTIFICATION 2/7 (unsupported/disjoint capability) 0 bytes

Nov 10 15:35:54.702 MET: %BGP-4-MSGDUMP: unsupported or mal-formatted message received from FE80::1%ATM0/0/0.1:

FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 001D 0104 505A 005A 52D2 C023 00

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active rcv message type 3, length (excl. header) 2

Nov 10 15:35:54.702 MET: %BGP-3-NOTIFICATION: received from neighbor FE80::1%ATM0/0/0.1 active 2/5 (authentication failure) 0 bytes

Nov 10 15:35:54.702 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Receive NOTIFICATION 2/5 (authentication failure) 0 bytes

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active bad state change from Closing to Closing

Nov 10 15:35:54.702 MET: -Traceback= 21B3370Cz 21B33C74z 21B34258z

Nov 10 15:35:54.702 MET: BGP: tbl IPv4 Unicast:base Service reset requests

Nov 10 15:35:54.702 MET: BGP: tbl IPv6 Unicast:base Service reset requests

Nov 10 15:35:54.702 MET: BGP: tbl VPNv4 Unicast:base Service reset requests

Nov 10 15:35:54.702 MET: BGP: tbl VPNv6 Unicast:base Service reset requests

Nov 10 15:35:54.702 MET: BGP: tbl IPv4 Multicast:base Service reset requests

Nov 10 15:35:54.702 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x296337B4:0) NSF delete stale NSF not active

Nov 10 15:35:54.702 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x296337B4:0) NSF no stale paths state is NSF not active

Nov 10 15:35:54.702 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x296337B4:0) Resetting ALL counters.

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active closing

Nov 10 15:35:54.702 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Session close and reset neighbor FE80::1%ATM0/0/0.1 topostate

Nov 10 15:35:54.702 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x296337B4:0) Resetting ALL counters.

Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active went from Closing to Idle

Nov 10 15:35:54.702 MET: %BGP_SESSION-5-ADJCHANGE: neighbor FE80::1%ATM0/0/0.1 IPv6 Unicast topology base removed from session  BGP Notification sent

CE_HOSTNAME#CE_HOSTNAME#
Nov 10 15:35:49.574 MET: BGP: ses global 10.194.235.41 (0x2970EDA4:1) Keep alive timer fired.
Nov 10 15:35:49.574 MET: BGP: 10.194.235.41 KEEPALIVE requested (bgp_keepalive_timer_expired)
Nov 10 15:35:49.574 MET: BGP: ses global 10.194.235.41 (0x2970EDA4:1) service keepalive IO request.
Nov 10 15:35:49.574 MET: BGP: 10.194.235.41 KEEPALIVE write request serviced in BGP_IO
CE_HOSTNAME#
Nov 10 15:35:50.598 MET: BGP: ses global FE80::2%GigabitEthernet0/1 (0x316FBDDC:1) Keep alive timer fired.
Nov 10 15:35:50.598 MET: BGP: FE80::2%GigabitEthernet0/1 KEEPALIVE requested (bgp_keepalive_timer_expired)
Nov 10 15:35:50.598 MET: BGP: ses global FE80::2%GigabitEthernet0/1 (0x316FBDDC:1) service keepalive IO request.
Nov 10 15:35:50.598 MET: BGP: FE80::2%GigabitEthernet0/1 KEEPALIVE write request serviced in BGP_IO
CE_HOSTNAME#
Nov 10 15:35:52.850 MET: BGP: 10.194.235.41 received KEEPALIVE, length (excl. header) 0
CE_HOSTNAME#
Nov 10 15:35:54.694 MET: BGP: FE80::1%ATM0/0/0.1 active went from Idle to Active
Nov 10 15:35:54.694 MET: BGP: FE80::1%ATM0/0/0.1 open active, local address FE80::2
Nov 10 15:35:54.698 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Adding topology IPv6 Unicast:base
Nov 10 15:35:54.698 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Send OPEN
Nov 10 15:35:54.698 MET: BGP: FE80::1%ATM0/0/0.1 active went from Active to OpenSent
Nov 10 15:35:54.698 MET: BGP: FE80::1%ATM0/0/0.1 active sending OPEN, version 4, my as: 65300, holdtime 180 seconds, ID AD53AB9
Nov 10 15:35:54.698 MET: BGP: FE80::1%ATM0/0/0.1 active KEEPALIVE write request serviced in BGP_IO
Nov 10 15:35:54.698 MET: BGP: FE80::1%ATM0/0/0.1 active service 2 read request in BGP_IO
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active KEEPALIVE write request serviced in BGP_IO
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active service 2 read request in BGP_IO
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active service 2 read request in BGP_IO
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active rcv message type 1, length (excl. header) 10
Nov 10 15:35:54.702 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Receive OPEN
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active rcv OPEN, version 4, holdtime 90 seconds
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active rcv OPEN w/ OPTION parameter len: 0
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active went from OpenSent to Closing
Nov 10 15:35:54.702 MET: %BGP-3-NOTIFICATION: sent to neighbor FE80::1%ATM0/0/0.1 active 2/7 (unsupported/disjoint capability) 0 bytes
Nov 10 15:35:54.702 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Send NOTIFICATION 2/7 (unsupported/disjoint capability) 0 bytes
Nov 10 15:35:54.702 MET: %BGP-4-MSGDUMP: unsupported or mal-formatted message received from FE80::1%ATM0/0/0.1:
FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 001D 0104 505A 005A 52D2 C023 00
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active rcv message type 3, length (excl. header) 2
Nov 10 15:35:54.702 MET: %BGP-3-NOTIFICATION: received from neighbor FE80::1%ATM0/0/0.1 active 2/5 (authentication failure) 0 bytes
Nov 10 15:35:54.702 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Receive NOTIFICATION 2/5 (authentication failure) 0 bytes
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active bad state change from Closing to Closing
Nov 10 15:35:54.702 MET: -Traceback= 21B3370Cz 21B33C74z 21B34258z
Nov 10 15:35:54.702 MET: BGP: tbl IPv4 Unicast:base Service reset requests
Nov 10 15:35:54.702 MET: BGP: tbl IPv6 Unicast:base Service reset requests
Nov 10 15:35:54.702 MET: BGP: tbl VPNv4 Unicast:base Service reset requests
Nov 10 15:35:54.702 MET: BGP: tbl VPNv6 Unicast:base Service reset requests
Nov 10 15:35:54.702 MET: BGP: tbl IPv4 Multicast:base Service reset requests
Nov 10 15:35:54.702 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x296337B4:0) NSF delete stale NSF not active
Nov 10 15:35:54.702 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x296337B4:0) NSF no stale paths state is NSF not active
Nov 10 15:35:54.702 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x296337B4:0) Resetting ALL counters.
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active closing
Nov 10 15:35:54.702 MET: BGP: ses global FE80::1%ATM0/0/0.1 (0x296337B4:0) act Session close and reset neighbor FE80::1%ATM0/0/0.1 topostate
Nov 10 15:35:54.702 MET: BGP: nbr_topo global FE80::1%ATM0/0/0.1 IPv6 Unicast:base (0x296337B4:0) Resetting ALL counters.
Nov 10 15:35:54.702 MET: BGP: FE80::1%ATM0/0/0.1 active went from Closing to Idle
Nov 10 15:35:54.702 MET: %BGP_SESSION-5-ADJCHANGE: neighbor FE80::1%ATM0/0/0.1 IPv6 Unicast topology base removed from session  BGP Notification sent
CE_HOSTNAME#

Cisco Employee

Re: Link Local BGP peering between Cisco and Juniper (M-Series)

Stefan,

From where I'm sitting I would so this.

1) Start stripping down and being verify specific when enabling features (say enabled IPv6 but only unicast and not multicast).

I.e. use only basic features and enable them one by one.

2) You can try config similar to this:

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor FE80::1 remote-as 65002

neighbor FE80::1 dont-capability-negotiate ! this is hidden command

neighbor FE80::1 version 4

no auto-summary

!

address-family ipv6

  neighbor FE80::1 activate

exit-address-family

That's not healthy in the long run ;-)

Marcin

Community Member

Re: Link Local BGP peering between Cisco and Juniper (M-Series)

Hi Marcin,

in the end the solution was way more simple and obvious than I thought.

I tried using different connections (ATM/Ethernet), different routers(M40/M320), different IOS and JunOS...

First I got it working with Ethernet and JunOS11.2, then I downgraded JunOS step by step and it was still working.

But not on the ATM link. So this "must" be an ATM interface issue on JunOS? Unlikely...

The solution came to my mind, when I tried to set the Cisco site passive... nothing happened any longer on both sites.

Why is the Juniper router not trying to reach it's neighbor? Let's get back to basic pings....

Lucky I copied the interface string from the routing-instance:

> ping fe80::2 interface at-2/0/0.119

ping: at-2/0/0.119: invalid interface name

D'Oh!! Couldn't be!!!

But it was really only a typo in the interface name

Correcting the interface string to at-2/2/0.119 and commiting:

Nov 11 00:55:34.846 MET: %BGP-5-ADJCHANGE: neighbor FE80::1%ATM0/0/0.1 Up

:megaselffacepalm:

But many thanks for your assistance!

Case closed!

11984
Views
0
Helpful
6
Replies
CreatePlease to create content