Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco IM & Presence 9.1 login issue - Cisco XCP Router service

Hi all,

For our client we are setting up an environment with IM & Presence (9.1) servers. This week, users are enjoying features provided by jabber clients (for windows, iphone, android ecc..).

Since i set up IM & Presence cluster i've never had any issue, but today i suddenly noticed a login issue on publisher node.

I've configured two IM & Presence servers, one Publisher and one Subscriber in cluster. IM & Presence cluster is integrated with CallManager 9.1.2 cluster, and callmanager is synchronized with active directory. Also user authentication is challenged against active directory.

Here a brief description of IM & Presence Cluster Topology:

- two im & presence nodes (publisher and one subscriber)

- im & presence users balanced over this two nodes

For subscriber node, everything work fine. I have login issue, for all users placed on publisher (jabber client display error message: Unable to connect the server). If i move one user from publisher to subscriber login works without problem.

Anyway if i restart Cisco  XCP Router service  (on publisher node), i don't have login issue anymore.

Can you tell me if it's a known bug or something missconfigured ?

thanks for your help!

marco

  • Jabber Clients
3 REPLIES
Bronze

please check if you are

please check if you are receiving notification for core dumps in the cups publisher.Also check if there is a excessive memory utilization being carried out by any service. RTMT will be helpful in identifying the same.

 

New Member

Hello Amit,i have performed

Hello Amit,

i have performed those checks but no alert received.

we are performing some test and noticed what is the real cause of unsuccessful login. Here a brief description of the problem observed:

- jabber client (for windows, for iphone, for mac) can login successful
 

- ADIUM client installed on a user's mac laptop
 

- as soon as ADIUM client sends request using port 5222 the login process on Publisher node of IM & Presence crashes (no alert received)
 
- we have publisher login working fine  if restarting Cisco XCP Router service

- this scenario happens regardless the Routing Communication Type configuration

 

So i can confirm problem is due to ADIUM client requests generated . Still cannot understand the right solution to apply

regards
marco

New Member

I tried PIDGIN client and no

I tried PIDGIN client and no issues found, so i'm going to suggest that to customer.

Now opened a cisco TAC for the strange behaviour when ADIUM try connection to IM & Presence server.

regards

marco

245
Views
0
Helpful
3
Replies