Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Jabber Chat Archive

Further to a discussion on saving the jabber history file, which I marked as solved, Im still having problems.

 

I have tried to follow the official guides on setting up the external database and the compliance, but it fails every time.

Nothing is being populated in the database, the message archiver service doesn't start and the Compliance goes back to not archived.

 

Steps from previous post below......

 

I have built a Windows 2008r2 server and put PostgreSQL on it.

I then opened Cisco Unified Presence Admin.

Went to messaging > External Server Setup > External Databases

Entered the DB Properties.

On the external database status the top one is ticked, its pingable, but the bottom one is not. It says Unable to execute the connectivity test because this external database server is not mapped to either the Message Archiver or Persistent Chat services.

When I go to messaging > Compliance, select message Archiver, I can select my new DB in the drop down. But when I save the screen just goes blank and nothing happens.

Any help appreciated....

Steve.

Everyone's tags (3)
2 REPLIES
New Member

Hey Steve,  This doesn't

Hey Steve, 

This doesn't really answer your question for PostgreSQL, but we got this to work using a Oracle database. We had to setup two separate table spaces for the pub / sub for it to connect properly. I figured I'd at least let you know Oracle worked for us. 

New Member

Update... If I select

Update... If I select Persistent chat and assign my DB to a node, it populates my DB. So the DB must be OK and the connection must be OK.

But the DB setup page still says it cant connect..

The following CUP node to external database server connection(s) failed:

  • IMP01 >> tcmadb (Persistent Chat)

But when I try to assign the DB to a node on the message archiver page, it fails. The screen just goes blank and doesn't come back and the DB remains empty.

Maybe Ill try Oracle next week....

 

Steve.

 

666
Views
0
Helpful
2
Replies
CreatePlease login to create content