Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Jabber for iPad issues

Hi all

I have been testing the new 1.0 Client for the last few days and have some results below, will be interested to hear if others experience these?

I am also interested if the Cisco BU looks at these posts or is there another forum I should be posting in? I guess TAC is the official channel for this but I am running a POC for a large Bank and it is not in production at this stage.

1. After 10mins or so the iPad will go to sleep and the TAB device on CUCM will unregister and you cannot call it from another device, if I log back in and switch to the app it will register again and I am about to call the device and make calls etc.

2. If the app is running and I disconnect from the wireless wait for it to unregister then reconnect to wifi again, the app will not automatically reconnect to CUCM and register, switching to the app also doesn't work as it will sit there saying 'Reconnecting', I have to kill the app completely and relaunch it for it to connect again.

3. I am not able to manually adjust the LDAP AD fields to use the ipPhone field in AD, it will only see the telephoneNumber field and mobile etc, i have tried to set the custom field on the device page on CUCM and in Presence with no luck.

Also have some other issues but they are currently known limitations

a. If the device is locked, you need to put in the passcode before answering the call (as with iPhone)

b. There is no CTI control of this device from TAPI or JTAPI (as with iPhone)

Environment is:

CUCM 7.1.5

CUPS 8.6.4

Still need to gather problem reports to gather the logs to see what is happening.

Any comments and feedback appreciated

Cheers

Andy

Everyone's tags (3)
19 REPLIES
VIP Purple

Jabber for iPad issues

I've been wondering the same thing, since the Jabber for iPad app contains different elements from several areas of the support forums.  Makes you wonder if you should post in the iPad area or the dedicated area for the devices the iPad is connecting to. 

I am also interested if the Cisco BU looks at these posts or is there another forum I should be posting in? I guess TAC is the official channel for this but I am running a POC for a large Bank and it is not in production at this stage.

I've noticed this as well, I'm running the app using the TelePresence functions connected to our VCS.  I watched the registrations on the server and my registration appeared again only after I unlocked and started the Jabber app.  Once launched I can return to the home screen, and can call it as normal.  However after a period of time if you lock the iPad it unregisters from the server.

1. After 10mins or so the iPad will go to sleep and the TAB device on CUCM will unregister and you cannot call it from another device, if I log back in and switch to the app it will register again and I am about to call the device and make calls etc.

I haven't seen this as of yet, but probably because I'm always inside our building connected to wifi, I'll keep an eye on it though.

2. If the app is running and I disconnect from the wireless wait for it to unregister then reconnect to wifi again, the app will not automatically reconnect to CUCM and register, switching to the app also doesn't work as it will sit there saying 'Reconnecting', I have to kill the app completely and relaunch it for it to connect again.

I've seen this, I did a call to my iPad just today and it was ringing, but I couldn't answer it right away.  I had to take precious time to bring up the lock screen, enter my passcode, etc.

a. If the device is locked, you need to put in the passcode before answering the call (as with iPhone)

Our environment is as follows:

TMS - User accounts

VCS - Call Control

Hope this helps.  Patrick

New Member

Jabber for iPad issues

Thanks for the quick reply Patrick

I will update anything I find over the next few weeks of testing also.

Cheers

Andy

New Member

Re: Jabber for iPad issues

Hi,

We are also facing the point 3 issue mentioned below can anyone pls assist ?

3. I am not able to manually adjust the LDAP AD fields to use the ipPhone field in AD, it will only see the telephoneNumber field and mobile etc, i have tried to set the custom field on the device page on CUCM and in Presence with no luck.

      

Thanks

Aditya

VIP Purple

Jabber for iPad issues

abyronin - Have you been able to find anything more out after more testing, I keep seeing the same results I noted above.

New Member

Jabber for iPad issues

Still an issue with testing and have logged a TAC case, the wifi shutting down when the device sleeps, they have a bug id for that open with Apple.

CSCub14854 however you won't see much on this until resolved.

Cheers

Andy

New Member

Jabber for iPad issues

May I ask if you have got any reply from Cisco on this one?

I have the same problem. The screen locks, and within a few minutes it unregisters from the VCS-E. Allthough, in the settings-page I've set it to "Never sign out".

Possibly there's nothing to do with this.. I guess it all depends on a policy on the iPad.

Running TMS 13.2.1, VCS-C X7.2 and VCS-E X7.2.

New Member

Re: Jabber for iPad issues

We have resolved the issue by making default search setting on CUP....

New Member

Re: Jabber for iPad issues

I think your first point isn that your iPad is set to go to sleep fter 10 minutes of idle time. When this happens Jabber is de-registering from whatever server it is connected to. I think that you can changesystem settings to keep the iPad running but dim or turnoff the display after a longer period but not hybernate. Anytime you have to swip the screen or put in your pin, the iPad has gone into deep sleep and the keepalives to CUCM or the other apps stops.

Sent from Cisco Technical Support iPad App

New Member

Jabber for iPad issues

Yepp, and that's the core of the issue. My iPad is set to hibernate after 15 minutes idle time, but I'm thinking of keeping the registration alive despite the hibernation. Although, this is an iOS-issue that'll we just have to live with

New Member

Jabber for iPad issues

Hi Guys,

I have problem with Jabber for iPad.

When I did video call from Jabber for iPad to Cisco IP Phone 9971, the 9971 get stuck and reset.

I cannot make a call from jabber for iPad to Cisco IP Phone 9971. But when I disabled the video, the connection ran as usual.

Is there anybody can tell me what is the problem ?

My CUCM version is 8.6.2

Presence version is 8.5.4

Thank you for attention.

New Member

Re: Jabber for iPad issues

Andree - I have the same exact  issue. Everytime a call is placed from an Ipad to our 9971/9951 phones, I  get 5 seconds of video then the Cisco device reboots. When I make an  Ipad to Ipad call, the call connects but the video isnt there (blank  screen). I believe this to be a codec problem but have yet to find the  appropriate setting that fixes this issue.

My CUCM version 8.6.1.2

My Presence version 8.6.1.1

updated - andree i just found in the release notes that the SIP profile for the 9971 needs to be version 9-2-3-27, I am currently 9-2-1 I will try to update and see if that works.

New Member

Jabber for iPad issues

Andree,

We are running the 9-2-2 load on our 9971 phones and are not having any problems.

New Member

Re: Jabber for iPad issues

Updating my 9971s to the latest firmware solved these issues.

Are you guys able to make a video call between the ipad jabber and cuva+7975?

The voice works fine, but i get one way video. Video is fine on the ipad side, a dark screen shows on the cuva side. Please note that cuva to windows jabber works fine.

Thanks.

Sent from Cisco Technical Support iPad App

New Member

Re: Jabber for iPad issues

Check your Regions and bandwidth in CUCM, Its all about the codec support for video. Make sure your max video call rate is set to 768kbps for video and use 64 kbps (G.722, G.711) as your codecs for all your offices if you have more than one. G729 is not supported for Jabber for IPad.

http://www.cisco.com/en/US/docs/voice_ip_comm/jabber/iPad/Release_notes/output/b_release_notes.html#concept_7AA081059A90402A9E4DB7A0558D6FA5


Also in CUCM 8.6, Under SYSTEM> LOCATION> you need to make sure you are providing enough bandwidth to all of your offices. Apparently 680kbps is a good average for each Jabber call with Video. If you choose Unlimited and the bandwidth is not available you will have video issues cutting out as well.


If you use Anyconnect to make a VPN connection to your private network via ASA device, make sure you specify a rule to direct Video and Voice to use DTLS. These are some of problems we incurred and resolved.

Also make sure to upgrade phone software if you are using 8000 or 9000 series phones to at least 9.2.2. Jabber Documentation specifies 9.2.3 or higher.


CUCM 8.62

WebEx Connect 7.2 for Presence and IM.

Good Luck!

New Member

Jabber for iPad issues

Hi Oren,

Your guide is great. The IP Phone work well now.

Thanks

New Member

Re: Jabber for iPad issues

We have faced the same things 1,2.
CUCM - 8.6.2
CUPS - 8.6.3
There are no same issues on previous version of Jabber for IPad - 9.1. But I can't revert to 9.1.

Sent from Cisco Technical Support iPad App

New Member

Re: Jabber for iPad issues

This issue will probably never go away. You simply need to restart the APP every so often, or it seems every time you use it... Try ON Demand VPN via ASA; it takes away steps from the messy process of restarting the Jabber APP all the time and seems to keep the device running longer before sleep mode. I am curious to try it on an Android device, but they haven’t really completed the app yet. It’s an issue with battery power on the IPhone, IPad. The restriction was added in IOS5 I believe and there is no fix in sight. If you have any new info please post it.

CUCM 8.62

Jabber 9.1.2

Webex Connect 7.22

New Member

Re: Jabber for iPad issues

Yes, probably, the main reason is power saving in iOS. I've tried disable all power saving options in iOS for a night. Everything was OK with Jabber. Jabber has not been disconnected from the servers and, therefore, there are no reconnections. But this is the Jabber's issue as well. Earlier, in ver. 9.1, I did not remember such reconnections.

Sent from Cisco Technical Support iPad App

New Member

Jabber for iPad issues

Hi,

One of my customer is having the same issue, Jabber gets unregsitered when ipad goes to sleep mode due to inactivity and they are not able to receive calls. I've read through the post but still not sure what to tell them.

The Bug CSCub14854 mentioned above says:

"*Waiting on a bug fix from Apple

Apple bug ID 11897952 - wifi drops to cellular when phone locked, causes VoIP app to miss incoming calls"

Should I just tell them to disable all power saving options just like mentioned tin the previous post ?

Saima

4642
Views
5
Helpful
19
Replies