Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Jabber for Windows Can't Login

Hi,

I have Jabber for Windows 9.6.1 and IM and Presence Server 9.1.1. The problem is it says it cannot communicate with the server upon logging in. But if I typed a wrong username / password it says "Your username and password is not correct." Has anyone experienced this? I cannot open a TAC case because this is a demo only. Hope someone can help.

Thank you.

12 REPLIES
New Member

Pretty much no matter why

Pretty much no matter why Jabber can't connect, it'll say wrong username and password.  Server down? Wrong username and password.  Port blocked on firewall?  Wrong username and password.  "User licensed for Unified IM and Presence" option not selected in CUCM?  User not assigned to a cluster in CUPS? Wrong username and password.  Wrong username and password?  Wrong username and password.

The troublehsooting steps are basically what I've put out there.  Make sure the Jabber ports are open, make sure the server is available, make sure that the CUCM user has a license applied for IM and presence, make sure the user is assigned to a node in CUPS, and finally, make sure the username and password are right.

 

New Member

Hi geguy,

Hi geguy, 1. Server is up. Both CUCM and IMP. 2. Port not blocked. This is on the same subnet. 3. But, Jabber for Android is already working. License is a demo license downloaded from the Cisco Licensing site. 4. Same answer in #3. 5. The test username is Levy with a device ID of CSFLEVY. Password is 1012 which is set in the End Users of CUCM.
New Member

Based from the Jabber for

Based from the Jabber for Windows Server Setup Guide, LDAP needs to be integrated to CUCM. That is the first step in the guide. Do I need this for it to work? I'm only using internal CUCM database since this is a demo only.

How about DNS? From the forums, some say that it requires DNS to be set-up. I don't have DNS either.

New Member

If we take a step back it

If we take a step back it sounds like you're trialling this with the bare minimum of supporting infrastructure and you're falling short of requirements in one or more areas.  Not having DNS is a fairly grave situation for any number of reasons and is likely a show stopper here.  Are you trying to POC this or something?  If you're trying to go live with this I suggest there's a lot of work to do and you need to come back to this when it's done...

New Member

Yes, this is a POC. The

Yes, this is a POC. The customer still doesn't have DNS and AD. So I guess I'l just have to tell them that these are the requirements.

 

Thanks.

New Member

Hi,Have you solved?I've  the

Hi,

Have you solved?

I've  the same problem :(

Cisco Employee

From nature of the issue and

From nature of the issue and that too over 9.6; to me it more looks like a certificate issue; since jabber for windows 9.2.5 onwards certificates play an important role in granting access to the cups node; so if there is an issue wiht the certificates being presented ; you may be running into the similar situation. A detailed problem report from jabber will have more information on it.

 

Long story short; try to see if you can get the jabber for windows 9.2.4 or below version connected; if this works you know certificates may be the cause of the connectivity issue.

 

to learn more about what certificates does jabber use you may try the following link;

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jabber/Windows/9_2_5/JABW_BK_CAAD3F25_00_cisco-jabber-for-windows-release-notes/JABW_BK_CAAD3F25_00_cisco-jabber-for-windows-release-notes_chapter_00.html

 

-hth

 

New Member

Hi amitk3, installed 9.1.0.

Hi amitk3, installed 9.1.0. Still the same result. The username is Levy with Device ID of CSFLEVY, password of 1012 which is defined in End Users. If I type Levy and 1012 in the username and password fields, it says "Unable to communicate with the server". If I type CSFLEVY and 1012, it says "Invalid username/password". If I also type Levy2 and 1012, it says "Invalid username/password". So basically, it already recognizes the credentials that I type.

Cisco Employee

So heres what you may want to

So heres what you may want to check; on the cups admin page;

-> goto System\ cluster topology and click the subcluster name and in the right hand pane check if the cups node that you are trying to connect to is it an mentioned with ip address / hostname or FQDN.

 

-> If this is any thing other than IP address; then you need to make sure that you are able to get that name ( hostname\FQDN) resolved into ip address though DNS.

 

-> If they dont have a DNS for a quick test you can try to goto to the windows PC ; click start\run\drivers\ etc\ open the "hosts" file and put

 

ipaddress     hostname ; click save this file ; from cmd check if ping can resolve this hostname\fQDN and then attempt reconnect.

 

this will get you the idea if you will need a DNS record to get this working.

 

The way jabber for windows work is that if you have named the server with like a hostname or FQDN you need to make sure that you give the same information in the connection settings; and ensure that its getting resolved ; you can still mention an ip address but you will still need to get the resolution working from FQDN.

 

-hth

 

New Member

I have a similar problem.  I

I have a similar problem.  I have two production clusters that I support.

The first in running CUCM 8.6(2), without IM & Presence, and the second is running CUCM 9.1(2) with Presence 9.1(1).

The two clusters are georgrapphically dispersed, but are in the same domain.  I've built a lab environment simulalating the first cluster, which is soon to be upgraded.  As part of the upgrade, IM & Presence server will be added.  EVentally, the two clusters will be able to Jabber each other.  At present, we use WebEx Connect.

The lab environment has a CM, Unity, and a IM &P server.  The License manager has been set up and a copy of my production licenses have been converted to CUWL, and are installed in the test environment.  The lab envrionment is installed w/o DNS, and all servers are a) referenced by IP address, and b) on the same subnet.

My CM links to LDAP are complete, and I can see all of my AD users in CM, Unity, and IM&P.

Additionally, I have configured a local user in CM.  I have both a local user and an AD user configured to a phone in an unused range. These two users are active and enabled.

I've created CSRs for the IM&P server and CM, and have imported my private CA certs as well as certs for tomcat,cups-xmpp, and ipsec.  As far as I can tell, the required services are up.

For Jabber, I'm currently playng with 10.5.0 for Windows.When I attempt to login I'm told the username or is incorrect.

 

Check Active Directory

Check Active Directory settings for a user. There is a place where you can define where the users can log-on to:

Anonymous
N/A

Hi,

Hi,

i believe since you are not using DNS you need to point jabber to IM&P server where your user are assigned to. on jabber client go to advanced settings, select  IM&P client ,select use this server and add your server's ip address. 

Thanks,

Ahmed 

16521
Views
0
Helpful
12
Replies
CreatePlease to create content