Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Jabber for Windows / iPhone - issue with photo and search

Dear community,

I have an issue regarding Cisco Jabber for Windows as well as iPhone & iPad.

I recently upgraded our Call Manager infrastructure from 8.6.5 to 10.0. Along with that, I wanted to rollout the new Jabber for Windows (9.7.2) because now we use a very old version (9.2.1).

After I upgraded my test client, I noticed that the user photos (which are retrieved from active directory) were gone.

So for the first time, I decided to modify the the jabber-config.xml (I attatched the two different versions).

I used the jabber config generator to create the new version: https://supportforums.cisco.com/document/106926/jabber-config-file-generator

My attempt is to achive these goals:

1) I want one config file which is working with Jabber for Windows, iPhone & iPad, Android as well as Jabber for Mac

2) I want a secure connection from the client to our directory server

3) I want to retrieve the user photos from the active directory user (attribute thumbnailPhoto)

4) Jabber should find only users which are a member of the active directory group "example" (example is a nested group which contains several users and at least _one_ other group). Until now, the whole active directory was searched for users/contacts.

 

So far, 1) and 2) seems to work fine. 3) and 4) are the troublemakers and I really don't no why.

 

Can somebody help me?

 

Best regards,
René

4 REPLIES
New Member

Okay, now it works at least

Okay, now it works at least for Jabber for Windows.

First of all, I had to remove _all_ directory specific configuration from the jabber-config.xml!

Then I had to revise the "Service Profile Configuration" in CUCM.

After I unchecked "Use UDS for Contact Resolution" everything worked like a charm.

I will try to find out if I can solve this for Jabber for iPhone/Android/Mac as well.

 

New Member

Okay, I've got it working.

Okay, I've got it working.

New Member

how?

how?

New Member

Look at this thread. You can

Look at this thread. You can find the answer there.

https://supportforums.cisco.com/discussion/12241391/ldap-contacts-and-photos-jabber-ipad-iphone-and-android-not-working


First I had to uncheck "Use UDS for Contact Resolution" and then I had to create a new jabber-config.xml and upload it to the TFTP server.

 

But there are a few limitations you have to deal with. But I have mentioned that in the other thread.

733
Views
0
Helpful
4
Replies
CreatePlease login to create content