Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Jabber on MAC - Added Contact Problem

Hi All UC Experts,

 

CM 9.1.2

IM& Presence 9.1.1

Jabber on MAC 9.6

Jabber on Windows 9.7

 

As my Jabber on MAC and iPhone, that is look like working, I'm using the EDI to search the LDAP contacts and I can search the LDAP users and click to call, but I cannot add the LDAP contacts as the Jabber contacts, even I view the added members from Jabber on Windows, that just showed the IM address only, but that is working fine about the Jabber on Windows.

1. Why I just can see the IM address on the added members and I cannot add the LDAP users as the Jabber contacts. (That is working fine when I tick the UDS searching on the CUCM UC Service Directory <-- but that will make the Jabber on Windows lookup the LDAP losing some users)

2. Why that is no photo (Windows AD sAMAccountName), but the Jabber on Windows can show up the photo.

3. Is it possible for me to turn on the EDI and USD searching both?

10 REPLIES
Cisco Employee

Have you properly configured

Have you properly configured the BDI directory in the jabber-config.xml??

#3, No, only one can be enabled for each directory integration. Either EDI/UDS for J4W, or BDI/UDS for non J4W clients. One set of clients cannot use both options at the same time.

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

That mean I cannot use the

That mean I cannot use the EDI as the inside and use the UDS as the outside? It is because I'm planing to deploy the Expressway for VPN-less Jabber. As I know that is not support the EDI at outside VPN-less Jabber .... but my UDS would not show the entire company contacts, so I prefer use the EDI as the inside and UDS as the outside ...

Hi Edwin,You can integrate

Hi Edwin,

You can integrate CUCM and LDAP with EDI for Windows devices and BDI for Apple devices, if you post your jabber-config.xml file I can help you.

Regards.

New Member

Thanks Emmanuel,This is the

Thanks Emmanuel,

This is the jabber-config.xml

<config version="1.0">
<Options>
<DockedWindowPosition>TopRight</DockedWindowPosition>
</Options>
<Phone>
<DeviceAuthenticationPrimaryServer>192.168.30.1</DeviceAuthenticationPrimaryServer>
<DeviceAuthenticationBackupServer>192.168.30.2</DeviceAuthenticationBackupServer>
<TftpServer1>192.168.30.1</TftpServer1>
<TftpServer2>192.168.30.2</TftpServer2>
<CtiServer1>192.168.30.1</CtiServer1>
<CtiServer2>192.168.30.2</CtiServer2>
<CcmcipServer1>192.168.30.1</CcmcipServer1>
<CcmcipServer2>192.168.30.2</CcmcipServer2>
</Phone>
<Policies>
<InitialPhoneSelection>deskphone</InitialPhoneSelection>
</Policies>
<Presence>
<PresenceServer>192.168.40.1</PresenceServer>
<PresenceServerAddress>192.168.40.2</PresenceServerAddress>
</Presence>
<Directory>
<PresenceServer>192.168.40.1</PresenceServer>
<PrimaryServerName>192.168.20.1</PrimaryServerName>
<BDIPrimaryServerName>192.168.20.1</BDIPrimaryServerName>
<ServerPort1>389</ServerPort1>
<BDIServerPort1>389</BDIServerPort1>
<UseWindowsCredentials>0</UseWindowsCredentials>
<ConnectionUsername>ciscouc@abc.deflocal</ConnectionUsername>
<BDIConnectionUsername>voice.uc@abc.def.local</BDIConnectionUsername>
<ConnectionPassword>ciscoucpass</ConnectionPassword>
<BDIConnectionPassword>ciscoucpass</BDIConnectionPassword>
<SearchBase1>DC=abc,DC=def,DC=local</SearchBase1>
<BDISearchBase1>DC=abc,DC=def,DC=local</BDISearchBase1>
</Directory>
</config>

New Member

Dear Emmanuel,I am using the

Dear Emmanuel,

I am using the below jabber-config.xml, that is working fine on the MAC and the iPhone, but the Windows lost the contacts' photo (b4 jabber-config.xml is work the photo on Windows)

Actually, I am using the Windows AD and the photo is using the Windows attribute.  

<UseWindowsCredentials>0</UseWindowsCredentials>  <--- Should I modify as "1"? related the photos?

<PhotoUriWithToken>http://webserver.local/photos/sAMAccountName.jpg</PhotoUriWithToken>  <--  I am not the Web server to load the photos. How can I add that

 

 

<config version="1.0">
<Options>
<DockedWindowPosition>TopRight</DockedWindowPosition>
</Options>
<Phone>
<DeviceAuthenticationPrimaryServer>192.168.30.1</DeviceAuthenticationPrimaryServer>
<DeviceAuthenticationBackupServer>192.168.30.2</DeviceAuthenticationBackupServer>
<TftpServer1>192.168.30.1</TftpServer1>
<TftpServer2>192.168.30.2</TftpServer2>
<CtiServer1>192.168.30.1</CtiServer1>
<CtiServer2>192.168.30.2</CtiServer2>
<CcmcipServer1>192.168.30.1</CcmcipServer1>
<CcmcipServer2>192.168.30.2</CcmcipServer2>
</Phone>
<Policies>
<InitialPhoneSelection>deskphone</InitialPhoneSelection>
</Policies>
<Presence>
<PresenceServer>192.168.40.1</PresenceServer>
<PresenceServerAddress>192.168.40.2</PresenceServerAddress>
</Presence>
<Directory>
<DirectoryServerType>BDI</DirectoryServerType>
<BDIPrimaryServerName>192.168.20.1</BDIPrimaryServerName>
<BDIPresenceDomain>domain.com</BDIPresenceDomain>
<BDIServerPort1>389</BDIServerPort1>
<BDIConnectionUsername>voice.uc@abc.def.local</BDIConnectionUsername>
<BDIConnectionPassword>ciscoucpass</BDIConnectionPassword>
<BDIUserAccountName>sAMAccountName</BDIUserAccountName>
<BDIBusinessPhone>telephoneNumber</BDIBusinessPhone>
<BDISearchBase1>DC=abc,DC=def,DC=local</BDISearchBase1>
<BDIPhotoUriSubstitutionEnabled>true</BDIPhotoUriSubstitutionEnabled>
<BDIPhotoUriSubstitutionToken>sAMAccountName</BDIPhotoUriSubstitutionToken>
</Directory>
<Directory>
<DirectoryServerType>EDI</DirectoryServerType>
<PrimaryServerName>192.168.20.1</PrimaryServerName>
<ServerPort1>389</ServerPort1>
<UseWindowsCredentials>0</UseWindowsCredentials>
<ConnectionUsername>voice.uc@abc.def.local</ConnectionUsername>
<ConnectionPassword>ciscoucpass</ConnectionPassword>
<BusinessPhone>telephoneNumber</BusinessPhone>
<SearchBase1>DC=abc,DC=def,DC=local</SearchBase1>
<PhotoUriSubstitutionEnabled>true</PhotoUriSubstitutionEnabled>
<PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>
</Directory>
</config>

Hi Edwin,Can you change all

Hi Edwin,

Can you change all your directory integration lines with the lines below because there are some parameters missing,

For Apple devices:

<Directory>

 <DirectoryServerType>BDI</DirectoryServerType>

 <BDIPrimaryServerName>192.168.20.1</BDIPrimaryServerName>

 <BDIPresenceDomain>domain.com</BDIPresenceDomain>

 <BDIServerPort1>389</BDIServerPort1>

 <BDIConnectionUsername>voice.uc@abc.def.local</BDIConnectionUsername>

 <BDIConnectionPassword>ciscoucpass</BDIConnectionPassword>

 <BDIUserAccountName>sAMAccountName</BDIUserAccountName>

 <BDIBusinessPhone>ipPhone</BDIBusinessPhone>

 <BDISearchBase1>DC=abc,DC=def,DC=local</BDISearchBase1>

 <BDIPhotoUriSubstitutionEnabled>true</BDIPhotoUriSubstitutionEnabled>

 <BDIPhotoUriSubstitutionToken>sAMAccountName</BDIPhotoUriSubstitutionToken>

 <BDIPhotoUriWithToken>http://webserver.local/photos/sAMAccountName.jpg</BDIPhotoUriWithToken>

</Directory>

<Directory>

<DirectoryServerType>EDI</DirectoryServerType>

<PrimaryServerName>192.168.20.1</PrimaryServerName>

<ServerPort1>389</ServerPort1>

<UseWindowsCredentials>0</UseWindowsCredentials>

<ConnectionUsername>ciscouc@abc.deflocal</ConnectionUsername>

<ConnectionPassword>ciscoucpass</ConnectionPassword>

<BusinessPhone>ipPhone</BusinessPhone>

<SearchBase1>DC=abc,DC=def,DC=local</SearchBase1>
<PhotoUriSubstitutionEnabled>true</PhotoUriSubstitutionEnabled>

<PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>

<PhotoUriWithToken>http://webserver.local/photos/sAMAccountName.jpg</PhotoUriWithToken>

</Directory>

 

You are mixing BDI and EDI lines and you are not specifying wich is the directory type.

If you have doubts please let me know and if it was useful please rate.

Regards.

New Member

Dear Emmanuel,I am using the

Dear Emmanuel,

I am using the below jabber-config.xml, that is working fine on the MAC and the iPhone, but the Windows lost the contacts' photo (b4 jabber-config.xml is work the photo on Windows)

Actually, I am using the Windows AD and the photo is using the Windows attribute.  

<UseWindowsCredentials>0</UseWindowsCredentials>  <--- Should I modify as "1"? related the photos?

<PhotoUriWithToken>http://webserver.local/photos/sAMAccountName.jpg</PhotoUriWithToken>  <--  I am not the Web server to load the photos. How can I add that

 

 

<config version="1.0">
<Options>
<DockedWindowPosition>TopRight</DockedWindowPosition>
</Options>
<Phone>
<DeviceAuthenticationPrimaryServer>192.168.30.1</DeviceAuthenticationPrimaryServer>
<DeviceAuthenticationBackupServer>192.168.30.2</DeviceAuthenticationBackupServer>
<TftpServer1>192.168.30.1</TftpServer1>
<TftpServer2>192.168.30.2</TftpServer2>
<CtiServer1>192.168.30.1</CtiServer1>
<CtiServer2>192.168.30.2</CtiServer2>
<CcmcipServer1>192.168.30.1</CcmcipServer1>
<CcmcipServer2>192.168.30.2</CcmcipServer2>
</Phone>
<Policies>
<InitialPhoneSelection>deskphone</InitialPhoneSelection>
</Policies>
<Presence>
<PresenceServer>192.168.40.1</PresenceServer>
<PresenceServerAddress>192.168.40.2</PresenceServerAddress>
</Presence>
<Directory>
<DirectoryServerType>BDI</DirectoryServerType>
<BDIPrimaryServerName>192.168.20.1</BDIPrimaryServerName>
<BDIPresenceDomain>domain.com</BDIPresenceDomain>
<BDIServerPort1>389</BDIServerPort1>
<BDIConnectionUsername>voice.uc@abc.def.local</BDIConnectionUsername>
<BDIConnectionPassword>ciscoucpass</BDIConnectionPassword>
<BDIUserAccountName>sAMAccountName</BDIUserAccountName>
<BDIBusinessPhone>telephoneNumber</BDIBusinessPhone>
<BDISearchBase1>DC=abc,DC=def,DC=local</BDISearchBase1>
<BDIPhotoUriSubstitutionEnabled>true</BDIPhotoUriSubstitutionEnabled>
<BDIPhotoUriSubstitutionToken>sAMAccountName</BDIPhotoUriSubstitutionToken>
</Directory>
<Directory>
<DirectoryServerType>EDI</DirectoryServerType>
<PrimaryServerName>192.168.20.1</PrimaryServerName>
<ServerPort1>389</ServerPort1>
<UseWindowsCredentials>0</UseWindowsCredentials>
<ConnectionUsername>voice.uc@abc.def.local</ConnectionUsername>
<ConnectionPassword>ciscoucpass</ConnectionPassword>
<BusinessPhone>telephoneNumber</BusinessPhone>
<SearchBase1>DC=abc,DC=def,DC=local</SearchBase1>
<PhotoUriSubstitutionEnabled>true</PhotoUriSubstitutionEnabled>
<PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>
</Directory>
</config>

Hi Edwin,

Hi Edwin,

<UseWindowsCredentials>0</UseWindowsCredentials> 

This parameter is for specify the username and password for the LDAP integration and not for obtain the avatar, 

PhotoUriWithToken>http://webserver.local/photos/sAMAccountName.jpg</PhotoUriWithToken>

Your jabber-config.xml doesn´t include this parameter, maybe your avatar in Apple devices is the contact photo that you add manually.

This parameter is for specify the Windows PC where the avatar is located, do you have a local webserver?

Additonal can you post a screenshot of status of the LDAP integration? You can obtain it from Jabber client, under help option select "show connection status"

Regards.

New Member

The Connection Status look

The Connection Status look like normally.

Hi,Your screenshot shows that

Hi,

Your screenshot shows that you LDAP is correctly integrated, you have to check the access to avatars, do you have a local web server?

If not you can enable the IIS Service from LDAP server and upload a .jpeg picture with 128 x 128 px to the inetput/wwwroot folder that was created, then check the access like this:

http://x.x.x.x/user.jpg

Where x.x.x.x is your local web server or IIS from LDAP.

            user is sAMAccountName format, for example if edwin.cfleung is your LDAP user the picture will called edwin.cfleung.jpg 

When the access is working you have to add this line to jabber-config.xml:

For Windows EDI directory,

<PhotoUriWithToken>http://x.x.x.x/sAMAccountName.jpg</PhotoUriWithToken>

For Apple BDI directory,

<BDIPhotoUriWithToken>http://x.x.x.x/sAMAccountName.jpg</BDIPhotoUriWithToken>

Then restart TFTP Service on CUCM and test again.

Regards. 

396
Views
0
Helpful
10
Replies
CreatePlease to create content