Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Jabber pulling wrong URI

Recently I configured CUCM and IM&P to enable SIP dialing.  In doing so, Jabber is pulling the email address as the SIP URI for users which is using the wrong domain.  When attempting to call a contact from Jabber, the list shows mbaker@domain1.com when it should show mbaker@domain2.com.  

 

I thought it was because I hadn't configured the msRTCSIP-PrimaryUserAddres entry in ASIEdit.  I configured this on my account, and when I go to the user account in CUCM, it shows the Directory URI correctly, however, Jabber is still showing the wrong domain.

 

Any ideas?

2 REPLIES
Cisco Employee

Did you refer to the

Did you refer to the following link;

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jabber/Windows/9_6/JABW_BK_C94DCBD1_00_server-guide/JABW_BK_C94DCBD1_00_server-guide_chapter_0111.html#CJAB_TK_E28C6E1E_00

 

there are two important things to be noted here;

 

-> the version of the call manager should be 9.1.2 and higher.

Also in order to enable Cisco Jabber to resolve contacts with URIs, you must ensure that Cisco Unified Communications Manager uses the fully qualified domain name (FQDN) in SIP requests.

 

from the above mentioned link can you check if you are meeting the requirement as mentioned in the following section of the document;

 

"Enable FQDN in SIP Requests for Contact Resolution"

 

i hope this helps.

New Member

Mark,You need at least CUCM 9

Mark,

You need at least CUCM 9.1.2 for it to work with Jabber:

 

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jabber/Windows/9_6/JABW_BK_C94DCBD1_00_server-guide/JABW_BK_C94DCBD1_00_server-guide_chapter_0111.html#CJAB_TK_E28C6E1E_00

 

Try the following:

Exit Jabber completily (File>Exit)

Delete the follwing directories:

C:\Users\<your user>\Application Data\ Roaming\Cisco\Unified Communications\Jabber

C:\Users\<your user>\AppData\Local\Cisco\Unified Communications\Jabber

Open Jabber again and check the user that has Directory URI correct in CUCM.

You can try restarting Sync Agent afterhours in the CUP server too, to make sure CUPS is updating its user database correctly.

 

527
Views
0
Helpful
2
Replies
CreatePlease to create content