Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Login failure

Hi everyone,

We were using jabber for Windows beta version 9.0.0 and everyone was able to login. We upgraded to version 9.0.2 and now, our clients on Win7 OS cannot login. The clients installed in WinXP machines login OK.

From the Reporting option on the jabber client i can see the following:

dapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Enter CXmppClientMgr::SignOn

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppClient::SignOn  AccountName:nb15057@uc.novabase.lab,Host:LABSRVUCCUPS01,Port:-1,WebEx-Token:******, token type:2,version:9.0.2

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppClient::Connect ,begin to connect to server

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppPresence::Init

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppClient::Connect , connecting to server by TCP connection......

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppClient::onStreamEvent ,CXmppClient::onStreamEvent, SessionState_Connecting

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Enter CSinkXmppClient::OnLocalStateChange

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Leave CSinkXmppClient::OnLocalStateChange

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: Connect result is:1

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Leave CXmppClientMgr::SignOn

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppPresence::AddCustomStatus , custstatus:128

2012-06-22 09:35:57,906 INFO  [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(33)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppPresence::SetCapability , nCapability:14,bEnabled:0

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Enter CXmppClientDoc::OnLocalStateChange

2012-06-22 09:35:57,906 INFO  [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(33)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: CXmppClientDoc::OnLocalStateChange  state=0

2012-06-22 09:35:57,906 INFO  [0x000011c4] [s\adapters\imp\components\Client.cpp(31)] [csf-unified.imp.PresenceAdapter] [IMPStackCap::Client::OnLocalStateChanged] - Client::OnLocalStateChange to: 0

2012-06-22 09:35:57,906 INFO  [0x000011c4] [s\adapters\imp\components\Client.cpp(35)] [csf-unified.imp.PresenceAdapter] [IMPStackCap::Client::OnLocalStateChanged] - Client::OnLocalStateChange exit

2012-06-22 09:35:57,906 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Leave CXmppClientDoc::OnLocalStateChange

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppSDK.dll]: CXmppClient::onDisconnect ,ConErrorCode:1028

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Enter CSinkXmppClient::OnSignOn

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Leave CSinkXmppClient::OnSignOn

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Enter CXmppClientDoc::OnSignOn

2012-06-22 09:35:57,984 INFO  [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(33)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: CXmppClientDoc::OnSignOn  result=1028

2012-06-22 09:35:57,984 INFO  [0x000011c4] [s\adapters\imp\components\Client.cpp(44)] [csf-unified.imp.PresenceAdapter] [IMPStackCap::Client::OnSignOn] - Client::OnSignOn: 1028 in[ms]

2012-06-22 09:35:57,984 INFO  [0x000011c4] [s\adapters\imp\components\Client.cpp(48)] [csf-unified.imp.PresenceAdapter] [IMPStackCap::Client::OnSignOn] - Client::OnSignOn exit

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: login, OnSignOn, auto-reconnect: 1, result:1028

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: CLoginIM::OnSink, reason:1028, bReconnect:1

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: CLoginContext::ChangeState now:0 auto:1

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: conn, next attempt. count:8, remain:4294967287, delta:0, initial-interval:10

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [LoginMgr.dll]: conn, timer, seconds:10

2012-06-22 09:35:57,984 DEBUG [0x000011c4] [ied\featuresets\adapters\imp\Log.cpp(32)] [JabberWerx] [IMPStackCap::Log::log] - [XmppMgr.dll]: Leave CXmppClientDoc::OnSignOn

The line in bold is not present in the XP clients that are able to login.

Anyone can help?

Thanks

Everyone's tags (3)
8 REPLIES

Login failure

Hi Francisco,

Problem report indicates that it is a CUP deployment. Can you try the following:

  • Get the host name of the CUP server that you are connecting to (NOT just the IP address).
  • Add an entry into the client machine host file  (C:\Windows\System32\drivers\etc\hosts) that maps the host name to the  IP address. (Make sure that the editor you use is launched with admin  privileges)
  • Restart Jabber and try to login.

If this works then the issue is related to the hostname information  missing in DNS. Configure the CUP server hostname entry on the DNS  server to resolve the problem

Thanks,

Maqsood

Login failure

Thanks for the reply Maqsood,

Unfortunately, the problem persists. Any other suggestion?

Thanks

Login failure

Hi Francisco,

Since you were on an un-supported pre FCS build before the upgrade, I will suggest to delete all folders under following locations and retry.

  • C:\Users\nb15057\AppData\Roaming\Cisco\Unified Communications
  • C:\Users\nb15057\AppData\Local\Cisco\Unified Communications

If login still fails then I will forward the problem report to the Jabber for Windows presence team for further investigation.

Thanks,

Maqsood

Login failure

Thanks for all the help Maqsood,

Finally made it work, changing the CUPS server host name to IP address under the presence administration cluster topology and reseting Config Manager and Router Services under Presence Serviceability.

Cisco Employee

Login failure

Hey Francisco,

The reason that worked is because the node name of the cups server needs to resolvable on the users PC's also.

- Colin

New Member

Re: Login failure

Hi Guys

I am still not able to login after delete all folder at following location.

  • C:\Users\username\AppData\Roaming\Cisco\Unified Communications
  • C:\Users\username\AppData\Local\Cisco\Unified Communications

I added the CUPS host entry to my win7 host file. able to ping the CUPS FQDN under CMD.

Jabber still stuck on "connecting". win 7 64 bit enterprise. Jabber version 9.0.3.

Yuke

Cisco Employee

Re: Login failure

Hey Yuke,

I think at this stage, you should open a TAC case and get someone assigned to looking into the issue. i believe it may be an issue on the server side.

Thanks,

- Colin

New Member

Re: Login failure

Hi Colin

I believe change the host name to ip address would solve the issue. or join my notebook to that Jabber domain would be helpful as well.

I have another set of testing system, change the hostname to ip, login without any issue, and the OS does not need to be part of AD domain.

1336
Views
5
Helpful
8
Replies