Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Photo URL in jabber-config.xml file

Hello all,

 

I am trying to figure out how to retrieve contact photos from a webserver.

https://abc.domain.com/sAMAccountName_MThumb.jpg

 

So I set these few paremeters in the jabber-config.xml file, but it is not working. Jabber client can't get photos.

   <PhotoUriSubstitutionEnabled>true</PhotoUriSubstitutionEnabled>
   <PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>
   <PhotoUriWithToken>https://abc.domain.com/sAMAccountName_MThumb.jpg</PhotoUriWithToken>

 

From the installation guide, I notice the sample what the document provides is to use sAMAccountName.jpg. So I am not sure if it still works if I combine the token with a suffix.

 <Directory>
   <DirectoryServerType>EDI</DirectoryServerType>
   <PrimaryServerName>1.1.1.1</PrimaryServerName>
   <ServerPort1>3268</ServerPort1>
   <SecondaryServerName>2.2.2.2</SecondaryServerName>
   <ServerPort2>3268</ServerPort2>
   <OtherPhone>ipPhone</OtherPhone>
   <BaseFilter>(&amp;(objectCategory=person))</BaseFilter>
   <SearchBase1>ou=xxx, dc=domain, dc=com</SearchBase1>
   <PhotoUriSubstitutionEnabled>true</PhotoUriSubstitutionEnabled>
   <PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>
   <PhotoUriWithToken>https://abc.domain.com/sAMAccountName_MThumb.jpg</PhotoUriWithToken>
 </Directory>

Anyone ever made it working?

 

Thanks,

WeiHan

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Its this defectCSCun10808

Its this defect

CSCun10808

4 REPLIES
Bronze

there is a need to recontruct

there is a need to recontruct the URL from what it looks like; as it does not seem that jabber is attempting to appropiately replace the sAMAccountName value. In order to proceed further you will need to take wireshark where you can clearly see what jabber thwors as a request for the photo URL fetch; most probably this is going to move with a 404 not found error message.

New Member

Thanks Amit. I did some

Thanks Amit.

 

I did some sniffer and notice Jabber inteprete the URL wrongly so it tried to access a wrong URL.

For example,  the correct URL should be:

/User%20Photos/Profile%20Pictures/sAMAccountName_MThumb.jpg

but it is trying to access:

/User%2520Photos/Profile%2520Pictures/sAMAccountName_MThumb.jpg

 

I think Jabber doesn't regonize the % charater? I tried use both space and %20 in the URL but got the same issue.

 

Checking with TAC to see is this something should be fix from Cisco side.

 

Regards,

WeiHan

Cisco Employee

Its this defectCSCun10808

Its this defect

CSCun10808

New Member

I would like to give an

I would like to give an update for the issue.

We can work around the %20 with just the original space. Another issue for this setting not to be working is the authentication from the server side. Jabber doesn't support it.

862
Views
0
Helpful
4
Replies