Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unable to Communicate with the Server - Jabber 9.7 and CUCM /IMP 10

Hey Guys,

 

I have a frustrating problem with Jabber. I have configured a new CUCM 10 and IMP environment, all looks good, with no system errors. I also configured a very basic jabber-conf file which basically just states to use UDS as the Directory source.

Have configured a CSF device in CUCM and associated to an enduser. Then applied the Jabber service profile. UNder the assigned Users page, I can see my user is assigned.

I'm working with an internal and external domain name. (.local and .com)

So I created my _cisco-uds SRV record and _cuplogin SRV record for lab.com pointing to A record cucm.lab.local. I have a dns server with two zones configured.

My laptop is not associated to any Windows Domain.

My configured IM presence domain is lab.com and Im using USERID@defaultdomain.  Under Domains in IMP I can see the lab.com is present.

I have restarted all necessary services on IMP.

I then install Jabber 9.7 on my Win7 laptop.

I run a packet trace and try to login into Jabber. Now I see the SRV request and response for cisco-uds is fine.. I then see communication flow between the laptop and CUCM server fine.. I get prompted to validate the CUCM cert (self signed). Click ok to proceed, then I see my laptop starting to talk with the IM&P server, then am prompted to validate the IMP server cert (again self seigned). Click ok to proceed. The I receive the "cannot communicate with the server" error.

 

I turn to my CSF Log files and see an Authentication error 15 in the log:

IMPStackCap::Login::OnLoginError] - OnLoginError: (data=0) LERR_JABBER_AUTH <15>: Authentication error with server e.g. resource bind, TLS, create session or SASL error

This is where I get too..

Some further settings that you may want to know

service parameters:

CUCM Domain is lab.local

SRV Cluster: presence.lab.local

 

Enduser:

Directory URI is ben.morgan@lab.com

IM Address is bmorgan@lab.com

 

LDAP Authentication is enabled.

 

Jabber Login:

bmorgan@lab.com

 

Any suggestions or assistance is much appreciated.

Also if you could advise on how to trace Jabber Logon event in RTMT that would be helpful

 

Thanks

Ben

 

9 REPLIES
New Member

Checkreachability between

Check

reachability between laptop to IM server

whether you have firewall between them

check presence engine services is running or not

 

 

New Member

Yes, can definitely reach the

Yes, can definitely reach the IM server, can ping by name etc and receive the cert warning for IM.

No firewall between me the IM Server

Have restarted the Presence Engine a few times.. but is running.

 

Thanks for you response, do you have any further suggestions.

 

Ben

New Member

kindly provide traces of

kindly provide traces of jabber which will be located in below path in your laptop

C:\Users\(your user id)\AppData\Local\Cisco\Unified Communications\Jabber\CSF\Logs

userid which you used to login in laptop

AppData will be display only, you make show hidden files (press alt->tools->options)

 

New Member

Have uploaded the csf log.

Have uploaded the csf log.

 

Have just tried with an ipad.. and exact same problem. get the cucm validate cert, then get the IM Server validate cert.. then cannot locate server error..

New Member

Delete cisco folder which is

Delete cisco folder which is in local and roaming and try to login in again

check unassigned user is displaying in presence server

system->cluster topology

uncheck enable high availability and restart presence engine and try to login

New Member

mate, I ended up rebooting

mate, I ended up rebooting the IM Server and all is working. Cant believe I didnt try that first.

 

Thanks for your help

A full server reboot fixed my

A full server reboot fixed my issue also. I don't get why I had to do this and how does a reboot fix this issue. 

New Member

Sorry userid is bmorgan

Sorry userid is bmorgan@uplinks.com.au

I have attached the trace from IMP Server, Presence Engine. FYI

New Member

LERR_JABBER_AUTH <17> in your

LERR_JABBER_AUTH <17> in your jabber.log can also indicate that you have an invalid URI scheme.  If you do advanced settings in IM&P and create an invalid URI in AD for the mail, although it will push it won't allow you to log in.  You can only see this using the troubleshooter.

4750
Views
9
Helpful
9
Replies
CreatePlease to create content