Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VCSC Presence works with MOVI 4.2, but not 4.3. But it works with the VCSE

Good evening,

I have run into an issue with a VCSC. For some reason, Presence information doesnt seem to reach any MOVI client registered to the VCSC. The odd part of it is it is just specific to Jabber client 4.3 and greater. When I register the same client to the VCSE, it registers fine.

Has anyone else ran into this? I just blew away the majority of the config and rebuilt it, but the issue still remains.

Aside from just the presence information, all other calling works on the VCSC.

Any help to narrow this one down would be greatly appreciated.

D.

14 REPLIES

VCSC Presence works with MOVI 4.2, but not 4.3. But it works wit

Darren,

Does the jabber report any error when it doesn't get the presence information like error code 403 or any thing else.

Its odd if its not working only with jabber.?

Check the provisioning directory. while defining the server URI'sI did you explicitly mentioned any movi/jabber version.

Also a diagnostic logs on VCS will help to get more information about the presence issue.

Thanks

Alok

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

So there is no error from the client itself.

The uri for presence has not changed. I did load the specific template for 4.3 and 4.4 to TMS and defined specific presence uri's in hopes that would correct this, but it did not.

I will load the diag log to this post shortly.

Sent from Cisco Technical Support iPad App

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

Here is the diagnostic log for a couple mins. I connected a jabber 4.4 client, tried to do a search, etc.

http://dl.dropbox.com/u/13288057/diagnostic_log_2012-04-13_13_07_28.txt

Thanks for looking into this, Alok.

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

Hi Darren,

I would have prefered if you can open a TAC case on this for further troubleshooting.

However just to give a hint i see the 200OK for presence event so it should have worked.

Apr 13 07:07:08 prd-vcsc-01 tvcs: UTCTime="2012-04-13 13:07:08,697" Module="network.sip" Level="INFO":  Dst-ip="10.0.1.200"  Dst-port="56599"   Detail="Sending Response Code=200, Method=PUBLISH, To=sip:test1.user1@video.poynt.com, Call-ID=3484905ee6f3aba2@10.0.1.200"

Apr 13 07:07:08 prd-vcsc-01 tvcs: UTCTime="2012-04-13 13:07:08,697" Module="network.sip" Level="DEBUG":  Dst-ip="10.0.1.200"  Dst-port="56599"

SIPMSG:

|SIP/2.0 200 OK

Thanks

Alok

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

That s what I see too. There is no sound reason why it is not working.

And it only effects 4.3 clients and newer.

I will open a ticket shortly.

Sent from my Android phone using TouchDown (www.nitrodesk.com)

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

Hi Darren,

Same here. Could you keep us informed about the TAC Case?

Thanks,

Tino

Sent from Cisco Technical Support iPhone App

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

Tino,

I definitely will keep you updated on the ticket.

D.

Sent from Cisco Technical Support iPad App

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

Hi,

Could you try to remove the templates and try as a default. I got the same problem and I solved with no template using;-)

Sent from Cisco Technical Support iPad App

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

Good thought! I pulled all the templates off of TMS provisioning directory. Unfortunately, the issue still occurs.
D.
New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

Hi Darren,

have you been able to solve this issue with TAC?

thanks

Tino

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

No, I was not.

There is some account thing that is not allowing me to work with Cisco TAC to resolve the issue (Equipment was purchased through OnX, while my company, igniteCSG (we are a Cisco partner, as well) provides services and support).

So, I am taking it up with Cisco services to figure out how this can be done.

And the issue is still occurring.

Darren

New Member

Re: VCSC Presence works with MOVI 4.2, but not 4.3. But it works

I'm seeing the same behaviour with Movi 4.2 working but Movi 4.3/4.4 not working. Attempting to get a TAC case open as well for the issue.

New Member

VCSC Presence works with MOVI 4.2, but not 4.3. But it works wit

Hi,

Any news from the TAC? The same problem here. If someone know the solution, please, post it here.

Thank you in advance.

New Member

VCSC Presence works with MOVI 4.2, but not 4.3. But it works wit

We've had quite similar issue with VCS-C and VCS-E (X7.1) scenario.

VCS-C is the registering clients against the AD, but all clients has to be proxied from the VCS-E to the VCS-C.

VCS-E has no DNS Zone with any matching SearchRule (therefore there is another VCS-E in this scenario).

Presence was also only working if we used JabberVideo client 4.2 and/or clients were directly registered to VCS-C (which is not allowed in our scenario).

After diagnostic log analyzes, we've noticed the difference between working and not working cases:

Working

Contact: IP_ADDRESS_CLIENT:2524;transport=tls>

Non-working

Contact: DOMAIN;gr=urn:uuid:xyz>

After that we've recognized, SIP GRUU function makes the difference.

http://tools.ietf.org/html/rfc5627

It seems that the 4.2 client ignores or breaks the GRUU function offer from VCS and the new clients are ready to deal with it.

In consequence we've deactivated SIP GRUU Mode on VCS-C by entering:

xConfiguration SIP GRUU Mode: Off

Result: we've got also running PresenceStatus for JabberVideo clients >4.2  (mainly tested with Version 4.7).

1240
Views
0
Helpful
14
Replies