シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
告知
シスコ サポート コミュニティへようこそ!あなたの ご意見 をお聞かせください。
New Member

Catalyst2960Sでのtotal output drops発生対策(QoS)

Catalyst2960Sを200M光からメタル(LAN)のメディアコンバータの代わりとして利用しています。

メタル側は100Mfull設定×2でEtherChannelを組んでいますが、このインタフェースでtotal output dropsが

多量に発生してしまいました。緊急度の高い通信のロストさせないようにするため,QoSで優先させたい

のですが、どのポイントでかけるのがよいでしょうか?

4 件の返信
New Member

Catalyst2960Sでのtotal output drops発生対策(QoS)

「EtherChannel:200Mbps」「WAN回線:200Mbps」なので、添付の構成図から見ても理論上はボトルネックはないように見えます。

"このインタフェースでtotal output dropsが" とありますが、これはEtherChannelインターフェース(Po1)でしょうか?それともEtherChannelを構成する物理インターフェースのことでしょうか?

また、EtherChannelの形成方法(PAgP/LACP/on)や負荷分散方式は何を採用されていますでしょうか?

構成図だけ見ると2960SでQoS(Queueing)の設定をすれば良いように見えますが、場合によってはWANに出るためのルータ(ルーティングポイント)で優先制御&帯域制御を設定した方が良い場合もあります。

要件(やりたいこと)やトラフィックの種類、2960SのConfig(一部だけでも可)も同時に添付/書き込みしていただけると、皆さんから的確なアドバイスがもらえると思います。

以上、よろしくお願いします。

New Member

Catalyst2960Sでのtotal output drops発生対策(QoS)

早速のご回答ありがとうございます。

「EtherChannel:200Mbps」「WAN回線:200Mbps」なので、添付の構成図から見ても理論上はボトルネックはないように見えます。

=>私もそう考えておりましたが、実際はEtherChannelを構成している片側の物理インタフェースでtotal output dropsが発生しています。

EtherChannelの形成方法はonにしており、ロードバンランスの方式としてsrc-dst-ipを使用していますが、均等にトラフィックが分散されず(7:3)になっています。

構成図だけ見ると2960SでQoS(Queueing)の設定をすれば良いように見えますが、場合によってはWANに出るためのルータ(ルーティングポイント)で優先制御&帯域制御を設定した方が良い場合もあります

=>諸事情により優先制御&帯域制御は2960Sでしか設定できない状況です。

設定の一部ですが以下になります。

mls qos

!

port-channel load-balance src-dst-ip

!

vlan AAA

!

class-map match-all BBB

match access-group 101

!

policy-map bbb

class BBB

set dscp ef

!

interface Port-channel1

switchport access vlan AAA

switchport mode access

!

interface GigabitEthernet1/0/1

///LAN

switchport access vlan AAA

switchport mode access

speed 100

duplex full

priority-queue out

channel-group 1 mode on

!

interface GigabitEthernet1/0/2

///LAN

switchport access vlan AAA

switchport mode access

speed 100

duplex full

priority-queue out

channel-group 1 mode on

!

interface GigabitEthernet1/0/3

///WAN//

switchport access vlan AAA

switchport mode access

priority-queue out

!

access-list 101 permit ip host A host B

access-list 101 deny   ip any any

no cdp run

よろしくお願いします。

New Member

Re: Catalyst2960Sでのtotal output drops発生対策(QoS)

追加の詳細情報を拝見しました。

あまり詳しくありませんが、小生の考えを記載させていただきます。

 

>私もそう考えておりましたが、実際はEtherChannelを構成している片側の物理インタフェースでtotal output dropsが発生しています

入力キュー、出力キューのどちらのtotal output dropsでしょうか?

その他にはエラーやDropはカウントされていませんか?(LANケーブルを交換してみるとか、ONUの問題も考えられます。)

 

>EtherChannelの形成方法はonにしており、ロードバンランスの方式としてsrc-dst-ipを使用していますが、均等にトラフィックが分散されず(7:3)になっています。

基本的なことで申し訳ないですが、対向機器とSpeed,Duplex,Access/Trunk,PAgP/LACP/on といった各種設定は一致していますでしょうか? PAgPやLACPで形成すると問題は解消したりしませんか?

比率は必ずしも1:1にならないと思います。分散の詳細仕様は非公開だったと認識しております。

コンフィグからは以下のことを実現したいように見えます。(間違ってたらごめんなさい・・・)

1.Catalyst2960Sでクラス分け&マーキング(EF付与)

2.EFマーキングなのでデフォルトでは出力キュー1に入る

3.出力キュー1を絶対優先キューとして処理させる。

まず、1.ですが、service-policyコマンドは物理I/Fにしか適用できなかったと記憶しています。

EtherChannelを構成するGi1/0/1,Gi1/0/2にはコマンドは入ると思いますが、Po1として正常に動作するかは不明です。

よってWAN側からの入力時に適用した方が良いのではと考えます。

次にpriority-queue outコマンドですが、こちらも物理I/Fにしか適用できなかったと記憶しています。

priority-queue out が適用された物理I/FでEtherChannelを組んだことがないので、なんとも言えませんが、場合によってはEhterChannel形成時(Po1がUpするタイミング)にエラーが出力されるかもしれません。

エラーなしでI/FがUpするなら問題ないとは思いますが、QoS的にはEFでマーキングされたパケットが格納されるキュー1を絶対優先キューとしているので、これ以上は追加設定はないのではと考えます。

そもそもボトルネックのない構成なので、ソフトウェア処理であるQoS(最近はASICで処理かもしれませんが・・・)で回避するよりも、他の問題も疑った方が良いかもしれません。

後は、他の有識者の方々の返信を待たれるか、Cisco TACへ問い合わせするか、"エキスパートに質問"のコーナーに投稿された方がよろしいかと思います。

ご検討のほどよろしくお願いします。

【追記】

自分で少々検証してみましたので結果をご連絡します。

>まず、1.ですが、service-policyコマンドは物理I/Fにしか適用できなかったと記憶しています。

>EtherChannelを構成するGi1/0/1,Gi1/0/2にはコマンドは入ると思いますが、Po1として正常に動作するかは不明です。

>よってWAN側からの入力時に適用した方が良いのではと考えます。

物理I/Fに適用してEtherChannelを形成することは可能でした。

LAN側(EtherChannel側)でクラス分け&マーキングする場合はEtherChannelの物理I/FにService-Policyを適用することで動作します。

>priority-queue out が適用された物理I/FでEtherChannelを組んだことがないので、なんとも言えませんが、場合によってはEhterChannel形成時(Po1がUpするタイミング)にエラーが出力されるかもしれません。

物理I/Fにpriority-queue outコマンドを投入した状態でEtherChannelを問題なく形成することができました。

ただし、priority-queue out はPo1のコンフィグにはコピーされません。動作としては恐らく問題なく動作していると思います。

Re: Catalyst2960Sでのtotal output drops発生対策(QoS)

こんにちは。

各 Catalyst2960-S の WAN 側インターフェース(1/0/3)でマーキングを行い、 LAN 側インターフェース(1/0/1-2)で priority-queue out を設定し、優先制御を行うのがベターかと思います。

例)
interface GigabitEthernet1/0/3
///WAN//
switchport access vlan AAA
switchport mode access
service-policy input bbb

Etherchannel で対応できれば理想なのですが、ご認識のとおり(また Cja 様からのご指摘のとおり)、必ずしも均等に分散されません。

(ネットワーク構成にもよりますが、頂いた情報から推測するとおそらく困難です。)

ご参考になれば幸いです。

6119
閲覧回数
5
いいね!
4
返信
作成コンテンツを作成するには してください