キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
告知
シスコ サポート コミュニティへようこそ!あなたの ご意見 をお聞かせください。
New Member

CISCO892Jのvrf設定を使用したWANとFEスイッチについて

892JのWAN側を広域イーサに接続し、VRF機能を用いて3系統のネットワークを通します。

またそれぞれのVRFへのアクセスをFEスイッチそれぞれのみ通信可能なように設定したいのですが

どのようなコマンド設定を用いればよいのでしょうか?

ip vrf 10

rd 10:1

route-target export 10:1

route-target import 10:1

!

ip vrf 20

rd 20:1

route-target export 20:1

route-target import 20:1

!

ip vrf 30

rd 30:1

route-target export 30:1

route-target import 30:1

としたときに、下記のようにしたいです。

interface GigabitEthernet0.10への接続は、FE2

interface GigabitEthernet0.20への接続は、FE3

interface GigabitEthernet0.30への接続は、FE4

タグ(2)
1 件の受理された解決策

受理された解決策
New Member

Re: CISCO892Jのvrf設定を使用したWANとFE

以下のような認識でよいですか。

      +----+

---FE2|    |

---FE3|892J|GE0---

---FE4|    |

      +----+

FE2からの通信がGE0.10へ抜ける。(vrf10)

FE3からの通信がGE0.20へ抜ける。(vrf20)

FE4からの通信がGE0.30へ抜ける。(vrf30)

上記の認識で良ければ、

例えば、以下のような設定をすれば良いと思います。

!

vrf definition vrf10

rd 10:1

!

address-family ipv4

exit-address-family

!

vrf definition vrf20

rd 20:1

!

address-family ipv4

exit-address-family

!

vrf definition vrf30

rd 30:1

!

address-family ipv4

exit-address-family

!

interface FastEthernet2

switchport access vlan 10

!

!        

interface FastEthernet3

switchport access vlan 20

!

!

interface FastEthernet4

switchport access vlan 30

!

!

interface GigabitEthernet0

no ip address

duplex auto

speed auto

!

!

interface GigabitEthernet0.10

vrf forwarding vrf10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface GigabitEthernet0.20

vrf forwarding vrf20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

!

interface GigabitEthernet0.30

vrf forwarding vrf30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

!

interface Vlan10

vrf forwarding vrf10

ip address 10.10.10.1 255.255.255.0

!

!

interface Vlan20

vrf forwarding vrf20

ip address 20.20.20.1 255.255.255.0

!

!

interface Vlan30

vrf forwarding vrf30

ip address 30.30.30.1 255.255.255.0

!

!

route-target の設定は経路をimport/exportしたいときのみ必要なので、

vrfを使って、ただ単にrouting tableを分けたいだけなら必要はないと思います。

上の例では ip vrf ではなくて、vrf definition を使っていますが、

ipv4 のvrfだけであれば ip vrf でも問題ないと思います。

*ipv6 等も使う場合は vrf definition を使う必要があります。

ip vrf の設定を使う場合は、I/Fの設定も ip vrf forwarding を使う必要があったと思います。

1 件の返信
New Member

Re: CISCO892Jのvrf設定を使用したWANとFE

以下のような認識でよいですか。

      +----+

---FE2|    |

---FE3|892J|GE0---

---FE4|    |

      +----+

FE2からの通信がGE0.10へ抜ける。(vrf10)

FE3からの通信がGE0.20へ抜ける。(vrf20)

FE4からの通信がGE0.30へ抜ける。(vrf30)

上記の認識で良ければ、

例えば、以下のような設定をすれば良いと思います。

!

vrf definition vrf10

rd 10:1

!

address-family ipv4

exit-address-family

!

vrf definition vrf20

rd 20:1

!

address-family ipv4

exit-address-family

!

vrf definition vrf30

rd 30:1

!

address-family ipv4

exit-address-family

!

interface FastEthernet2

switchport access vlan 10

!

!        

interface FastEthernet3

switchport access vlan 20

!

!

interface FastEthernet4

switchport access vlan 30

!

!

interface GigabitEthernet0

no ip address

duplex auto

speed auto

!

!

interface GigabitEthernet0.10

vrf forwarding vrf10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface GigabitEthernet0.20

vrf forwarding vrf20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

!

interface GigabitEthernet0.30

vrf forwarding vrf30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

!

interface Vlan10

vrf forwarding vrf10

ip address 10.10.10.1 255.255.255.0

!

!

interface Vlan20

vrf forwarding vrf20

ip address 20.20.20.1 255.255.255.0

!

!

interface Vlan30

vrf forwarding vrf30

ip address 30.30.30.1 255.255.255.0

!

!

route-target の設定は経路をimport/exportしたいときのみ必要なので、

vrfを使って、ただ単にrouting tableを分けたいだけなら必要はないと思います。

上の例では ip vrf ではなくて、vrf definition を使っていますが、

ipv4 のvrfだけであれば ip vrf でも問題ないと思います。

*ipv6 等も使う場合は vrf definition を使う必要があります。

ip vrf の設定を使う場合は、I/Fの設定も ip vrf forwarding を使う必要があったと思います。

2473
閲覧回数
0
いいね!
1
返信