Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1700 router factory reset

Hi-

I've got a Cisco 1720 router that I need to factory reset. I can connect to the console using hyperterminal (9600, 8N1). I reboot the router using the switch, then ctrl+break. I'm given a rommon 1> prompt. However, I can't seem to type the necessary confreg 0x2102

I've even tried turning on echo.

Any ideas???

THANK YOU

1 ACCEPTED SOLUTION

Accepted Solutions
bjw Silver
Silver

Re: 1700 router factory reset

Cool,

I was starting to feel a little dumb up to this point. I'm glad it worked out... Rate if I helped

11 REPLIES
bjw Silver
Silver

Re: 1700 router factory reset

New Member

Re: 1700 router factory reset

Thanks for taking the time to reply!

I saw that link already. The problem is that when I'm at that first rommon 1 prompt, I can't seem to type anything.

I assumed it was a local echo problem, so I tried just entering confreg 0x142 (and others) followed by return. Nothing happens.

bjw Silver
Silver

Re: 1700 router factory reset

What happens when you type confreg and hit enter?

And are you at rommon1> or > prompt

New Member

Re: 1700 router factory reset

this is at the rommon 1 > prompt. Nothing happens with confreg. See detailed post below.

bjw Silver
Silver

Re: 1700 router factory reset

New Member

Re: 1700 router factory reset

I've tried just confreg [enter]

Nothing appears at the rommon 1 > prompt and no settings are displayed on screen. Just to make sure that I was still connected, I did another ctrl+break and get:

rommon 1 >

*** Reserved LVL 7 Interrupt ***

PC = 0xfff0b9c0, Vector = 0x500, SP = 0x80004de4

So I'm connected, but it doesn't seem like my other keystrokes are getting to the router when in rommon 1 >

If I let the device boot without ctrl+breaking, I am prompted for the username and password. I can type these in and the characters appear on screen.

bjw Silver
Silver

Re: 1700 router factory reset

I'll have to mull this a bit. If you're sure that Hyperterm is setup right (i.e. confirm it by accessing another Cisco Box console port)8 N 1 no flow control, then you may have corrupt ROM issues. The bottom line is that without rommon 1 interaction, you have no method of forcing base maintenance actions. And the only failed rommon issues I have ever run across are called into TAC and the subject unit replaced.

New Member

Re: 1700 router factory reset

I'm going to give this a try on another 1700 router that we're going to have to do this on anyway. I'll get right back with you.

Thanks

New Member

Re: 1700 router factory reset

I HATE HYPERTERMINAL and appologize for wasting your time. I tried using MTTTY, configured the same way 9600,8,n,1 no flow, and viola, confreg works.

Thank you so much for working through this with me.

bjw Silver
Silver

Re: 1700 router factory reset

Cool,

I was starting to feel a little dumb up to this point. I'm glad it worked out... Rate if I helped

New Member

Re: 1700 router factory reset

All of the dumness is on me. And you didn't just help, you solved.

Thanks

869
Views
10
Helpful
11
Replies
CreatePlease login to create content