Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

1721 router configuration

Hi,

I have the 1721 router IOS-12.3

I want to use it as a home router (connected to cable modem with no dialer, I have a legal IP).

Can someone point me to a link where I can find the IOS commands to build this configuration (Ethernet0 connected to the CM; DHCP client and the FastEthernet0 is connected to a hub with DHCP server).

Thanks in advance,

Tamir

10 REPLIES
New Member

Re: 1721 router configuration

If you are doing NAT, then the first one is more likely to help. If you aren't, then the second one will probably help:

http://www.parkansky.com/tutorials/dmz.htm

New Member

Re: 1721 router configuration

Hello Dan,

Thanks for your quick reply.

I've read the article that you?ve sent me ? THANKS!

I don?t think that this is my problem.

I need a link that will show me an example of the ?running configuration? that is similar to mine.

I?ve managed to build most of the configuration, but still it doesn?t work.

I?m getting an IP from my ISP (to the Cisco) but there is no internet connection to the LAN.

Thanks again for the help,

Best Regards,

Tamir

New Member

Re: 1721 router configuration

Hi,

Let me get this straight first... this is like DSL connection right?

so your topology would look like this...

pc---switch---router 1721---cable modem---internet is this your setup?

so you need to establish PPPoE on the router side... I hope I got this and just e-mail me if this is not the case...

http://www.cisco.com/en/US/partner/tech/tk175/tk15/technologies_configuration_example09186a0080093fbf.shtml

hth

New Member

Re: 1721 router configuration

Hi,

First, Thanks for the help.

The connection is Cable Modem (CM).

There is no dialer needed since It?s connected to the internet automatically without any dialer (right now, there is a switch connected to the CM)

The topology is exactly as you mentioned.

I need to establish a connection with NAT and DHCP server.

Thanks in advance,

Tamir

New Member

Re: 1721 router configuration

Is it possible you can post a sanitized copy of your config so far?

Re: 1721 router configuration

I have not practically tried it but what I think is we have to configure E0 to get a DHCP address /dynamic Ip from cable modem and have 1721 run as a DHCP server for local Lan. Then we have to configure NAT on 1721 to publically route the traffic.

Conf t

interface e0

ip address dhcp -> check if that command works in your IOS.

ip nat outside

int fa 0

ip nat inside

Please check the link below and it will colve your problem:

http://www.cisco.com/en/US/tech/tk86/tk89/technologies_configuration_example09186a0080094be1.shtml

HTH, Please rate if it does.

-amit singh

New Member

Re: 1721 router configuration

Cisco1721#show running-config

Building configuration...

Current configuration : 1283 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco1721

!

boot-start-marker

boot-end-marker

!

enable password ...

!

no aaa new-model

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.0.50 192.168.0.100

!

ip dhcp pool 1

network 192.168.0.0 255.255.255.0

default-router 192.168.0.254

!

!

no ip domain lookup

ip cef

no scripting tcl init

no scripting tcl encdir

!

!

!

!

interface Ethernet0

description connected to Internet

ip address dhcp

ip nat outside

half-duplex

!

interface FastEthernet0

description connected to EthernetLAN

ip address 192.168.0.254 255.255.255.0

ip nat inside

speed auto

!

router rip

version 2

passive-interface Ethernet0

network 192.168.0.0

no auto-summary

!

ip nat translation timeout 4194

ip nat translation tcp-timeout 4194

ip nat inside source list 1 interface Ethernet0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0

no ip http server

!

!

access-list 1 permit 192.168.0.0 0.0.0.255

snmp-server community public RO

snmp-server location Home

snmp-server enable traps tty

!

control-plane

!

!

line con 0

exec-timeout 0 0

password 7 071B325C1C514C53444359

login

line aux 0

line vty 0 4

password 7 111D0A15454A5E5A577B79

login

!

!

end

Cisco1721#

Cisco1721#show version

Cisco IOS Software, C1700 Software (C1700-Y-M), Version 12.3(2)XE, EARLY DEPLOYM

ENT RELEASE SOFTWARE (fc1)

Synched to technology version 12.3(3.5)T

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by Cisco Systems, Inc.

Compiled Wed 19-Nov-03 01:11 by ealyon

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

ROM:

Cisco1721 uptime is 3 minutes

System returned to ROM by power-on

System image file is "flash:c1700-y-mz.123-2.XE.bin"

Cisco 1721 (MPC860P) processor (revision 0x300) with 55208K/10328K bytes of memo

ry.

Processor board ID FOC080513KA (471973549), with hardware revision 0000

MPC860P processor: part number 5, mask 2

1 Ethernet interface

1 FastEthernet interface

32K bytes of NVRAM.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Cisco1721#

Cisco1721#show interfaces

Ethernet0 is up, line protocol is up

Hardware is PQUICC Ethernet, address is 000d.28db.ff21 (bia 000d.28db.ff21)

Description: connected to Internet

Internet address is 84.109.17.38/22

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10BaseT

ARP type: ARPA, ARP Timeout 04:00:00

.

.

.

.

FastEthernet0 is up, line protocol is down

Hardware is PQUICC_FEC, address is 000f.23da.d263 (bia 000f.23da.d263)

Description: connected to EthernetLAN

Internet address is 192.168.0.254/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 198/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Unknown duplex, Unknown Speed, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes

Re: 1721 router configuration

there is some connectivity problem between routers fastethernet0/0 interface and switch connectivity.thats why line protocol is down.plz. try changing the cable between the router and the switch interface and make sure that you are using a straight-through cable for the connectivity.

HTH,

-amit singh

New Member

Re: 1721 router configuration

Hi Amit,

Thanks for the reply.

I'm using a straight-through cable.

There was a connectivity (The link is up).

I think that there is something wrong with my configuration (IOS).

Can you advise where I can see a sample of IOS setup similar to mine?

Thanks,

Tamir

New Member

Re: 1721 router configuration

Hi Tamir,

First thing mention ur fa 0/0 ip add as excluded ip add in dhcp .

second check the ip access list u configured for the NAT and possible configure extended ip acl

Check Sh Ip Route

May this help u..

Thanks,

hardik

727
Views
0
Helpful
10
Replies