Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1811 basic setup question - vlan 1 can't ping internet

Hello, I'm having trouble setting up a router to allow access to the internet.  I'm sure it's something simple but I can't seem to figure it out and was hoping someone could help?

The setup is cable modem/router connected to fa1 giving it the ip address 192.168.0.15 then computers connected to a couple of ports (fa2-5) getting dhcp addresses from the router.

 

what's happening is:

can ping internet from router (fa1 to google.com - OK)

can ping fa1 from vlan 1 interface  ( vlan 1 to fa1 - OK )

can't ping internet from vlan 1 interface (  vlan 1 to google.com - no response )

(computers can ping each other).

 

If anyone has any recommendations I'd appreciate it.

Thanks,

 

config below:

router#show run
Building configuration...

Current configuration : 1547 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool mainpool
   network 192.168.2.0 255.255.255.0
   dns-server 192.168.0.1
   default-router 192.168.2.1
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Async1
 no ip address
 encapsulation slip
!
ip default-gateway 192.168.0.15
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet1 overload
!
access-list 1 permit 192.168.2.0
!
control-plane
!
line con 0
line 1
 modem InOut
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
!
end

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Hi,Can you change:access-list

Hi,

Can you change:

access-list 1 permit 192.168.2.0

to

access-list 1 permit 192.168.2.0 0.0.0.255

and test again?

HTH

 

2 REPLIES
Hall of Fame Super Silver

I see two things (which are

I see two things (which are probably related) that may well be your problem:

- I see this in your config

ip default-gateway 192.168.0.15

- I do not see any default route.

 

I do not understand why you are configuring a default gateway, unless IP routing is disabled. And not having a default route may be why the router is not able to route traffic from your inside devices.

 

HTH

 

Rick

 

VIP Super Bronze

Hi,Can you change:access-list

Hi,

Can you change:

access-list 1 permit 192.168.2.0

to

access-list 1 permit 192.168.2.0 0.0.0.255

and test again?

HTH

 

486
Views
0
Helpful
2
Replies
CreatePlease to create content