Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1811 Router - Two Internet connections

Hi,

My client will be moving to a new office and we plan to have two Internet sources. How can I make both of them work with my 1811 router and also have load balancing. I am running IOS v. 12.4.

Thank you for your help.

Oliver

11 REPLIES
Hall of Fame Super Silver

Re: 1811 Router - Two Internet connections

Hello Oliver,

you can get redundancy

it is more difficult to achieve load balancing.

I guess you are going to get two public IP address blocks one from ISP1 and one from ISP2 and that then you need to use NAT for using  this.

Traffic sourced from ISP1 block has to be sent to ISP1, traffic sourced from ISP2 block has to be sent to ISP2.

NAT with route-maps that combines also PBR can be the right tool

Hope to help

Giuseppe

New Member

Re: 1811 Router - Two Internet connections

Thanks Guiseppe. I will surely check on PBRs.

All the best,

Oliver

New Member

Re: 1811 Router - Two Internet connections

Oliver,

The easiest way is to configure 2 default routes (pointing out each internet link). By default Cisco router will load balance (per destination).

If you want to load balance per packet. you can go into the Interface and apply: ip load-sharing per-packet

HTH

New Member

Re: 1811 Router - Two Internet connections

How can I accomplish this? I understand that by default, even if it is not showing up on the running-config file, there is an:

ip route 0.0.0.0 0.0.0.0 x.x.x.x where x.x.x.x is the IP address of the router

Please correct me if I am wrong.

Thanks,

Oliver

Hall of Fame Super Silver

Re: 1811 Router - Two Internet connections

Oliver

I am not sure where you got the idea that there is :"ip route 0.0.0.0 0.0.0.0 x.x.x.x where x.x.x.x is the IP address of the router" but it is not correct.

[edit] there are a few things that are present even though they do not show up in the running config (such as deny ip any any as the last line of an access list). But there is not any default setting that provides a default route.

HTH

Rick

New Member

Re: 1811 Router - Two Internet connections

Thank you Rick for clearing that. I am still learning...:)

How can I accomplish two routes as you have earlier mentioned?

O

New Member

Re: 1811 Router - Two Internet connections

Like Rick says, there is no default route "by default" ... if you have not configured this and its not showing up on your running config then its not going to be there.

the configuration would be:

ip route 0.0.0.0 0.0.0.0 [ISP1 gateway]

ip route 0.0.0.0 0.0.0.0 [ISP2 gateway]

i don't really know what your LAN IP range is, but if its public, just make sure both ISP advertise this range. If its private, you'll need abit of NAT-ing configured.

I'd also leave it to load - balance per destination (if you are doing NAT).

Hall of Fame Super Silver

Re: 1811 Router - Two Internet connections

Hello Oliver,

>>even if it is not showing up on the running-config file, there is an:

ip route 0.0.0.0 0.0.0.0 x.x.x.x where x.x.x.x is the IP address of the router

as Rick has explained:

a) no routing command is present by default because it would not fit everywhere: there are cases where you don't want this for example because dynamic routing protocols have to be used.

b) x.x.x.x  = the IP next-hop of a static route has to be different from the router's ip address it has to be the IP address of a connected device (in your case the ISP router or broadband NAS) so it has to be the IP address of somebody else

IP routing can be easily configured as:

ip route 0.0.0.0 0.0.0.0 ISP1-ipaddress

ip route 0.0.0.0 0.0.0.0 ISP2-ipaddress

if you don't know what IP addresses will be on the WAN interfaces it is likely that you should use the outgoing interface name as a reference for the static routes.

in the same way the reference for NAT can be the name of WAN interfaces if the ip address is the result of DHCP or PPP over X activity.

so if 192.168.121.0/24 is your internal lan

access-list 111 permit ip 192.168.121.0 0.0.0.255 any

access-list 112 permit ip 192.168.121.0 0.0.0.255 any

two route-maps can be defined

route-map NAT_toISP1 permit 10

match ip address 111

set interface WAN1

route-map NAT-toISP2 permit 10

match ip address 112

set interface WAN2

ip nat inside source route-map NAT_toISP1 interface WAN1 overload

ip nat inside source route-map NAT-toISP2 interface WAN2 overload

int fas0/0

ip address 192.168.121.1 255.255.255.0

ip nat inside

int wan1

ip nat outside

int wan2

ip nat outside

this can be an example of a possible configuration but changes may be needed for example to avoid NAT when not needed

WAN1 and WAN2 are just placeholders for the real names.

Hope to help

Giuseppe

New Member

Re: 1811 Router - Two Internet connections

Guiseppe,

Thank you very much for this comprehensive guide.

I will have a chance to test the settings next week.

You have described WAN1 and WAN2, which is perhaps the FastEthernet 0 and FastEthernet 1 respectively on our router, is this correct?

Oliver

Hall of Fame Super Silver

Re: 1811 Router - Two Internet connections

Hello Oliver,

yes it is correct.

I used those names just to indicate them.

To be noted if you use some form of PPPoE the interfaces to be used are the dialer interfaces not the FE physical interfaces

So to be more precise WAN1 and WAN2 indicates the L3 interfaces that will have an IP address over them when active.

Hope to help

Giuseppe

Re: 1811 Router - Two Internet connections

Hi,

My client will be moving to a new office and we plan to have two Internet sources. How can I make both of them work with my 1811 router and also have load balancing. I am running IOS v. 12.4.

Thank you for your help.

Oliver

Hi Oliver,

Check out the below link for configuration for nat based load baclining with route maps.

http://www.ciscosystems.com/en/US/products/sw/secursw/ps1018/products_configuration_example09186a0080950b87.shtml

Hope to help

Ganesh.H

6012
Views
1
Helpful
11
Replies
CreatePlease to create content