Cisco Support Community
Community Member

1811 Switch capabilities

Hello all

How do I extend fa0 subnet to the 8 switch ports. I would like to have 1 wan port, and 9 lan ports. Kind of like a $50 linksys router you would buy at walmart.

Thanks for your time


Re: 1811 Switch capabilities

I've forgotten how the port numbering here goes, but I believe we have Fa0 to Fa9. 8 of these ports are layer-2, meaning the only commands accepted are 'switchport access vlan ', and the other is a layer-3 interface, meaning you can configure an IP address directly on it. Assuming Fa0 is the "wan" port, your configuration would look something like this:

ip dhcp pool Private



import all

interface fa0

ip address dhcp

ip nat outside

interface range fa1 - 9

switchport access vlan 1

interface vlan1

ip address

ip nat inside

access-list 1 permit

ip nat inside source list 1 interface fa0 overload

The above configuration configures your WAN to get an IP from your DSL/cable modem. Your LAN is configured for DHCP in the range, and the router will be performing NAT in between the LAN and WAN.


Community Member

Re: 1811 Switch capabilities

Thanks Will for your response. Is there a way to do it without natting inside to outside.

We have 10.2.114.x on outside, we have on inside. With assigned to fa0 . What I would like to do is plug a pc into switch and give it a,3,4,5,6 and allow it to route to 10.2.114.x

Make sense?

Thank you again

Community Member

Re: 1811 Switch capabilities


Is is possible to route from FA0 and switch ports to FA1. Example, FA1 has

and Fa0 has on the Fa0 side I have a whole class B some of which I would like to assign to Pcs and plu into the switch ports.

Sw port 1 would have Sw port 2 would have and so on. I would like for these to route (not nat) to fa1. Is this possible?


CreatePlease to create content