Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1811 - Voice VLAN DHCP Problems

I can't believe I am asking this, but I must be missing something. Setting up an 1811 in a lab environment (no WAN connection). Very basic configuration, but cannot seem to get DHCP working for phones. This device is standalone right now with no other devices connected (except 2 phones and a laptop).

Any help would be greatly appreciated. Config below:

Current configuration : 2864 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname C1811-BaseCamp

!

boot-start-marker

boot-end-marker

!

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

!

!

ip cef

ip dhcp excluded-address 10.96.16.1 10.96.16.49

ip dhcp excluded-address 10.96.16.91 10.96.16.255

ip dhcp excluded-address 192.168.16.1 192.168.16.49

ip dhcp excluded-address 192.168.16.91 192.168.16.255

!

ip dhcp pool DATA

   network 10.96.16.0 255.255.255.0

   default-router 10.96.16.254

   netbios-name-server 10.96.17.2

   domain-name cookeaqua.com

   dns-server 10.96.16.1 10.96.17.2 10.1.200.50

   lease 0 1

!

ip dhcp pool VOICE

   network 192.168.16.0 255.255.255.0

   default-router 192.168.16.254

   option 150 ip 192.168.16.240

   lease 0 1

!

no ip domain lookup

ip domain name cookeaqua.com

ip ssh version 2

ip inspect log drop-pkt

ip inspect name FIREWALL tcp

ip inspect name FIREWALL udp

ip inspect name FIREWALL ftp

ip inspect name FIREWALL fragment maximum 256 timeout 1

ip ips po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

!

interface FastEthernet0

ip address dhcp

shutdown

duplex auto

speed auto

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet2

switchport access vlan 26

no ip address

spanning-tree portfast

!

interface FastEthernet3

switchport access vlan 16

switchport voice vlan 26

no ip address

spanning-tree portfast

!

interface FastEthernet4

switchport access vlan 16

switchport voice vlan 26

no ip address

spanning-tree portfast

!

interface FastEthernet5

switchport access vlan 16

switchport voice vlan 26

no ip address

spanning-tree portfast

!

interface FastEthernet6

switchport access vlan 16

switchport voice vlan 26

no ip address

spanning-tree portfast

!

interface FastEthernet7

switchport access vlan 16

switchport voice vlan 26

no ip address

spanning-tree portfast

!

interface FastEthernet8

switchport access vlan 16

no ip address

spanning-tree portfast

!

interface FastEthernet9

switchport access vlan 16

switchport voice vlan 26

no ip address

spanning-tree portfast

!

interface Vlan1

no ip address

shutdown

!

interface Vlan16

ip address 10.96.16.254 255.255.255.0

!

interface Vlan26

ip address 192.168.16.254 255.255.255.0

!

interface Async1

no ip address

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.96.16.250

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

line con 0

line 1

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

login

!

end

Everyone's tags (7)
9 REPLIES
Purple

1811 - Voice VLAN DHCP Problems

Hi,

can you do this:

logging buffered debug

no service timestamp debug

logging buffered 100000

do clear log

do debug ip dhcp server packet

shut/no shut the voice VLAN SVI and then

do sh log 

post output here

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

1811 - Voice VLAN DHCP Problems

Have you created the vlans themselves? Do a show vlan brief to ensure it exists, and show interface vlan 26 to verify that it is showing up, line protocol up.

New Member

1811 - Voice VLAN DHCP Problems

Hi Cadet - I will do some of the logging tomorrow morning when I am back in the lab.

Benjamin - the VLANs are fully created and active.

New Member

1811 - Voice VLAN DHCP Problems

That is definitely quite odd then. Are dhcp addresses being assigned to the data vlan just fine? One thing you could test is put a port statically in the voice vlan - switchport access vlan 16 and just see if your laptop can get an IP out of the scope. I also notice you're running 12.3 code, do you have the ability to update to 12.4?

Ben

1811 - Voice VLAN DHCP Problems

Hi Adam,

you should try to take out this line:

option 150 ip 192.168.16.240

and verify first if the IP Phones get an IP in this way. Then you could assign a TFTP Server for the configs..

Alessio

1811 - Voice VLAN DHCP Problems

Couple things with the config....

Make sure CDP is enabled. The phones use that to let the switch know it is a phone.

I do not see an IP Helper address for the Voice vlan and since the DHCP server IP address is in a different subnet you will need this.

In the DHCP config for the voice vlan I do not see thet domain name, dns servers, netbios server defined.

interface FastEthernet2 has VLAN 26 but it is set as access not voice.

interface FastEthernet8 does not have the voice vlan defined

Also does the phone get any IP address?

What model phone are you using?

Can you see the MAC addresses of the phones when you run show mac-add dyn

Are the PC connected through the phones or do the phones and PC's each have their own connection?

Mike

New Member

1811 - Voice VLAN DHCP Problems

Okay - I made a poor assumption previously and have found the root of the problem.

When I have:

switchport access vlan 16

switchport voice vlan 26

On a switchport, the voice vlan does not show ip on the port under vlan-switch.

If I only add switchport access vlan 26 to the port, then the phone gets DHCP on that VLAN.

So it appears to be an issue with having 2 vlans on the one switchport.

Any ideas?

1811 - Voice VLAN DHCP Problems

You can have two vlans on the same port as long as one is access and the other is voice.

Did you make the correction I showed above? Also what about the questions I asked above?

Mike

New Member

1811 - Voice VLAN DHCP Problems

Hi Mike,

I just completed an IOS upgrade on the device and all vlan assignments are now working correctly. The phone has received the correct vlan and dhcp information. All good now.

Thanks!

Adam

2195
Views
5
Helpful
9
Replies
CreatePlease login to create content