Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1921 ISR certificate request not valid

I'm trying to perform a certificate request on a 1921 router.  I've followed the wizard using Cisco Configuration Professional several times.  First I created a 2048 RSA key pair, then used the "Cut-and-Paste" wizard in CCP to generate the CSR using that keypair.  When pasting the text into Godaddy's CSR window, Godaddy responds with "Invalid CSR submitted. Please re-create your CSR and submit your request again".  Done this numerous times tweaking this and that with no success.

I've tried adding the  "-----BEGIN CERTIFICATE REQUEST-----" and "-----END CERTIFICATE REQUEST-----" but that has not changed the behavior.

Anyone seen this before?  I've Googled it to death and can't find a solution.

 

5 REPLIES
VIP Super Bronze

Is this for an SSL

Is this for an SSL certificate?

Can you try using the cli?


 

New Member

Hi.  Yes, it's for an SSL

Hi.  Yes, it's for an SSL cert.  Just moments ago I got it to work, but only after running the CSR through one of the online decrypters.  I was trying to make sure the encoded information was valid.  One of the decrypters automatically reformatted the text, and added the header and footer lines I mentioned above.  Only after copying THIS text and pasting into the GoDaddy window was the CSR valid.  Very weird.  I attempted this process no less than 25 times and was about to tear my hair out.

I can't say what the problem was but some for of reformatting the CSR output was required before GoDaddy would accept the CSR.

The output that worked, and my output, look exactly the same.  Not just characters, but formatting, etc. including the header and footer lines.

This should be a very repeatable issue.  Anyone with a router and a copy of CCP can see the issue.

At any rate, problem is solved for now, but I can't say what the solution actually was.

VIP Super Bronze

Thanks for the update Justin

Thanks for the update Justin

New Member

Justin thank you!I was having

Justin thank you!

I was having the same problem till i saw your post and i went to a cer verification and whatever it autofixed it made it work.

 

 

New Member

Nice to hear I was able to

Nice to hear I was able to help.  Thinking back on this I wonder if the text needed to be really stripped down, to just pure ASCII, or extra spaces/carriage returns removed, or something along those lines.  At any rate, glad it worked for you.

53
Views
0
Helpful
5
Replies
CreatePlease to create content