Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1941 W Configuration Router to Embedded AP

     The problem that I am having with my configuration is being able to route between the Router and its embedded WLan-AP.  I am looking into configuring the Wlan-G0 interface in the Router to communicate with the GE0 interface in the embedded WLan-AP allowing the devices to route between Devices. Bellow is the configuration of the Device.  Any help is welcome. 

******** WLAN_AP *******

hostname BAY02_AP
!
enable secret 5 $1$jOkE$TjxX0XA0CyA6bz2qwz6Fq/
enable password 7 072C285F4D06
!
no aaa new-model
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.120 192.168.2.126
!
ip dhcp pool WLAN_BAY02_USERS
   network 192.168.2.64 255.255.255.192
   default-router 192.168.2.126
   lease 55
!
!
dot11 syslog
!
dot11 ssid BAY_BRIDGE
   authentication open
   authentication key-management wpa version 2
   infrastructure-ssid
   wpa-psk ascii 7 BAY_NASAMars_2013!
!
!
!
username Cisco password 7 00271A150754
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
antenna gain 0
channel 2437
station-role root bridge
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
description To 1941AP03 Dot11Radio1 Bridge
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid BAY_BRIDGE
!
antenna gain 0
dfs band 3 block
channel dfs
station-role root bridge
distance 1
bridge-group 1
!
interface GigabitEthernet0
description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
no ip address
no ip route-cache
!
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface BVI1
description Bridge Interface IP Address
ip address 192.168.23.2 255.255.255.240
no ip route-cache
!
ip default-gateway 192.168.22.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 protocol ieee
bridge 1 route ip
!
!
!
line con 0
no activation-character
line vty 0 4
login local
!
end


******** Router Config ************

hostname BAY02_RT
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
no ipv6 cef
!
!
!
!
!
ip cef
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO1941W-A/K9 sn FTX140980LH
hw-module ism 0
!
!
!
!
!
bridge irb
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description To 3750 Gig1/0/24 LAN Hosts
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip unnumbered Vlan1
arp timeout 0
no mop enabled
no mop sysid
!
interface GigabitEthernet0/1
description To L2 Cisco Switch For Routers
ip address 192.168.123.2 255.255.255.248
duplex auto
speed auto
!
interface Wlan-GigabitEthernet0/0
description Internal switch interface connecting to the embedded AP
switchport mode trunk
no ip address
!
interface Vlan1
ip address 192.168.22.1 255.255.255.240
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
no ip address
!
interface BVI2
mtu 1514
ip address 10.0.23.2 255.255.255.248
!
interface BVI23
ip address 192.168.23.1 255.255.255.240
!
!
router eigrp 123
network 192.168.2.0
network 192.168.4.0 0.0.0.7
network 192.168.23.0 0.0.0.15
network 192.168.123.0 0.0.0.7
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 23 protocol ieee
bridge 23 route ip
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end

   

Thanks,

Romieo

Thanks, Romieo
5 REPLIES
Hall of Fame Super Gold

1941 W Configuration Router to Embedded AP

Go here.

There are some recently-attached router config for the 880W.  The config should work with you.

New Member

1941 W Configuration Router to Embedded AP

Thanks for the suggestion Leo.  I looked over the discussion but I found what I needed to add in my configuration after looking into deeper.  If there is anyone with the same issue Reading this posting looking into your Bridging configuration.

Router configuration:

1st Configure the Wlan-G0/0 port as a trunk. Configure your Native Vlan.

2nd Configure the Native Vlan to the Bridge-group of the BVI interface.

3rd Make sure the BVI interface is in the same subnet as the BVI interface on the embedded AP.

Embedded WLan-AP configuration:

1st Configure the G0 Interface with a sub-interface G0.X as a Dot1q Native Vlan.

2nd Configure the Sub-interface as part of the Bridge-group on the AP side of the Router.

3rd Remember that the only Bridge-group on the WLan-AP that supports Routing IP is Bridge 1

*** Note:  Bridge 1 protocol ieee

                     Bridge 1 route ip (Most important command for bridging to work)

Thanks,

Romieo
If this Helps don't forget to Rate.

Thanks, Romieo
Hall of Fame Super Gold

1941 W Configuration Router to Embedded AP

3rd Make sure the BVI interface is in the same subnet as the BVI interface on the embedded AP.

Not sure about the 1941 but BVI is found in the AP only.  So your router's management IP Address should be in the same subnet as the AP's BVI1 interface.

New Member

1941 W Configuration Router to Embedded AP

Yes, you can either configure the Management IP Address in the same Subnet, but I don't know if its the IOS on the 1941.  I had to create a BVI on the Router and place the VLan Interface into the Bridge-group.  It drove me crazy for about 4 days to figure it out But thats Networking.. Now I will never forget..

Thanks,

Romieo

Thanks, Romieo
New Member

Here are my simple problem >

Here are my simple problem >>

i need the radiod1 and 2 to give ip address ( 192.168.0.0 255.255.255.0 ) dhcp server will be handled by the router.
but they give ip address ( 255.255.0.0 range )

******************

dot11 ssid Samplessidabg
auth open
auth key wpa ver 2
wpa-psk ascii password1
guest-mode
exit

dot11 ssid Samplessidn
auth open
auth key wpa ver 2
wpa-psk ascii password2
guest-mode
exit

int d0
encryp mode ciphers aes
ssid Samplessidabg
bridge-group 1
channel 6
no shut
exit

int d1
encryp mode ciphers aes
ssid Samplessidn
bridge-group 1
channel 6
no shut
exit

int bv1
ip address 192.168.0.2 255.255.255.0
ip nat inside
exit

default-gateway 192.168.0.1 ( also the gateway in my router w.c i have configures

correctly)

*****************

if anyone can help me what do i need to change or add in this config

or show a sample that works..

 

thanks for the help..

320
Views
0
Helpful
5
Replies
CreatePlease to create content