Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1941W Wireless config

I just purchased a 1941w router to see if we want to use this to replace our existing routers and external access points. At each of our locations we have 1  subnet that has a server, AP, router, switch, etc.

I would like to configure the AP and the router in the 1941w in the same subnet but cannot figure out how to do this. If I setup the wlan-ap0 interface with an IP in the subnet I am using it will not let me assign an IP from that same subnet to any of the ethernet interfaces. It says they overlap.

No matter what I do I cant seem to use the same IP on both. I could if I purchased a 1941 without wireless and then purchased an aironet so why cant I do it when they are in the same box?

I'm not a cisco expert so I assume I'm just not doing something right. Any help appreciated.

Thanks

Everyone's tags (3)
4 REPLIES

1941W Wireless config

You need to configure a bridged interface that is linked to your ethernet-interface and your wlan-ap0-interface. On the bridged-interface you set the IP-address. Search on cisco's website to set it up.

New Member

1941W Wireless config

Thank you for the reply but when I try to bridge the wlan-ap0 interfae it says it does not support bridging. This is the command I used:

bridge-group 1

This isthe output I get

wlan-ap0 does not support bridging

Any other ideas?

Re: 1941W Wireless config

Maybe this link will help:

http://www.cisco.com/en/US/docs/routers/access/1900/software/configuration/guide/wlan.html

Haven't looked though it, but if there is an answer for your question, it should be there.

I think the very first thing they show might be the thing you are looking for.

New Member

1941W Wireless config

You need to create a vlan en BVI interface in you're config

!

ip dhcp pool LAN-WiFi

import all

network 192.168.0.0 255.255.255.0

dns-server 194.109.6.66 194.109.9.99

default-router 192.168.0.1

domain-name WORKGROUP

lease 7

!

.....

!

interface wlan-ap0

ip unnumbered BVI1

arp timeout 0

no mop enabled

no mop sysid

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

no cdp enable

bridge-group 1

hold-queue 100 out

!

interface Vlan1

no ip address

bridge-group 1

!

interface BVI1

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

!

and do not forget

bridge 1 protocol ieee
bridge 1 route ip

in you're AP config you can set both ( 2.4 and 5Ghz ) to the vlan1

now the LAN and WLAN have the same IP range.

829
Views
0
Helpful
4
Replies