Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2 3750 ip base switch intervlan routing between vlans

Hello,

I have 2 3750-e ipbase switches on a port channel trunk encap 1.q i want to configure 2 vlans on each one and have them talk to eachother how can i make it work
like switch 1
vlan 10
interface 192.168.1.10 255.255.255.0
vlan20
no ip
switch 2
vlan 10
no ip
vlan20
interface 192.168.2.10 255.255.255.0

computer connected to switch 2 with ip 192.168.2.200 cannot ping 192.168.1.10

4 REPLIES
VIP Super Bronze

Hi,You first need to deside

Hi,

You first need to decide what switch is going to do the routing between the vlans for you.

Your config above shows that one switch has an SVI for vlan 10 and the other has an SVI for vlan 20.

If you want switch-1 to route between vlans, then you need to configure both SVIs on that switch.

Example:

switch-1

vlan 10

name test-vlan-10

exit

inter vlan 10

ip add 192.168.1.10 255.255.255.0

no sh

exit

switch-1

vlan 20

name test-vlan-20

inter vlan 20

ip add 192.168.2.10 255.255.255.0

no sh

now you need to add the trunk to the interface connecting to switch-2

example:

switch-1

interface gi0/1

switcport

switchport mode trunk

switchport trunk enc dot.q

 

Do the same for switch-2

interface gi0/1

switcport

switchport mode trunk

switchport trunk enc dot.q

 

HTH

 

 

 

New Member

You also need to make sure

You also need to make sure you have the "ip routing" command on the switch with the 2 SVI's

New Member

on switch 2 do i have to also

on switch 2 do i have to also make the vlan's?? but with no ip address? and map the ports i want to the appropriate vlan? like so:

switch-2

vlan 10

name test-vlan-10

exit

switch-2

vlan 20

name test-vlan-20

exit

int gigabitethernet1/0/1

switchport mode access

switchport access vlan 10

exit

int gigabitethernet1/0/2

switchport mode access

switchport access vlan 20

exit

 

Thanks again!!

New Member

Yes if you are not using VTP

Yes if you are not using VTP client/server mode between the two switches or if you have the VTP mode set to transparent you will need to create the VLAN's like above in order to assign the switch ports to that VLAN like above.

 

 

 

115
Views
0
Helpful
4
Replies
CreatePlease to create content