Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2 4948's, 2 Routed Links and 1 Trunk

All,

I have two (2) catalyst 4948's that I am trying to get to talk to each via a trunk and I also have 1 routed interface on each switch. I have one routed interface per switch and between them I have a L2 trunk. What I want is if a PC is connected to switch 1 and has to go to switch 2 I don't want it to take the routed interface out on switch 1 and come back in on switch 2. I want local traffic to flow between the switches via the trunk. The only problem is, it isn't working. I have routes on both switches but I can't talk between the switches over the trunk. Can someone shed some light on this. Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: 2 4948's, 2 Routed Links and 1 Trunk

If your using VTP, use vtp version 2.

Do this on both switches. This will set them as both servers.

# vtp mode server

# vtp version 2

# vtp domain xxx

# vtp password mypassword

# vtp pruning

"show vlan brief" should show vlan 41 on both switches.

5 REPLIES
New Member

Re: 2 4948's, 2 Routed Links and 1 Trunk

Can you post configs?

Keep in mind a trunk carries vlans, which are layer 2.

New Member

Re: 2 4948's, 2 Routed Links and 1 Trunk

okay notice below the configs on sw2 and sw1. There is a routed interface on each switch and the other remaining interfaces are layer 2 trunks. I want local traffic to run between the trunks and traffic destined for the outside to just go out the routed interface. Is this possible the way I have it set up? Or should I just put both routed interfaces on one switch and keep the trunk?

SW2

no aaa new-model

ip subnet-zero

no ip domain-lookup

ip domain-name NET.SBA.GOV

!

no ip bootp server

cluster run

!

!

!

power redundancy-mode redundant

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

interface GigabitEthernet1/1

switchport access vlan 41

switchport port-security maximum 3

switchport port-security aging time 15

interface TenGigabitEthernet1/49

description Trunk to switch1

!

interface TenGigabitEthernet1/50

description Uplink to Dist 2

no switchport

ip address 165.110.17.153 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip hello-interval eigrp 1 1

carrier-delay msec 0

!

interface Vlan1

no ip address

shutdown

!

interface Vlan41

ip address 0.0.41.254 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

!

router eigrp 1

network 0.0.17.152 0.0.0.3

eigrp stub connected summary

no auto-summary

passive-interface default

no passive-interface TenGigabitEthernet1/50

redistribute connected

----------------------------------------------

SW1

no aaa new-model

ip subnet-zero

ip cef load-sharing algorithm original

!

cluster run

!

!

!

power redundancy-mode redundant

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

ip ssh version 2

interface GigabitEthernet1/1

switchport access vlan 41

switchport port-security maximum 3

spanning-tree portfast

interface TenGigabitEthernet1/49

no switchport

ip address 0.0.17.97 255.255.255.252

ip hello-interval eigrp 1 1

carrier-delay msec 0

!

interface TenGigabitEthernet1/50

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 41

switchport mode trunk

!

interface Vlan1

no ip address

!

interface Vlan41

ip address 0.0.41.253 255.255.255.0

!

router eigrp 1

network 0.0.17.96 0.0.0.3

eigrp stub connected summary

no auto-summary

passive-interface default

no passive-interface TenGigabitEthernet1/49

redistribute connected

New Member

Re: 2 4948's, 2 Routed Links and 1 Trunk

Your trunk on switch2 is not configured.

on sw2 add this.

interface TenGigabitEthernet1/49

description Trunk to switch1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 41

switchport mode trunk

This way if PC1 sitting on sw1 port g1/1 wants to send traffic to PC2 sitting on sw2 port g1/1, it will use the trunk. PC1 will arp for PC2 mac address since it will be on the same subnet and the switch will feed it over the trunk.

New Member

Re: 2 4948's, 2 Routed Links and 1 Trunk

Okay, thanks I got my trunks set. Now I need my vlans set I am running VTP v1 but still am not seeing vlan 41 on both switches. Can you shed some light on this?

New Member

Re: 2 4948's, 2 Routed Links and 1 Trunk

If your using VTP, use vtp version 2.

Do this on both switches. This will set them as both servers.

# vtp mode server

# vtp version 2

# vtp domain xxx

# vtp password mypassword

# vtp pruning

"show vlan brief" should show vlan 41 on both switches.

307
Views
0
Helpful
5
Replies