Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

??-2 physical connections on 1 Serial interface-??

Hi there

I'm in the middle of setting up CCENT lab. I've 2 1721 routers conected via DCE/DTE cable [R2 is set to DCE]. Router 1 is connected to Router 2 on serial interface and to a 2950 switch on fast ethernet interface. Router 2 is also connected directly to my laptop on fast ethernet interface.

For some reason when I use ''show ip route'' command on both of my routers they're showing that they are connected to 3 subnets. I dont understand why is it showing physical connection to this network:  192.168.1.65/32 ??

Please can someone explain me what I'm doing wrong??

Below I'm attaching config files and command outputs.

My subnets:

I            192.168.1.0  -    192.168.1.63

II           192.168.1.64 - 192.168.1.127

III          192.168.1.128 - 192.168.1.191

IV          192.168.1.192 - 192.168.1.255

255.255.255.192

Thanks.

----------------------------------------------------------------------------------------------------------

Router1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks

C       192.168.1.65/32 is directly connected, Serial0

C       192.168.1.64/26 is directly connected, Serial0

C       192.168.1.128/26 is directly connected, FastEthernet0

-----------------------------------------------------------------------------------------------------------

Router1

Current configuration : 709 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$Y69O$E4Iao7lfz2z65DeRSVtt2/

!

no aaa new-model

ip cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

interface FastEthernet0

ip address 192.168.1.129 255.255.255.192

speed auto

!

interface Serial0

ip address 192.168.1.66 255.255.255.192

encapsulation ppp

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

line con 0

password 7 070B345C4F

login

line aux 0

line vty 0 4

password 7 121D100713

login

!

end

====================================================

====================================================

R2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks

C       192.168.1.64/26 is directly connected, Serial0

C       192.168.1.66/32 is directly connected, Serial0

C       192.168.1.0/26 is directly connected, FastEthernet0

---------------------------------------------------------------------------------------------------------------

R2#show running-config

Building configuration...

Current configuration : 813 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$Dp3y$klKPKWSqsd3U99.jHtEro1

!

no aaa new-model

ip cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0

ip address 192.168.1.2 255.255.255.192

speed auto

!

interface Serial0

ip address 192.168.1.65 255.255.255.192

encapsulation ppp

clock rate 2000000

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

line con 0

password 7 1413071B0D

login

line aux 0

line vty 0 4

password 7 0202114B0A

login

!

end

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

??-2 physical connections on 1 Serial interface-??

Lukasz

The explanation for this is that the serial link is using ppp encapsulation. And as the router brings up the serial interface the ppp protocol uses IPCP negotiation to learn the address of the neighbor and then it puts that address into the routing table as a connected network and as a /32 since that is what ppp learned about its neighbor.

HTH

Rick

7 REPLIES
VIP Super Bronze

??-2 physical connections on 1 Serial interface-??

Hi,

That is correct.  On r1 route table:

     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks

C       192.168.1.65/32 is directly connected, Serial0

C       192.168.1.64/26 is directly connected, Serial0

C       192.168.1.128/26 is directly connected, FastEthernet0

192.168.1.65 is the IP address of the serial interface of the neigbor router and that is a host address (/32)

the second one (192.168.1.64/26) is the subnet for the serial interface between r1 and r2

The 3rd one is the subnet for the FastEthernet interface of the router

HTH

New Member

??-2 physical connections on 1 Serial interface-??

Hi

Thanks thats a bit clearer now. But still I don't understand why the subnet mask is /32 while 2 other masks are /26.

If you could explain it I will be much appreciated.

Thanks a lot.

VIP Super Bronze

Re: ??-2 physical connections on 1 Serial interface-??

Hi,

/32 the address of r2 serial interface and there is C next to it, so it is a directly connected interface.  Then you have 2 /26 masks, one is the one you created for the serial interface that connects r1 and r2 together and the other one is the one you created for the fastEthernet interface.  They also each have a C next to them and that means they are directly connected or local subnets.

Now, since you do not have any static routes on r1 or r2, you will not be able to ping from a host (PC/Laptop) connected to r1 to a host connected to r2 and vice versa. If you want to have full connectivity between hosts connected to r1 and r2 you need a static route on each router as follows:

r1

ip route 192.168.1.0 255.255.255.192  192.168.1.66

r2

ip route 192.168.1.128 255.255.255.192  192.168.1.65

Please remember to tag your threads and help support "Teachers without Borders"

https://supportforums.cisco.com/community/netpro/idea-center/communityhelpingcommunity

HTH

New Member

??-2 physical connections on 1 Serial interface-??

Hi

Thanks for your help.

I literally finished setting up static routing for them just before I checked your recent post and I can now connect to all the devices on my network. HURRAY.

The reason I've asked for that third physical (C) connection was that I've watched tutorial video in which tutor sets up a similar layout. In his routing table there are only two C's appears  -

1st for the network on the serial interface side and

2nd for the network on the fastethernet side

What is he saying is that routers knows only about the networks that they are physically connected to - so following this logic my routers are only connected to two networks each and what i don't understand is why [as you stated]

''/32 the address of r2 serial interface and there is C next to it, so it is a directly connected interface''

routers recognizing serial interface of other router as a network??

It really annoys me.

Thank you very much.

Hall of Fame Super Silver

??-2 physical connections on 1 Serial interface-??

Lukasz

The explanation for this is that the serial link is using ppp encapsulation. And as the router brings up the serial interface the ppp protocol uses IPCP negotiation to learn the address of the neighbor and then it puts that address into the routing table as a connected network and as a /32 since that is what ppp learned about its neighbor.

HTH

Rick

New Member

??-2 physical connections on 1 Serial interface-??

Thanks a lot guys!!

Hall of Fame Super Silver

??-2 physical connections on 1 Serial interface-??

Lukasz

I am glad that our responses were able to lead you to a solution to this issue. Thank you for using the rating system to mark this question as answered (and thanks for the points). It makes the forum more useful when people can read a question and can know that a solution was found. Your marking of this question has contributed to this process.

HTH

Rick

723
Views
0
Helpful
7
Replies
CreatePlease login to create content