Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2 Wirless Link From 2 ISPs

Kindly,have a look to the attached diagram;as well as to the Config provided from Devang!

i have 2 wireless connection from 2 different ISPs(ISPA;ISPB)ISP A Terminate link at R1;ISPB Treminate link at R2;i want to achieve the following setup:if the first Link(ISPA)fail the second link (ISPB) TAKE OVER.R1 ITS PRIMARY;R2 ITS SECONDERY.e.g continuous internet access in case on of link goes down

How can i CONFIGURE like this setup?can i do load Balence?

Config like this:

*****************

active router(R1)

*****************

interface fa0/0

ip address 10.10.100.2 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 105 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.1

standby 10 track Fa 0/1

!

ip nat inside source list 1 interface fa0/1 overload

access-list 1 permit 10.10.100.0 0.0.0.255

!

int f0/1

ip address 202.10.10.1 255.255.255.252

ip nat outside

Standby Router(R2)

******************

interface fa0/0

ip address 10.10.100.3 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 100 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.1

standby 10 track Fa 0/1

!

ip nat inside source list 1 interface fa0/1 overload

access-list 1 permit 10.10.100.0 0.0.0.255

!

int f0/1

ip address 194.126.10.1 255.255.255.252

ip nat outside

10xs for ur reply & for ur examination!

11 REPLIES
Silver

Re: 2 Wirless Link From 2 ISPs

This config looks OK. Did you test it on your network?

In this next scenario you route some of your VLANs to R1 with R2 as backup and some VLANs to R2 with R1 as backup. Notice you now have 2 virtual interfaces:

*****************

router(R1)

*****************

interface fa0/0

ip address 10.10.100.1 255.255.255.255.0

stabdby 10 preempt

standby 10 priority 120

standby 10 ip 10.10.100.3

standby 20 ip 10.10.100.4

Router(R2)

******************

interface fa0/0

ip address 10.10.100.2 255.255.255.255.0

standby 20 preempt

standby 20 priority 120

standby 20 ip 10.10.100.4

standby 10 ip 10.10.100.3

New Member

Re: 2 Wirless Link From 2 ISPs

Hi!

1)on both routers do i need static route point my network to the outside interface?

2)on the switch do i need defautl route point to the virtual interface?

10xs

Silver

Re: 2 Wirless Link From 2 ISPs

What does your switch configuration look like?

Do you have the routers in a separate VLAN?

New Member

Re: 2 Wirless Link From 2 ISPs

HI

No in same Vlan;i meant in the previous post:

1)default route from the switch to the virtual ip address

2)static route from from both routers to outside interface(real ip address on both routers)

10xs

Silver

Re: 2 Wirless Link From 2 ISPs

Yes, what you describe is right.

The two routers also need to communicate with each other so they can exchange HSRP protocol messages.

New Member

Re: 2 Wirless Link From 2 ISPs

the 2 routers & also the switch on the same segment!so why do i need to configure Static/default route?

Silver

Re: 2 Wirless Link From 2 ISPs

If you have a single VLAN on your switch, then you do not.

New Member

Re: 2 Wirless Link From 2 ISPs

am not tested this config yet;but this config fit my setup!

any expert help here

10xs

Silver

Re: 2 Wirless Link From 2 ISPs

There is no substitute for testing.

Configure your routers and test. If you have problems, use troubleshooting commands (mainly show ..., Or debug) and post the output on this forum.

New Member

Re: 2 Wirless Link From 2 ISPs

Hi!

experts; i need help!this config works for my Scenario..

10xs

New Member

Re: 2 Wirless Link From 2 ISPs

HI Experts!

i need verification to my config if it works or not!

10xs

156
Views
0
Helpful
11
Replies
CreatePlease to create content