Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2509 issue

Hi,

I have a 2509 router with ocatal cable configured as terminal server, when i connect the cables 1,2 and 3 they work just fine. But the rest (4,...8) not. The strange thing is when the IOS is loading up the rest (4,...8) of cable they all work fine but when the IOS is finished loading it just hangs there nothing happens. I've tryed another cable but i got the same result.

AS#sw4
Trying SW4 (1.1.1.1, 2007)... Open
*** Console framing error ***
PC = 0x87ff783c, Vector = 0x500, SP = 0x87fffe38
*** Console framing error ***
PC = 0x87ff7838, Vector = 0x500, SP = 0x87fffe38
*** Console framing error ***
PC = 0x87ff7838, Vector = 0x500, SP = 0x87fffe38

Smart Init is enabled
smart init is sizing iomem
  ID            MEMORY_REQ                 TYPE
00036C          0X000B3B80 C2620XM Single Fast Ethernet
000044           UNKNOWN port adapter
                0X00098670 public buffer pools
                0X00211000 public particle pools
TOTAL:          0X0035D1F0

If any of the above Memory Requirements are
"UNKNOWN", you may be using an unsupported
configuration or there is a software problem and
system operation may be compromised.
Rounded IOMEM up to: 3Mb.
Using 2 percent iomem. [3Mb/128Mb]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706

Cisco IOS Software, C2600 Software (C2600-ADVIPSERVICESK9-M), Version 12.4(25c),
RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Thu 11-Feb-10 23:02 by prod_rel_team


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2620XM (MPC860P) processor (revision 1.0) with 127627K/3445K bytes of memo
ry.
Processor board ID JAE0746087B
M860 processor: part number 5, mask 2
2 FastEthernet interfaces
2 Serial(sync/async) interfaces
1 ISDN Basic Rate interface
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Slot is empty or does not support clock participate
WIC slot is empty or does not support clock participate


Press RETURN to get started!


*Mar  1 00:00:06.339: %LINEPROTO-5-UPDOWN: Line protocol on Interface VoIP-Null0
, changed state to up
*Mar  1 00:00:23.923: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state t
o up
*Mar  1 00:00:23.923: %LINK-3-UPDOWN: Interface Serial0/0, changed state to down
*Mar  1 00:00:23.923: %LINK-3-UPDOWN: Interface Serial0/1, changed state to down
*Mar  1 00:00:23.927: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state t
o up
00:00:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, chang
ed state to down
00:00:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed sta
te to down
00:00:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed sta
te to down
00:00:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, chang
ed state to down
00:00:25: %LINK-5-CHANGED: Interface BRI0/0, changed state

After this it just hangs there, when i connect the router directly to my PC it works without any problems.


Access server configs:

version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS
!
enable secret 5 $1$4QjE$0xpVYIWjhYZ5
!
ip host SW4 2007 1.1.1.1
ip host R2 2002 1.1.1.1
ip host R1 2008 1.1.1.1
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.200 255.255.25
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip classless
!
!
line con 0
line 1 8
transport input all
line aux 0
line vty 0 4
password cisco
login
!
end

2 REPLIES
Cisco Employee

Re: 2509 issue

Hi Holoe,

I assume that the AS device in your post is the terminal server built on 2509 router, and the "sw4" is some attached device you can access via the terminal server.

The console framing error message as displayed in your post generally refers to a fact that an unintelligible character was received on a console of your "sw4" device. That is serious as it suggests that your async line is emitting symbols that the "sw4" device has troubles understanding. Usually, these framing errors are the result of mismatched bit speeds, data bits, parity, stop bits or flow control, or by faulty hardware or cabling. Also, elmag noise in the vicinity can result in similar problems.

As you are indicating that the ports 1-3 work fine and the 4-8 do not, I am afraid there are hardware problems with their serial controllers and not much can be done. You could try explicitly setting the speed, data bits, parity and flow control just to be sure about their settings:

line 1 8

speed 9600

databits 8

parity none

flowcontrol none

Also you could eventually try to upgrade your IOS if that's possible - your IOS on the 2509 is so old that I am even wondering whether you have booted into a full IOS or to the BootROM by any accident (the BootROM on 2500 series contains a limited IOS somewhere around the 11.3 version, similar to yours). What does the show version say about the boot image location?

Still, all these suggestions are only guesses on my part - they may not be successful. Still, I believe they are at least worth trying.

Best regards,

Peter

New Member

Re: 2509 issue

Hi Peter thanks for applying to my post, the Console framing error i got was when i where hitting the enter key. So why  does it work when a switch or a router is booting and not when it's finished booting. And yes it’s booting into the full IOS version. I set speed, data bits, parity and flow control but no luck.

Show version command output:

Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-D-L), Version 11.3(7)T,  RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1998 by cisco Systems, Inc.
Compiled Tue 01-Dec-98 12:29 by ccai
Image text-base: 0x03034AA0, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFT
WARE (fc1)

AS uptime is 10 minutes
System restarted by power-on
System image file is "flash:c2500-d-l.113-7.T.bin", booted via flash

cisco 2509 (68030) processor (revision M) with 6144K/2048K bytes of memory.
Processor board ID 07885341, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
8 terminal line(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

323
Views
0
Helpful
2
Replies