Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2600 Encapsulation ERROR!!!! Help Me PLease!!!

Whenever I try to configure my sub interface on my ethernet port with a IP ADDRESS I get the message below. I have tried several routers and all of them give me the same ERROR. 2620, 2610 and 2620

Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,

or ISL vLAN.

9 REPLIES
Silver

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

Before you add the IP address configure the subinterface as a dot1q trunk.

interface type slot/port.subinterface-number

encapsulation dot1q vlan-id

ip address

HTH

Steve

New Member

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

Hi,

inside the configuration in the interface, put this command:

encapsulation dot1q vlan XXX

XXX = vlan number

After this, you can put the ip address in the interface.

Merry Christmas!

New Member

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

The encapsulation command is not available I checked for it by using the ? symbol.

New Member

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

I'm sorry, not in interface. Put encapsulation command in subinterface...

New Member

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

I knew what you meant earlier. I did try it in the sub-interface. I used the ? symbol and the encap command was not available. Thanks for your help.

Cisco Employee

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

Hi Friend,

Check you image as you need to have minimum IP PLUS feature set image loaded on your router to suppotr encaosulation command.

HTH

Ankur

*Pls rate all helpfull post

New Member

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

How do I find how what image has the IP PLUS? Is there a link on Cisco's site that will tell me what IOS will include it for my 2620? You have been really helpful.

Hall of Fame Super Silver

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

Charlie

If you post the output of show version, there is information included in the file name that will normally tell which feature set of code you are running.

You may use the Feature Navigator on the Cisco site to investigate what versions and feature sets of code for 2620 support the encapsulation command:

www.cisco.com/go/fn

HTH

Rick

New Member

Re: 2600 Encapsulation ERROR!!!! Help Me PLease!!!

Thanks rburts and everyone else for your help. I think the IOS I does not have the encapsulation features I need to setup router on a stick. I also found that I need more memory to load the IOS that does. Thanks again for all your help. This site is great.

655
Views
9
Helpful
9
Replies