Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

2610 to 2950 stumper

Here's the situation...

I have a 2610xm router I'm trying to connect to a 2950 switch.

If I connect the 2950 to the router, I do not get a link.

I have tried a known-good straight through cable, and a known-good cross-over.

I have tried various combinations of speed and duplex settings on the router and switch.

I tried disabling spanning-tree portfast on the uplink interface.

I have even tried to upgrade the OS on the router. Still, no link.

I didn't have time to upgrade the OS on the switch, but its worth a shot.

Neither the switch or the router display any errors.

The Gotcha is... if I use the same cables I tried before to connect the router to a D-Link unmanaged 24-port gig switch, I get a link. If i connect the D-link to the same port on the 2950 that I tried to connect the router, I get a link. It doesn't matter if I use the straight through from the router to the d-link or the d-link to the 2950 or the cross-over. I always get a link.

So I ask...

Why won't the 2950 talk to the 2610?

Router: Version 12.4(18) I upgraded from 12.3

Switch: Version 12.1(22)EA2

attached are the router and switch configs.

114
Views
0
Helpful
0
Replies