Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2611 router - Dhcp client and server / NAT, etc

Hi all,

Very new to Cisco equipment here, taking CCNA courses now, studying, and learning lots. In addition, to facilitate this process I have bought myself a 2924 switch (which I have basically up and running) and a 2611 router.

The router is next on my list of getting to be basically functional. Right now, it's plugged in for console use only and is not on my network.

I currently have a linux server I am using as a DHCP server. I've decided to take that load off the linux box and use the 2611 as a DHCP server. Now, I also use my linux server as a router running NAT. So I have several questions.

1. I found a good document on the web about sending out (through e0/1) DHCP services. But I've found nothing about how to setup e0/1 to GET a DHCP address from my cable provider, Comcast. How can I do this?

2. How can I setup basic routing so that I have internet through the 2611? It doesn't have to be the most secure setup in the world, just functional as I get better.

Synopsis: I need to recieve a DHCP address from Comcast on e0/0. I need to send out a DHCP signal from e0/1 (I think I can this myself, though). I need to route (very basic).

Help would be greatly appreciated. I just need to avoid my own personal network downtime, so I'd really like someone to just help me get this running. Many thanks!

Chris

4 REPLIES

Re: 2611 router - Dhcp client and server / NAT, etc

Quite simple,

for example,

say you have 2 interfaces on your 2611

e0/0 and e0/1

do:

int e0/0

ip address dhcp

int e0/1

ip address 192.168.0.1 255.255.255.0

ip dhcp exclude 192.168.0.1

ip dhcp pool mypool

network 192.168.0.0 /24

default-router 192.168.0.1

you can add the following options:

r1(dhcp-config)#?

DHCP pool configuration commands:

accounting Send Accounting Start/Stop messages

bootfile Boot file name

client-identifier Client identifier

client-name Client name

default-router Default routers

dns-server DNS servers

domain-name Domain name

exit Exit from DHCP pool configuration mode

hardware-address Client hardware address

host Client IP address and mask

import Programatically importing DHCP option parameters

lease Address lease time

netbios-name-server NetBIOS (WINS) name servers

netbios-node-type NetBIOS node type

network Network number and mask

next-server Next server in boot process

no Negate a command or set its defaults

option Raw DHCP options

origin Configure the origin of the pool

subnet Subnet allocation commands

update Dynamic updates

utilization Configure various utilization parameters

vrf Associate this pool with a VRF

you also need to set up a default route pointing to the IP of your gateway.

ip route 0.0.0.0 0.0.0.0 IP-OF-GATEWAY

Vlad

New Member

Re: 2611 router - Dhcp client and server / NAT, etc

Vlad,

I will attempt this tomorrow and will post back with results. Thank you so much.

Chris

New Member

Re: 2611 router - Dhcp client and server / NAT, etc

Hi Vlad,

I'm sorry it took so long to get back to you. I've had several family issues that have interfered severely into me continuing with my migration.

I'm fuzzy on only one thing before I start...

"you also need to set up a default route pointing to the IP of your gateway.

ip route 0.0.0.0 0.0.0.0 IP-OF-GATEWAY "

If my default-router (e0/1) is 192.168.5.73, what will this command be? I'm confused because it obviously can't be set to an IP address since the IP from Comcast is dynamic and therefore might, and will change. In other words, how do I know what the IP-OF-GATEWAY is?

Thanks, Vlad!

Chris

New Member

Re: 2611 router - Dhcp client and server / NAT, etc

I think I might know what I've got to do entirely, but I wanted to run this past the experts here first. Can someone please read this over and tell me if I am missing anything, please? Thanks!

My IP addressing scheme is 192.168.5.0 255.255.255.0

1. My 2611 has two interfaces: e0/0 and e0/1. My first question is really, really stupid because I think I know the answer. Being that these are ethernet, and not fast ethernet (well, to the best of my knowledge anyway), does this mean they're only 10Mb, not 100Mb?

2. Configure routing

Router(config)# router rip

Router(config-router)# network 192.168.5.0

Missing anything?

3. Now, since I have Comcast and they send out DHCP addresses, I obviously need to set e0/0 to recieve a DHCP address. I've found documents on the web and from what I can determine, it boils down to me doing:

Router(config)#int e0/0

Router(config-if)#ip address dhcp

Anything else I need to do on this interface for DHCP reception purposes?

4. Setting up int e0/1 to hand out addresses internally.

Router(config)# ip dhcp pool bartlett

Router(dhcp-config)# network 192.168.5.0/24

Router(dhcp-config)#domain-name mydomain.net - Do I really need this?

Router(dhcp-config)#dns-server 192.168.5.1

192.168.5.1 - Do I really need this?

Router(dhcp-config)#default-router 192.168.5.73 - This is the IP address of e0/1 on this very router.

Router(dhcp-config)#lease 7

Router(dhcp-config)#

ip dhcp exclude 192.168.5.73 - Router's e0/1 interface

Router(dhcp-config)#ip dhcp exclude

192.168.5.3 - Other static device I need to remove from DHCP pool

Router(dhcp-config)#ip dhcp exclude 192.168.5.7

- Other static device I need to remove from DHCP pool

Router(dhcp-config)#ip dhcp exclude 192.168.5.27 - Other static device I need to remove from DHCP pool

Router(dhcp-config)#ip dhcp exclude 192.168.5.33 - Other static device I need to remove from DHCP pool

Router(dhcp-config)#ip dhcp exclude 192.168.5.1 - Other static device I need to remove from DHCP pool

Does that all look right for setting up basic DHCP? Am I missing anything?

5. Configure NAT.

Router(config)# access-list 77 192.168.5.0 0.0.0.255

Router(config)# int e0/0

Router(config-if)# ip access-group 77 out

Router(config)# access-list 77 deny all

Router(config)# access-list 77 permit 192.168.5.0 0.0.0.255

Router(config)# ip nat inside source list 77 int e0/0 overload

Router(config)# int e0/0

Router(config-if)# ip nat outside

Router(config)# int e0/1

Router(config-if)# ip nat inside

Router(config)# ip route 0.0.0.0 0.0.0.0 e0/0

Missing anything?

Ok, whew! I think that's it! If you could please evaluate this plan o' mine, alter it if necessary, and generally let me know what you think, I'd appreciate it.

Regards,

Chris (Cisco newbie)

1371
Views
0
Helpful
4
Replies
CreatePlease to create content