Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2611 router

i have started to train for my CCNA. I bought a 2600 router and a 2900xl switch to hook up at home. I have been problems getting my router to get on the internet. I set up

e0/0 adpater 192.168.1.1/24 and set the e0/1 to get dhcp from comcast. I am using a windows 2003 server for my internal DNS and DHCP. I set the nat inside and outside and my access list to permit any. I just can't sem to get a web page to open on my server

15 REPLIES

Re: 2611 router

Do you have a ip route 0.0.0.0 0.0.0.0 to your e0/1 interface for routes to all unknown networks?

Command is as follows

"ip route 0.0.0.0 0.0.0.0 int e0/1"

New Member

Re: 2611 router

here is the running-config it still did not work so i tried to put the route on both

interface Ethernet0/0

description Internet

ip address dhcp

ip nat outside

no ip route-cache

full-duplex

!

interface Ethernet0/1

description Internal

ip address 192.168.1.1 255.255.255.0

ip nat inside

no ip route-cache

full-duplex

!

ip nat inside source list 1 interface Ethernet0/0 overload

no ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0/1

ip route 0.0.0.0 0.0.0.0 Ethernet0/0

!

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

!

Re: 2611 router

you should only have one route.

Take ip route 0.0.0.0 0.0.0.0 Ethernet0/1 out of your config.

Also try pinging google's ip or any internet ip and see if you get a reply. If you do a sh ip int brief, do you have an ip? Also are you connecting to a comcast DSL router?

Also have you verified your switch config is correct and the default gateway on your server is 192.168.1.1

New Member

Re: 2611 router

first how do i remove a route, second while in the router i can ping yahoo.com and get a responce but no for anything else(microsoft,google,ect)

I have nothing configured in the switch exept the ip address so i can telnet in. I have an ip from comcast(69.253.81.216/25 and my server is set to the 192.168.1.1

Re: 2611 router

Just put a no in front of the ip route statement

Example: "no ip route 0.0.0.0 0.0.0.0 int e0/1"

hmm you can only ping yahoo and nothing else? From your browser can you get to yahoo? If you can ping yahoo then you do have external access. Not sure why though you can not ping other web sites.

New Member

Re: 2611 router

when at the router#ping www.yahoo.com i get a responce, from windows IE or even the windows CDM i get page error or destionation host not found

Re: 2611 router

Have you verified your dns config on your server? Try pinging from the router by IP, not URL.

74.125.47.103 is one of google's ip.

Also try doing a nslookup from your server and see if you can resolve hostnames. If you cant, it sounds like a dns issue.

New Member

Re: 2611 router

no luck, I have three of comcasts DNS server address set as forwarders in my dns, i can see the router using them.

Re: 2611 router

have you tried a trace route from your router to a public ip? I dont know why only yahoo would respond and not other public ip addresses.

New Member

Re: 2611 router

i have check and double checked all my settings. This is the adapter i have set to recive a ip address from comcast and when i console in to the router i see lines and lines just like this.

*Mar 1 00:09:49.385: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/

0, changed state to down

*Mar 1 00:09:52.218: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/

0, changed state to up

*Mar 1 00:09:54.638: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/

0, changed state to down

Re: 2611 router

Have you checked your speed and duplex settings and do you have the correct cable type between the 2?

New Member

Re: 2611 router

Before i recived the router a foctory reset was done.

modem-router, router-switch, switch-pc all with straight though cat5

Hall of Fame Super Silver

Re: 2611 router

Richard

I would have thought that the connection from modem to router would be a cross over cable rather than a straight through as you seem to indicate. Try changing the cable and see if it makes any difference.

HTH

Rick

New Member

Re: 2611 router

just to let everyone know it was my older comcast modem. after i replced it everything work fine

Hall of Fame Super Silver

Re: 2611 router

Richard

Thank you for posting back to the forum to indicate that your issue was resolved and for identifying what did resolve it.

HTH

Rick

179
Views
0
Helpful
15
Replies