Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2800 router and 3750 switch won't create gigabit trunk

Hi there Tech-xperts,

I have a 2800 router and 3750 switch that will not operate at Gigabit speed. I've tried various combinations of fixed/auto speed and duplex settings, but they only seem to talk to each other when set to 100Mb.

Any fixes or suggestion greatly appreciated.

2821 router 12.4(20)T1

3750 switch Version 12.2(25)FZ

(3750 is actually a WS-C3750G-24WS-S25)

These are directly connected via a UTP cable.

The router interface config:

interface GigabitEthernet0/1

no ip address

duplex full

speed 100

!

interface GigabitEthernet0/1.500

encapsulation dot1Q 500 native

ip address 10.10.150.1 255.255.255.0

!

interface GigabitEthernet0/1.520

encapsulation dot1Q 520

ip address 10.10.120.1 255.255.255.0

!

interface GigabitEthernet0/1.521

encapsulation dot1Q 521

ip address 10.10.121.1 255.255.255.0

!

The switch interface config:

interface GigabitEthernet1/0/1

description rtr INMRTR01 via Riverbed

power inline never

switchport trunk encapsulation dot1q

switchport trunk native vlan 500

switchport mode trunk

duplex full

spanning-tree portfast

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: 2800 router and 3750 switch won't create gigabit trunk

I would say you have a faulty patch cable if it won't negotiate gig speed with both sides as auto. Gigabit uses all 8 wires to achieve gig whereas it uses 1,2,3,6 for any lower speeds . So if you don't have 8 good wires in your patch cable or connection between these 2 devices you won't get gig speed.

2 REPLIES
Purple

Re: 2800 router and 3750 switch won't create gigabit trunk

I would say you have a faulty patch cable if it won't negotiate gig speed with both sides as auto. Gigabit uses all 8 wires to achieve gig whereas it uses 1,2,3,6 for any lower speeds . So if you don't have 8 good wires in your patch cable or connection between these 2 devices you won't get gig speed.

New Member

Re: 2800 router and 3750 switch won't create gigabit trunk

Thank Glen,

New cable fixed it. Surprisingly the existing 1/2 meter cable tests ok with my (basic) cable tester.

Roof

227
Views
0
Helpful
2
Replies