Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2800 vs 1841 Question

Have a quick question that is probably easily answered by someone that knows more than I do.

I have 2 seperate remote locations.   One with a 2800 series router and one with an 1841 router.   We are doing VOIP at the site with the

2800 series router and therefore utilize multiple VLAN's on the router (data, voice, wireless, etc).    I have created multiple VLAN interfaces

on the router to coincide with the appropriate networks.    I have no problems with this location.  However, it leads me to the other site that has

the 1841 router.    I am trying to create VLAN interfaces on that router and it doesnt seem to be an option.  It actually has a newer version of IOS than

the 2800.  

1841     =     12.4(25)

2800     =     12.4(9)T7

So does the 1800 not support this feature or is there something i'm missing?   Why is it I can create VLAN interfaces on a 2821, but not on the 1841.

I'm sure that this is probably a dumb question to most of you and I'm probably the only one that doesn't know the answer, but i've found this forum to be

extremely helpful as all of you guys seem to know your stuff.    I figured this is the place to go for answers! :).

2 ACCEPTED SOLUTIONS

Accepted Solutions
Bronze

Re: 2800 vs 1841 Question

Does your 1841 connect to an external switch? If so, you should probably use subinterfaces instead of VLAN interfaces. I'm guessing the 2821 has somthing like the NM-16ESW or somthing similar in it (16 port switch module)? If that's the case, you can create the multiple VLAN interfaces without problems. I know the 1841 doesnt have that same option, but you could potentially have a 4-port switch in there. What's the hardware setup? If you don't have an additional switch module in the 1841, try subinterfaces with a trunk to your switch to acheive the same results.

interface fa0/0.1

description voice

encapsulation dot1q

ip address x.x.x.x y.y.y.y

interface fa0/0.2

description wireless

encapsultaion dot1q

ip address w.w.w.w v.v.v.v.v

interface fa0/0.3

description data

encapsulation dot1q

ip address t.t.t.t u.u.u.u

Hope to Help.

New Member

Re: 2800 vs 1841 Question

As described in the previous reply, i would say that you can check if your 2800 router is using a Ether switch module or not?

You can only configure the vlan interfaces on it if you have a HWIC-4ESW,HWIC-9ESW or Network modules or NME modules.

++ If you are using a router which doesn't have any of them then you might have to use the subinterface commands.

You can refer the following link for the same:

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/miragenm.html

3 REPLIES

Re: 2800 vs 1841 Question

Have a quick question that is probably easily answered by someone that knows more than I do.

I have 2 seperate remote locations.   One with a 2800 series router and one with an 1841 router.   We are doing VOIP at the site with the

2800 series router and therefore utilize multiple VLAN's on the router (data, voice, wireless, etc).    I have created multiple VLAN interfaces

on the router to coincide with the appropriate networks.    I have no problems with this location.  However, it leads me to the other site that has

the 1841 router.    I am trying to create VLAN interfaces on that router and it doesnt seem to be an option.  It actually has a newer version of IOS than

the 2800.  

1841     =     12.4(25)

2800     =     12.4(9)T7

So does the 1800 not support this feature or is there something i'm missing?   Why is it I can create VLAN interfaces on a 2821, but not on the 1841.

I'm sure that this is probably a dumb question to most of you and I'm probably the only one that doesn't know the answer, but i've found this forum to be

extremely helpful as all of you guys seem to know your stuff.    I figured this is the place to go for answers! :).

Hi,

Try with vlan database configuration

router#vlan database
vlan 5 name ()

or try with below level of configuration

If you add an interface to a non-existent VLAN the router will create the VLAN for you.

configure terminal
interface fa0/0/0
switchport mode access
switchport access vlan 5


Then you need to assign an IP to the VLAN interface so that traffic can hit it:
interface vlan 5
ip address 172.168.210.1 255.255.252.0
no shutdown

Hope to help !!

Ganesh.H

Remember to rate the helpful post

Bronze

Re: 2800 vs 1841 Question

Does your 1841 connect to an external switch? If so, you should probably use subinterfaces instead of VLAN interfaces. I'm guessing the 2821 has somthing like the NM-16ESW or somthing similar in it (16 port switch module)? If that's the case, you can create the multiple VLAN interfaces without problems. I know the 1841 doesnt have that same option, but you could potentially have a 4-port switch in there. What's the hardware setup? If you don't have an additional switch module in the 1841, try subinterfaces with a trunk to your switch to acheive the same results.

interface fa0/0.1

description voice

encapsulation dot1q

ip address x.x.x.x y.y.y.y

interface fa0/0.2

description wireless

encapsultaion dot1q

ip address w.w.w.w v.v.v.v.v

interface fa0/0.3

description data

encapsulation dot1q

ip address t.t.t.t u.u.u.u

Hope to Help.

New Member

Re: 2800 vs 1841 Question

As described in the previous reply, i would say that you can check if your 2800 router is using a Ether switch module or not?

You can only configure the vlan interfaces on it if you have a HWIC-4ESW,HWIC-9ESW or Network modules or NME modules.

++ If you are using a router which doesn't have any of them then you might have to use the subinterface commands.

You can refer the following link for the same:

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/miragenm.html

936
Views
0
Helpful
3
Replies
CreatePlease to create content