Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

2811 Router with Vlan and NAT

Hi All,

Would appreciate a reply for the following scenario. I have an IPT environment with 3 dot1q vlans on a 3560 switch...infrastructure vlan 10 (10.1.1.0), voice vlan 20(10.1.2.0), data vlan 30(10.1.3.0). The switch is connected to a 2811 fast ethernet port. My question is, if I am receiving just 1 IP (192.1.1.x) for the internet connection to the 2811 router, how do I configure the fast ethernet port for nat and also for the individual vlans that are connecting to it. Would the static routes be advisable for the connection to the vlans? Any recommendations are appreciated!

Thanks guys

4 REPLIES
Hall of Fame Super Blue

Re: 2811 Router with Vlan and NAT

Hi

Not 100% sure what you are asking. Do you mean you have one public IP address allocated to the outside interface of your 2811 router ?

Assuming this is what you mean you can setup NAT as follows

(Assume interface with your public IP address is fa0/1)

access-list 101 permit ip 10.1.1.0 0.0.0.255 any

access-list 101 permit ip 10.1.2.0 0.0.0.255 any

access-list 101 permit ip 10.1.3.0 0.0.0.255 any

ip nat inside source list 101 interface fa0/1 overload

int fa0/0

ip nat inside

int fa0/1

ip nat outside

HTH

Jon

New Member

Re: 2811 Router with Vlan and NAT

Thank you for the reply Jon. Yes, I have 1 Public IP address coming from a T1 data connection. The outside interface would be the serial associated with the T1 connection. For the inside interface, do I need to create subinterfaces for each vlan?

For example:

int fa0/0.1 for infrastruture

description ***infrastructure Vlan***

encapsulation dot1Q 10

ip address 10.1.1.0 255.255.255.0

ip nat inside

etc...for fa0/0.2 and fa0/0.3

I appreciate the help!

Re: 2811 Router with Vlan and NAT

Hi

yes u need to create sub-interfaces in order to enable routing between the vlans.

Thanks

Mahmood

New Member

Re: 2811 Router with Vlan and NAT

Thank you for the info.

Can you offer suggestions for my static routes for the ISP and the subinterfaces?

I almost have the understanding of how it all connects.

Thanks!

325
Views
0
Helpful
4
Replies
CreatePlease to create content