Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2911 switch WIC and onboard gi0/0 layer 2 connectivity

We have a 2911 with an EHWIC-D-8ESG-P and SRE-900 installed.  A PC is connected to Gi0/3/0 and an upstream L3 switch, with a configured VLAN21 interface, is connected via Gi0/0.21.

The router can ping the upstream VLAN21 interface of 10.11.16.1 but can not ping the PC connected to the WIC switch on interface Gi0/3/0.

The PC on Gi0/3/0 is addressed 10.11.16.92.

VM Windows Server 2003 at 10.11.16.91 and they can ping each other.

**********************************************

2911 config info:

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.21
description PrimaryLAN
encapsulation dot1Q 21
ip address 10.11.16.98 255.255.255.0

!

interface GigabitEthernet0/3/0
switchport access vlan 21
spanning-tree portfast

!

interface Vlan21
ip unnumbered GigabitEthernet0/0.21

**********************************************

SRE info:

SRETest2# sh hypervisor vswitch
Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks  
vSwitch0         128         3           128               1500    vmnic2  

  PortGroup Name        VLAN ID  Used Ports  Uplinks  
  VM Network VLAN 21    21       0           vmnic2  

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: 2911 switch WIC and onboard gi0/0 layer 2 connectivity

Hi,

Please do the following:

bridge irb

bridge 21 protocol ieee

bridge 21 route ip

interface GigabitEthernet0/0.21
description PrimaryLAN
encapsulation dot1Q 21
bridge-group 21

interface Vlan21
bridge-group 21

interface bvi 21

ip address 10.11.16.98 255.255.255.0

Make sure that you remove IP address from gig 0/0.21 and ip unnumber under vlan 21.

4 REPLIES
Silver

Re: 2911 switch WIC and onboard gi0/0 layer 2 connectivity

Issue from from the PC.

I wonder if you can provide the following output:

show ip arp 10.11.16.91

show ip arp 10.11.16.98

show mac address-table interface gig 0/3/0

I wonder if you want to configure IRB:

http://www.cisco.com/en/US/partner/docs/ios/bridging/configuration/guide/br_transprnt_brdg_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1041949

Put VLAN 21 and gi 0/0.21 on bridge group 21. Enable routing (bridge-group 21 route IP) on the router. It should work.

New Member

Re: 2911 switch WIC and onboard gi0/0 layer 2 connectivity

The laptop still is unable to ping the Gi0/0.21 or upsteam interface 10.11.16.1

**********************************************************

Configs added to the router:

bridge irb

interface GigabitEthernet0/0.21
description PrimaryLAN
encapsulation dot1Q 21
ip address 10.11.16.98 255.255.255.0
bridge-group 21

interface Vlan21
ip unnumbered GigabitEthernet0/0.21
bridge-group 21

**********************************************************

SREUnit2#  ping 10.11.16.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.11.16.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
SREUnit2#sh ip arp           
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.11.16.1            128   0000.0c07.ac01  ARPA   GigabitEthernet0/0.21
Internet  10.11.16.7             14   0012.4496.3580  ARPA   GigabitEthernet0/0.21
Internet  10.11.16.98             -   d0d0.fd93.a370  ARPA   GigabitEthernet0/0.21
Internet  10.11.18.1              1   4000.0000.5474  ARPA   GigabitEthernet0/0.21
Internet  192.168.74.50           -   d0d0.fd93.a380  ARPA   SM1/0
Internet  192.168.74.129          -   d0d0.fd93.a373  ARPA   Vlan1
SREUnit2#
SREUnit2#
SREUnit2#
SREUnit2#
SREUnit2#
SREUnit2#sh mac-address-table

EHWIC Slot: 3
Destination Address     Address Type    VLAN    Destination Port
-------------------     ------------    ----    -----------------
4000.000f.5474          Dynamic           21    GigabitEthernet0/3/0
d0d0.fd93.a373          Self              21    Vlan21
d0d0.fd93.a373          Self               1    Vlan1

SREUnit2#sh clock
10:53:27.744 CST Tue Nov 9 2010
SREUnit2#sh clock
10:58:28.540 CST Tue Nov 9 2010
SREUnit2#

********************************************

FYI

I case anyone notices and to avoid confusion, 4000.0000.5474 is my laptop and am connected via telnet to the router at 10.11.16.98 (hence in the arp table) and the test laptop connected to Gi0/3/0 is 4000.000f.5474.  Yep, I use LAA for ease of troubleshooting issues.

Silver

Re: 2911 switch WIC and onboard gi0/0 layer 2 connectivity

Hi,

Please do the following:

bridge irb

bridge 21 protocol ieee

bridge 21 route ip

interface GigabitEthernet0/0.21
description PrimaryLAN
encapsulation dot1Q 21
bridge-group 21

interface Vlan21
bridge-group 21

interface bvi 21

ip address 10.11.16.98 255.255.255.0

Make sure that you remove IP address from gig 0/0.21 and ip unnumber under vlan 21.

New Member

Re: 2911 switch WIC and onboard gi0/0 layer 2 connectivity

All is working. Thanks for your assistance. It is greatly appreciated.

Test laptop on Gi0/3/0 able to ping VMServer at 10.11.16.92 and gateways at 10.11.16.1

VMServer able to ping laptop and gateway.

2386
Views
0
Helpful
4
Replies