Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2924XL switch showing undersize input packets

7206 with IO controller and PA-FE-TX running c7200-is-mz.123-14.T2.bin connected to a 2924XL running c2900XL-c3h2s-mz-120.5-XU.bin. Excessive input errors experienced on 2924XL switch port from router:

TGP-PRODSW#sho int fa 0/24

FastEthernet0/24 is up, line protocol is up

Hardware is Fast Ethernet, address is 0002.7d35.cb58 (bia 0002.7d35.cb58)

Description: TGP Production Router Fa 4/0.1

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 245/255, txload 1/255, rxload 5/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:17, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 2054000 bits/sec, 234 packets/sec

5 minute output rate 254000 bits/sec, 216 packets/sec

205622 packets input, 224228456 bytes

Received 4790 broadcasts, 15467 runts, 0 giants, 0 throttles

15467 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 257 multicast

0 input packets with dribble condition detected

178268 packets output, 29248414 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

TGP-PRODSW#sho controllers ethernet-controller fa 0/24

Transmit Receive

30008640 Bytes 233020574 Bytes

178969 Unicast frames 207670 Unicast frames

4274 Multicast frames 258 Multicast frames

367 Broadcast frames 1096 Broadcast frames

0 Discarded frames 0 No bandwidth frames

0 Too old frames 0 No buffers frames

0 Deferred frames 217 No dest, unicast

0 1 collision frames 2 No dest, multicast

0 2 collision frames 3449 No dest, broadcast

0 3 collision frames 0 Alignment errors

0 4 collision frames 0 FCS errors

0 5 collision frames 0 Collision fragments

0 6 collision frames

0 7 collision frames 15814 Undersize frames

0 8 collision frames 6300 Minimum size frames

0 9 collision frames 29186 65 to 127 byte frames

0 10 collision frames 6696 128 to 255 byte frames

0 11 collision frames 9727 256 to 511 byte frames

0 12 collision frames 19470 512 to 1023 byte frames

0 13 collision frames 141313 1024 to 1518 byte frames

0 14 collision frames 0 Oversize frames

0 15 collision frames

0 Excessive collisions

0 Late collisions

Speed/duplex on both ends hard-set to 100-full across a 4-5 foot CAT5 patch cable between the two systems. Spare PA-FE-TX card, spare 2924XL, and another patch cables all tried with same results. No other port on switch showing these issues.

Thoughts - IOS bug in router???

4 REPLIES
Purple

Re: 2924XL switch showing undersize input packets

Can't you post both interface configs , still looks like a speed/duplex issue as you are getting runts and input errors and also your reliability field only shows 245/255 , it should show 255/255 . Post a "show int status" from the 2924.

New Member

Re: 2924XL switch showing undersize input packets

'show int status' command not supported in this version of IOS.

Switch:

interface FastEthernet0/24

description TGP Production Router Fa 4/0.1

duplex full

speed 100

switchport trunk encapsulation dot1q

switchport mode trunk

!

Router:

interface FastEthernet4/0

description PROD_TRUNK

no ip address

no ip redirects

no ip unreachables

ip route-cache flow

no ip mroute-cache

duplex full

!

interface FastEthernet4/0.1

description Connected to WLT&FOR-MANAGE_NET

encapsulation dot1Q 1 native

ip address x/y secondary

ip address x/y

no snmp trap link-status

!

interface FastEthernet4/0.2

description Connected to WLT_BRDNT_&_YCI

encapsulation dot1Q 2

ip address x/y secondary

ip address x/y secondary

ip address x/y secondary

ip address x/y

ip access-group CUSTOMER_BLINDERS_WITH_PROTECT in

no ip redirects

no ip unreachables

no snmp trap link-status

no cdp enable

!

interface FastEthernet4/0.3

description Connected to WLT_CANOPY_&_FOR_BRDNT

encapsulation dot1Q 3

ip address x/y secondary

ip address x/y secondary

ip address x/y secondary

ip address x/y ip access-group CUSTOMER_BLINDERS_WITHPROTECT in

no ip redirects

no ip unreachables

no snmp trap link-status

no cdp enable

!

interface FastEthernet4/0.4

description Connected to FOR Canopy

encapsulation dot1Q 4

ip address x/y secondary

ip address x/y

ip access-group CUSTOMER_BLINDERS_WITHPROTECT in

no ip redirects

no ip unreachables

no snmp trap link-status

no cdp enable

Purple

Re: 2924XL switch showing undersize input packets

You are right don't see anything specific there , check to see if the router interface will take a speed command . Some FE interfaces were configurable for 10 or 100 , it might help to hardcode the speed if it takes it . If there is no speed command then not sure what it would be but it sure doesn't look right with the runts and the reliability field way off . Did you try a different port on the 2924 and did the problem still show itself? Also on the FE interfaces if it has both a fiber and copper port for the same interface you have to select the media type . Don't know off the top of my head whether you have to do that with your FE adaptor or not , just something to keep in mind.

New Member

Re: 2924XL switch showing undersize input packets

Router doesn't support the speed command. Switch was originally connected to the integrated Fast Ethernet port on the I/O controller. Added a PA-FE-TX to the chassis with no change. Tried different switch ports in the original switch with no change. Tried a different switch with no change. Tried different patch cables with no change.

Have swapped everything except the router chassis, I/O controller, and router IOS at this juncture.

274
Views
0
Helpful
4
Replies