Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

2950's and 2940's

Occasionally some of my 2940's or 2950's will become unmanageable. That is layer 2 traffic passes through it but I can no longer telnet, ping, or anything the switch itself. Has anyone else had this problem? I thought it was maybe a memory issue.

8 REPLIES
Cisco Employee

Re: 2950's and 2940's

Have you monitor the memory utilization before or after this happened. What do you do when this problem happens. What is the IOS running on the switches. Did you check the switch logs for some errors on this.

It could be related to some software issues as well. Have you tried upgrading the IOS on thye switches.

-amit singh

Community Member

Re: 2950's and 2940's

I usually had this problem after imaging computers. After configuring igmp snooping and getting pim set up on my router, I have not had this problem since. the only way for me to recover was to reboot the switch.

Community Member

Re: 2950's and 2940's

I have the same problem with my 2940 Switches.

The switches become unresponsive to telnet/ping, but still forward all traffic.

The logs didn't contain any errors. (Only infrequent interface up/downs, due to PCs reconnecting)

Our 2940 switches are running for over a year in low traffic areas of our network. The failing switches still got more traffic than the rest of the 2940s.

IOS is 12.1(22)EA4.

How do I monitor memory utilization?

How can I obtain a new IOS?

Purple

Re: 2950's and 2940's

Latest release is 12.1.22.EA10a for 2940's . We have a lot of 2950's and have never seen that problem , think 12.1.22 ea10 is the latest for those too.

Community Member

Re: 2950's and 2940's

It is limited to just a few of these devices. I have removed one 2940 permanently. That definitely fixes that problem.

Community Member

Re: 2950's and 2940's

Use the show mem command and look under Largest(b), which is the largest amount of contiguous bytes available. Check to see if that number is droppong. As far as new IOS, if you have smartnet you can download a new image from CCO.

Community Member

Re: 2950's and 2940's

Yes, I have tried upgrading the IOS but the problem persisted. Fortunately, I have begun migrating away from these switches.

Silver

Re: 2950's and 2940's

I've seen this happen on several switches as well. In my case it happened because of a process that ran to long in CPU which itself turned out to be a bug (which only showed under mediate or high traffic patterns when multiple vlan interfaces where configured).

Typical recommendation here is to check your current version's release notes to see if there are any caveats and upgrade the switch to the latest release.

HTH,

Leo

186
Views
0
Helpful
8
Replies
CreatePlease to create content