Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

2950 Telnet Access Not Working

I have several 2950's that I am unable to telnet to. I have connected to their neighbors and CDP is working correctly and updating. If you reboot the switch it usually resolves the issue for a brief before, but then eventually stops working. All other traffic passes without issue to and from the switch but telnet does not work.

Does anyone know of any IOS bugs or known issues like this?

10 REPLIES
Community Member

Re: 2950 Telnet Access Not Working

Can you paste a sh ver and sh run for us?

Community Member

Re: 2950 Telnet Access Not Working

! No configuration change since last restart

version 12.1

no service pad

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

hostname HOSTNAME

logging buffered 16384 debugging

aaa new-model

aaa authentication login default group tacacs+ line

aaa authentication enable default group tacacs+ enable

enable secret xxx

enable password*****

clock timezone EST -5

clock summer-time EDT recurring

logging trap debugging

logging ***********

tacacs-server host *********

tacacs-server key *********

ntp server **********

IP

IP-IP Global

ip subnet-zero

ip default-gateway 192.168.5.1

ip http server

Spanning-tree

spanning-tree extend system-id

Interface

Interface-Interface FastEthernet0/1

interface FastEthernet0/1

switchport mode access

no ip address

spanning-tree portfast trunk

Interface-Interface FastEthernet0/2

interface FastEthernet0/2

switchport mode access

no ip address

spanning-tree portfast trunk

Interface-Interface GigabitEthernet0/1

interface GigabitEthernet0/1

switchport mode trunk

no ip address

Interface-Interface Vlan1

interface Vlan1

ip address 192.168.5.21 255.255.255.0

no ip route-cache

SNMP

snmp-server engineID local xxx

snmp-server community ***** RO

snmp-server community ***** RW

snmp-server system-shutdown

Line

Line-Line con 0

line con 0

password*****

Line-Line vty 0 4

line vty 0 4

password*****

Line-Line vty 5 15

line vty 5 15

password*****

Community Member

Re: 2950 Telnet Access Not Working

Also, HTTP access does not work to the device either.

I have changed the IP information, I have verified that information already and I was able to connect to the device last week, but this morning when I came in I was unsuccessful.

Hall of Fame Super Blue

Re: 2950 Telnet Access Not Working

Hi

Some obvious things to check, apologies if they are a bit basic, please don't take offence.

1) Have you checked that all your telnet lines are not in use ? (unlikely but it has happened)

2) Are you sure that your switch IP address has not been allocated to another device. So if it is not working can you still ping the IP address and if so what mac address is showing up in the arp table on your PC.

3) When you say telnet does not work are you getting a prompt or does it just timeout ?

Just out of interest do you have servers connected on fa0/1 & fa0/2 that are running 802.1q trunking on their Nic's. I only ask as you have the spanning-tree portfast trunk statement in the config.

HTH

Community Member

Re: 2950 Telnet Access Not Working

1) I have not checked if the telnet lines are in use, but there are only 3 people who have access to log into devices in our network and the other two people said they have not gone to that switch

2) I am unable to ping the IP address of the VLAN 1 interface

3) It timesout prior to opening the session.

HTTP session attempts also time out. This has happened on a lot of other 2950's we have in our infrastructure which is why I am thinking it is a much larger issue.

No, not sure why the ports have those commands. This is an access switch in an end user closet so it should not have the trunk command on the end. I will have to remove that, if and when I can telnet to the switch

Community Member

Re: 2950 Telnet Access Not Working

I would recommend trying a different rev of IOS. Since I see that the switchports are taking the "no ip address" command it looks like maybe you have a layer 3 IOS on there? I've seen problems arise from this on 2950s before.

Are all of your switches on the same rev?

Also verify that VLAN1 isn't shut down for some reason.

HTH

Community Member

Re: 2950 Telnet Access Not Working

Correct, all our 2950's run EMI. The majority of them are on the same IOS version so I will download the latest and see if I can push it out tonight.

Thanks.

Community Member

Re: 2950 Telnet Access Not Working

Just ping to VLAN 1 after configuring

if u have stil problem then create vlan 2 and ping to it if it pinging then try to telnet vlan2 hope you won't get problem and all 2950 series comes with EMI so this is not a problem

hope this may help yuo

Community Member

Re: 2950 Telnet Access Not Working

You need the login command see below:

line vty 0 4

password *********

login

Purple

Re: 2950 Telnet Access Not Working

Also add the command "exec-timeout 15 " to all your vty and console ports , this will logout any telnet sessions after 15 minutes of activity.

586
Views
0
Helpful
10
Replies
CreatePlease to create content