Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2960 and Broadcom BCM5716C card problems

I have a 2960G-48TC-L and connected server with BCM5716C card.  This server is runing Windows Server 2003 and serving DHCP.  When the server is started the Netlogon service reports an error indicating no domain servers are available, DHCP service fails also.  Netlogon starts however DHCP does not, but I can manually start it without a problem.  It's as though the network connection has not finished initializing for some reason, however in the event viewer I see the NIC has completed it's connection.  If I plug the server into another Linksys switch it is able to startup without these errors.

I'd like to connect this server to the gigabit switch.  Should I upgrade the IOS?  It is currently running 12.2(25)SEE1.  If so which IOS should I upgrade to and anyother concerns I should have?


Thanks for any help you can provide.

JH

Everyone's tags (2)
6 REPLIES
Hall of Fame Super Blue

Re: 2960 and Broadcom BCM5716C card problems

missionbell wrote:

I have a 2960G-48TC-L and connected server with BCM5716C card.  This server is runing Windows Server 2003 and serving DHCP.  When the server is started the Netlogon service reports an error indicating no domain servers are available, DHCP service fails also.  Netlogon starts however DHCP does not, but I can manually start it without a problem.  It's as though the network connection has not finished initializing for some reason, however in the event viewer I see the NIC has completed it's connection.  If I plug the server into another Linksys switch it is able to startup without these errors.

I'd like to connect this server to the gigabit switch.  Should I upgrade the IOS?  It is currently running 12.2(25)SEE1.  If so which IOS should I upgrade to and anyother concerns I should have?


Thanks for any help you can provide.

JH

James

Just a quick check - have you enabled "spanning-tree portfast" on the port the server is connected into ?

Jon

New Member

Re: 2960 and Broadcom BCM5716C card problems

Not sure.  It's been a while since I've config thru the CLI.  I've recently only been using the GUI.  What is the easiest way to determine this?

Hall of Fame Super Blue

Re: 2960 and Broadcom BCM5716C card problems

missionbell wrote:

Not sure.  It's been a while since I've config thru the CLI.  I've recently only been using the GUI.  What is the easiest way to determine this?

I'm not familiar with the GUI but easiest way for me would simply to do a "sh run" and check the config for the relevant interface.

Jon

New Member

Re: 2960 and Broadcom BCM5716C card problems

Ok, thanks for your help.  I looked at the running-config and for that port I only see the description I gave t

he port in the GUI.  I don't see anything else associated with that port or other ports, exce

pt for the uplink.  It had some additional info.

New Member

Re: 2960 and Broadcom BCM5716C card problems

Alright, it appears enabling the port as a desktop thru the GUI added the appropriate settings.  It added the enableportfast setting.  Upon booting the server no problems with connectivity.


Thanks for your help,

James

Re: 2960 and Broadcom BCM5716C card problems

Hi James

Desktop smartmacros will include the "spanning-tree portfast" command specified by Jon.. Apart from this, it will include all best practice configs for a end user PC/Server connectivity like - bpduguard enable (to prevent spanning tree instabilities), port-security configs, switchport mode access, and so on.. Incase you need to apply these commands on CLI, you can use the following:

switch1 (config) # interface fast 0/1

switch1 (config-if)# macro apply cisco-desktop

and automatically you will have these commands applied:

switchport access vlan 

switchport mode access 
switchport port-security
switchport port-security maximum 1 
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity 
spanning-tree portfast (most important)
spanning-tree bpduguard enable (important)


Hope this helps.. all the best...

Raj

1978
Views
0
Helpful
6
Replies