Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2960 and Qos : It doesn t work

Hi,

trying to set up Qos on a 2960. What i want to do : Tagging port Fa0/4 to Cos 5

I've done this with 2950 EI but it doesn't work witch 2960

Here's my configuration

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos

interface FastEthernet0/4

description *** MEDIA GATEWAY RTP ***

switchport access vlan 11

switchport mode access

switchport nonegotiate

speed 100

duplex full

mls qos cos 5

mls qos trust cos

spanning-tree portfast

end

I monitor port Fa0/4 and all trames have dscp 0

What is wrong in my configuration ? same configuration works with 2950.

Thanks

20 REPLIES
Hall of Fame Super Bronze

Re: 2960 and Qos : It doesn t work

You usually use "cos" for non-ip traffic (trunk interfaces) and "dscp" for ip traffic.

What kind of traffic is traversing via this interface?

Is the media gateway server setting its own "cos" value or you want the switch to insert this value on the packets?

If so, you must use "mls qos cos 5 override".

For more information on QoS in Cat2960 see:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_44_se/configuration/guide/swqos.html

HTH,

__

Edison.

New Member

Re: 2960 and Qos : It doesn t work

We have ip traffic. The media gateway is not able to set its own "cos" value.

cmd line Mls qos cos 5 override is not accepted by the switch

Hall of Fame Super Bronze

Re: 2960 and Qos : It doesn t work

Configure for DSCP instead.

__

Edison.

New Member

Re: 2960 and Qos : It doesn t work

The "mls qos cos override" is a separate command that you would enter on the interface but its not your problem. If your gateway doesn't mark COS then it isn't needed. I agree just mark the DSCP with EF(46).

New Member

Re: 2960 and Qos : It doesn t work

+1 on DSCP.

Bear in mind that CoS field only exists on Ethernet frame with 802.1Q header. Since your port is configured as access port, there's no 802.1Q header, hence no CoS field. On the contrary, DSCP field is contained within the IP header, so it exists end-to-end. Always configure DSCP/IP Prec when you can, and only fallback to CoS when your hardware is not capable to look past L2 header. Note that most newer Layer-2 switches can look up to layer-4 headers for QoS purposes only.

New Member

Re: 2960 and Qos : It doesn t work

But why the same configuration works on a 2950 switch ? What is wrong for 2960 ?

How can i configure DSCP/ IP Prec on the port to mark all frames incoming on this port with EF ?

New Member

Re: 2960 and Qos : It doesn t work

Good point. Sorry I missed that. I'm not sure why it worked on 2950, but not 2960. But then again, we're talking about change of platform, so I'm not at all surprised that the configs would have to change too, especially in relation to QoS.

Here's a QoS config guide for 2960. There're a few sections about configuring classification and marking using DSCP: http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_37_se/configuration/guide/swqos.pdf

Edit: better yet, start with configuring AutoQoS on the interface before you start with the classification and marking configs. This will ensure all the necessary QoS configs are automatically generated by the switch. Saves you from having to manually configuring everything from scratch. :-)

New Member

Re: 2960 and Qos : It doesn t work

One of the challenges of QOS is almost every platform is different, try the following and I did this from memory so if someone else sees a problem with it chime in:

policy-map your_policy

class class-default

set dscp ef

interface fa0/4

service-policy input your_policy

New Member

Re: 2960 and Qos : It doesn t work

That will work. However, it's better to apply the commands above AFTER issuing AutoQoS. If nothing else, to ensure the CoS-to-DSCP and DSCP-to-CoS mappings are done properly. As has been pointed out, every platform is different, so it's better to let AutoQoS handle this type of platform-specific configurations.

New Member

Re: 2960 and Qos : It doesn t work

sorry but no success. Diffserv is still 0 in my network trace

New Member

Re: 2960 and Qos : It doesn t work

Where are you sniffing the traffic?

New Member

Re: 2960 and Qos : It doesn t work

On the same switch

My sniffer is on fast 0/3 and i monitor fast0/4

New Member

Re: 2960 and Qos : It doesn t work

I believe you are sniffing the traffic before the switch marks it. Try sniffing a port where the traffic is exiting the switch or the the port on the next upstream device where this switch connects too.

New Member

Re: 2960 and Qos : It doesn t work

Sniffing an other port, same pb

Here is my configuration

mls qos

policy-map VOIP_SIEMENS

class class-default

set dscp ef

interface FastEthernet0/4

description *** MEDIA GATEWAY RTP ***

switchport access vlan 11

switchport mode access

switchport nonegotiate

load-interval 30

speed 100

duplex full

spanning-tree portfast

service-policy input VOIP_SIEMENS

end

MAN_SW_TOIP-0_01#sh mls qos interface fastEthernet 0/4

FastEthernet0/4

Attached policy-map for Ingress: VOIP_SIEMENS

trust state: not trusted

trust mode: not trusted

trust enabled flag: ena

COS override: dis

default COS: 0

DSCP Mutation Map: Default DSCP Mutation Map

Trust device: none

qos mode: port-based

MAN_SW_TOIP-0_01#sh policy-map interface fastEthernet 0/4

FastEthernet0/4

Service-policy input: VOIP_SIEMENS

Class-map: class-default (match-any)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: any

0 packets, 0 bytes

30 second rate 0 bps

Policy map seems not working ???

New Member

Re: 2960 and Qos : It doesn t work

The show policy-map interface command does not work on the 2960 and other switches, so as you can see it is hard to see what is actually going on.

New Member

Re: 2960 and Qos : It doesn t work

Ok thanks. But what is wrong in my configuration ?

Hall of Fame Super Bronze

Re: 2960 and Qos : It doesn t work

As another poster suggested, why don't you start with "AutoQoS" as a baseline and then modify per your needs.

Take a moment and read the link that I and the other poster have referred you to go.

I don't have a 2960 switch at the moment to verify the correct configuration and as you can see, every hardware have a slightly different QoS configuration.

HTH,

__

Edison.

New Member

Re: 2960 and Qos : It doesn t work

Hi,

i've have tried to use autoqos. No more success

Re: 2960 and Qos : It doesn t work

Hi,

You cannot "trust" the CoS and force the CoS at the same time.

You have to choice between trust or force the cos.

In your configuration, you have to remove the command "mls qos trust cos".

If it is possible, try to force with DSCP and not CoS with the command "mls qos dscp 46" but I don't know if it works on 2960.

Best regards

Re: 2960 and Qos : It doesn t work

You cannot do "trust cos" in this setup. The port has been configured as an access port and thus will not have a dot1Q header. As the cos-bits are in the 802.1p section of this header, the switch will read the cos as '0' and clear the dscp-field because of the trust. That is for incoming traffic (i.e. from the MGC)

Traffic towards the MGC (outgoing from the switch)should have had it's qos set at entering the network. Non-trusting ports and trunks will wipe this information, resulting in the delivery of class0 traffic.

When the MGC does not send traffic with correct markings you may apply these on the switch but I would rather go for trusting what is sent. This means that you should trust dscp and configure the MGC to mark the traffic.

regards,

Leo

785
Views
0
Helpful
20
Replies