Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2960 be a dhcp server?

could the 2960 series switch act as a dhcp server?

thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: 2960 be a dhcp server?

Hi

DHCP server is possible in Cisco 2960 switches, find the configurations below according 2 ur requirement.

ip dhcp pool test

network 192.168.50.0 255.255.255.0

domain-name cisco.com

default-router 192.168.50.1

dns-server 192.168.50.2

lease 4

ip dhcp snooping

ip dhcp-server 192.168.50.3

interface vlan 1

ip address 192.168.50.3

you can also know the dhcp server status by

show ip dhcp binding

show ip dhcp conflicts

Note: you can also type the excluded ip address which will not be used by the dhcp server.

ip dhcp excluded-address 192.168.50.1 192.168.50.10

hope this helps,

rate this post if you cleared.

6 REPLIES
Hall of Fame Super Bronze

Re: 2960 be a dhcp server?

Celso,

According to this link

http://www.cisco.com/en/US/products/ps6406/products_configuration_guide_chapter09186a00805a75ba.html

It does.

_____

Please rate helpful posts.

Thanks

New Member

Re: 2960 be a dhcp server?

by default it says dhcp server is enabled. what is the default ip address range will it lease..

Am asking this coz ive replaced 20 edge switches with cisco 2960s after which the worksations started to acquire ip addresses with range of 192.168.50.xxx, and thereby created problem coz the known DHCP server has got range of class A.

i did not do any configurations on the switches prior to installations.

how could this happened?

thanks

Cisco Employee

Re: 2960 be a dhcp server?

Celso,

DHCP is enabled by default on the 2960 switch but the switch responds to DHCP requests only if it is configured as a DHCP server.

For example, a Sample DHCP Server configuration on the switch would look like:

ip dhcp pool TEST

network 10.1.1.0 255.255.255.0

dns-server 10.1.1.2

default-router 10.1.1.1

domain-name cisco.com

lease 4

Refer the fine print in the document for details.

http://www.cisco.com/en/US/products/ps6406/products_configuration_guide_chapter09186a00805a75ba.html#wp1204675

Let me know if it helps.

Regards,

Arul

Re: 2960 be a dhcp server?

Hi

DHCP server is possible in Cisco 2960 switches, find the configurations below according 2 ur requirement.

ip dhcp pool test

network 192.168.50.0 255.255.255.0

domain-name cisco.com

default-router 192.168.50.1

dns-server 192.168.50.2

lease 4

ip dhcp snooping

ip dhcp-server 192.168.50.3

interface vlan 1

ip address 192.168.50.3

you can also know the dhcp server status by

show ip dhcp binding

show ip dhcp conflicts

Note: you can also type the excluded ip address which will not be used by the dhcp server.

ip dhcp excluded-address 192.168.50.1 192.168.50.10

hope this helps,

rate this post if you cleared.

New Member

2960 be a dhcp server?

Hello,

I have a question, will this work even if we have multiple vlan configured on the switch 2960

Also it will assign all host inside a vlan with IP based on the range defined in IP Pool

I mean it all host get random IPs from the range irrespective of the vlan they are in, right !!

Regards

2960 be a dhcp server?

Example - 

Your hosts are in Vlan10

Vlan 10 has an SVI of 10.1.1.1 (/24)

You have a DHCP scope setup on the switch and as part of this scope you have to provide a Network address which will be 10.1.1.0. When yours hosts inside Vlan 10 send out a DHCPDISCOVER packet, the switch knows to direct this to the DHCP Pool for that specific subnet (i.e 10.1.1.0), Hosts inside Vlan 50 for example, will need thier own scope if you want them to have DHCP also.

The subnets and VLAN ID's above are just exampled.

46503
Views
6
Helpful
6
Replies
CreatePlease login to create content