Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

2960 cannot be seen on the network except by the core switch 4507R

we have a 4507R that has switchport mode access vlan 2 set on Gi7/42. It is directly connected to a 2960 that has Fa0/24 configured for switchport mode access, vlan 2. the 2960 has a vlan 2 interface of 192.168.2.201. These two interfaces can talk to each other with no problems at all.

there are also 2 other 3560G switches that have a port on vlan 2. these switches can see the 2960 and vice versa.

no other devices in the network (besides the 2 3560Gs and the 4507) can see the 2960. All other networks devices can see and talk to the 4507R and the 3560s.

I'm not sure if the 4507R isn't sending out routing updates to the switches. I have tried setting static routes and default gateways.

i just find it weird that all netowrk devices can see vlan 2 on the 3560s but can't seem to find the 2960.

the 4507:

!

interface GigabitEthernet7/42

switchport access vlan 2

switchport mode access

speed auto 100

spanning-tree portfast

!

....

!

interface Vlan2

ip address 192.168.2.1 255.255.255.0

!

...

the 2960:

!

interface FastEthernet0/24

description Management

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

...

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan2

ip address 192.168.2.201 255.255.255.0

no ip route-cache

thanks in advance for any help.

7 REPLIES

Re: 2960 cannot be seen on the network except by the core switch

Kendrick,

The reason you are seeing this is because the 2960 is a layer two switch, and the 3560's are layer three switches. The vlan 2 IP address you have configured on the 2960 is for management of the switch. The 2960 is unable to participate in the routing process with your 4507.

Mark

New Member

Re: 2960 cannot be seen on the network except by the core switch

thanks Mark.

yes, I have configured the vlan 2 ip address for management purposes.

the 2960 isn't doing any routing, it's just a node off the 192.168.2.1 network which is hosted on the 4507.

i'm still not sure why if i'm on the 192.168.x. network i can't telnet to 192.168.2.201, but I can telnet to 192.168.2.52 which is an address of the 3560s

Re: 2960 cannot be seen on the network except by the core switch

Do you have "ip default-gateway 192.168.2.1" command on the 2950?

New Member

Re: 2960 cannot be seen on the network except by the core switch

I would make sure that you have the default gateway command setup and there is no need to put "spanning-tree portfast" between the 4507 and the 2960.

Purple

Re: 2960 cannot be seen on the network except by the core switch

I agree sounds like default gateway is missing on the 2960 ,verify with the "show ip default" command , it should show the layer 3 device address that is doing the routing for the subnet.

New Member

Re: 2960 cannot be seen on the network except by the core switch

great! that's definitely what was needed. If i wanted to run 2 vlans between this port now, would just making it a trunk on both ends not effect anything?

New Member

Re: 2960 cannot be seen on the network except by the core switch

ok i've got port trunking setup and it's working. thanks again for everyone's help and input! i'm a new network engineer so i'm pretty sure you all will see more posts from me soon enough and i look forward to giving back to the community as much as i can

135
Views
0
Helpful
7
Replies
CreatePlease to create content