Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2960 etherchannel 2 ports into 1 2gbit port

Hello People,

I have an Catalyst 2960G Switch.

I want to bundle 2 ports so it operates at 2gbit/s.

On 1 side I have an IBMServer1 with EthernetBonding also at 2gbits bundled.

And on the other side I also have an IBMServer2 with EthernetBonding at 2gbits bundled.

See the attached file for a simple drawing.

I am absolutely sure the config of the IBM servers is correct, because I've tested it with crosscables and

measured the bandwith with a linux program called 'Iperf' at 1,8Gbit/s

Her is my relevant Cisco Config

interface Port-channel1

switchport mode access

!

interface Port-channel2

switchport mode access

interface GigabitEthernet0/17

switchport mode access

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet0/18

switchport mode access

channel-group 2 mode on

spanning-tree portfast

!

interface GigabitEthernet0/19

switchport mode access

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet0/20

switchport mode access

channel-group 2 mode on

spanning-tree portfast

I'm able to ping from serverA to serverB so there is an connection.

It is also redundant because when I physically detach a network cable the connection stays alive.

But when I measure the bandwith from ServerA to ServerB, it says its maximun bandwith is 941Mbit/s, while is should be able to reach 1800Mbit/s.

I've also tried it witch the LACP protocol but I got te same result.

Am I missing something here?

Help is very much appreciated.

Hendrik van der Ploeg

Linux System Administrator

The Netherlands

7 REPLIES
Bronze

Re: 2960 etherchannel 2 ports into 1 2gbit port

Hi,

Issue an: sh etherchannel 1 detail.

Why don't you use: trunk ?

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

!

!

interface GigabitEthernet0/47

description UPLINK

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

!

interface GigabitEthernet0/48

description UPLINK

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

!

BR,

Bjornarsb

Re: 2960 etherchannel 2 ports into 1 2gbit port

Hendrik-

The first thing I would do is set the server and the switch speeds to 1000. Auto-neg rarely seems to work on servers and Cisco switches. You can check to see if the are negotiating (in)correctly with the show interface command.

HTH

Purple

Re: 2960 etherchannel 2 ports into 1 2gbit port

Etherchannel is not a load sharing function. If you have a conversation that is strictly going between 2 servers that conversation is only going to go down one of those links thus probably it is reporting 940 meg . It is all based on how you set up the load balance for the channel but a single conversation will always go down a single link of the channel .

New Member

Re: 2960 etherchannel 2 ports into 1 2gbit port

Glen is right, you would need another host in similiar setup and use ipperf at the same time.

Use test ether-channel to make sure that each server will send on a different link otherwise you will only get up to 1 Gbps performance.

Also, spanning-tree portfast causes more problem than it solves with linux bonding because STP has to properly manage the MAC so it doesn't flap, but again it depends on what bonding mode you are using.

LACP should be fine, but stuff like mode=1 needs STP on for the port.

New Member

Re: 2960 etherchannel 2 ports into 1 2gbit port

OK Thanks!!!

I'm back in the office on monday.

I'll give it a try then

New Member

Re: 2960 etherchannel 2 ports into 1 2gbit port

Hi Hendrik

This is due to the distribution rule of cisco's

Understanding How EtherChannel Frame Distribution Works

EtherChannel distributes frames across the links in a channel by reducing part of the binary pattern formed from the addresses in the frame to a numerical value that selects one of the links in the channel.

EtherChannel frame distribution is based on a Cisco-proprietary hashing algorithm. The algorithm is deterministic; given the same addresses and session information, you always hash to the same port in the channel, preventing out-of-order packet delivery.

The address may be a source, a destination, or a combination of two IP addresses, two MAC addresses, or two TCP/UDP port numbers depending on the policy that is adopted through the ip, mac, session, and ip-vlan-session options of the set port channel all distribution command. See the "Configuring EtherChannel Load Balancing" section for detailed information

See (or other Docu's)

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/catos/8.x/configuration/guide/channel.html

Groetjes

Willem

New Member

Re: 2960 etherchannel 2 ports into 1 2gbit port

ok i've given the command: show interfaces port-channel 1

At the bandwith section is says 2000000kbit.

So I guess the configuration should be fine.

But what is the best option at loadbalance?

And how can I test the both etherchannels at the same time.

The "test ether-channel" won't co-operate with me

test ether-channel load-balance interface port-channel 1 ip 10.168.1.28 255.255.255.0

Then it gives back:

Would select Gi0/17 of Po1

658
Views
0
Helpful
7
Replies
CreatePlease to create content