Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2960 LACP and VLan Issues

All,

I appreciate any assistance on this.  I just setup LACP on ports 3-4 and it is not working.  Once I place the ports on vlan 1 the ports go inactive.  If I place the ports on vlan 10 for instance they go live and are green.  If they are on vlan 10 I can not see the server or anything.  Any ideas?  What information do you need other than what is below.

Here is info with them on VLAN 1

interface GigabitEthernet0/3

description Zeus LACP

channel-group 5 mode active

interface GigabitEthernet0/4

description Zeus LACP

channel-group 5 mode active

vlan internal allocation policy ascending
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
Cisco-2960#sh lacp counters
             LACPDUs         Marker      Marker Response    LACPDUs
Port       Sent   Recv     Sent   Recv     Sent   Recv      Pkts Err
---------------------------------------------------------------------
Channel group: 5
Gi0/3       57     3448     0      0        0      0         0    
Gi0/4       57     3448     0      0        0      0         0    
Cisco-2960#sh lacp internal
Channel group 5
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi0/3     SA      susp      32768         0x5       0x5     0x104       0x5  
Gi0/4     SA      susp      32768         0x5       0x5     0x105       0x5  
Group: 5
----------
Group state = L2
Ports: 2   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
Minimum Links: 0
Cisco-2960#sh etherchannel protocol
Channel-group listing:
----------------------
Group: 5
----------
Protocol:  LACP
Thanks Again!

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: 2960 LACP and VLan Issues

Thanks for your reply. Sorry, my mistake I wanted to ask for 'sh run int po5' instead of 'sh int'. By the way, based on your logs, it looks like the problem is that the channel members and port-channel interface configuration are not consistent. In order for the port-channel to work properly, the members need to have the same configuration, as well as the port-channel interface.

I would suggest to try the following, as you're using vlan 1 only:

conf t

int ra gi0/3 - 4

switchport mode access

switchport access vlan 1

int po5

switchport mode access

switchport access vlan 1

Let me know if this helps. If not, please provide me with the following:
sh run int gi0/3
sh run int gi0/4
sh run int po5
Silver

Re: 2960 LACP and VLan Issues

Yes, you need to configure the same settings (like same vlan) for both member ports, gi0/3 and gi0/4 if you are using those. That's why I was using 'int ra' in my example, which means 'interface range' so that you can configure multiple ports at the same time.

8 REPLIES
Silver

Re: 2960 LACP and VLan Issues

Hi,

It would be good to know the following:

- What device is connected on the other side?

- How is the other side configured?

- Is the other side configured as a trunk port or access port?

- Configuration of interface Port-channel5 (sh int po5).

- Output of 'sh etherchannel 5 summary' when it's working and when it's not working.

- Do you see any error messages in the logs (sh log) ? If yes, paste some here.

Andras

New Member

Re: 2960 LACP and VLan Issues

Thanks for the reply.  Below is what you asked for:

1) Apple Xserve (2010 purchase)

2) The 2 ports are bound together

3) I assume an assess port

4) Cisco-2960#sh int po5

Port-channel5 is down, line protocol is down (notconnect)

  Hardware is EtherChannel, address is 0017.0e8f.9a04 (bia 0017.0e8f.9a04)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, link type is auto, media type is unknown

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:36:30, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     2005 packets input, 177522 bytes, 0 no buffer

     Received 2005 broadcasts (268 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 268 multicast, 0 pause input

     0 input packets with dribble condition detected

     2218 packets output, 200076 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

Number of channel-groups in use: 2

Number of aggregators:           2

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

5      Po5(SD)         LACP      Gi0/3(s)    Gi0/4(s) 

Logs
02:13:41: %EC-5-CANNOT_BUNDLE2: Gi0/3 is not compatible with Gi0/4 and will be suspended (access vlan of Gi0/3 is 1, Gi0/4 is 10)
02:13:41: %EC-5-CANNOT_BUNDLE2: Gi0/3 is not compatible with Po5 and will be suspended (access vlan of Gi0/3 is 1, Po5 is 10)
02:13:41: %EC-5-CANNOT_BUNDLE2: Gi0/3 is not compatible with Po5 and will be suspended (access vlan of Gi0/3 is 1, Po5 is 10)
02:13:41: %EC-5-CANNOT_BUNDLE2: Gi0/4 is not compatible with Po5 and will be suspended (access vlan of Gi0/4 is 1, Po5 is 10)
02:13:42: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/3, changed state to down
02:13:42: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/4, changed state to down
02:13:42: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to down
02:13:43: %LINK-3-UPDOWN: Interface Port-channel5, changed state to down
Let me clarify working and not working.  The activity lights are green when they are set to any vlan other then 1.  Once they are on vlan 1 the output above shows.  The whole network is on vlan 1.  Again let me know what you need and I will provide it.
Thanks

Message was edited by: rkovelman

Silver

Re: 2960 LACP and VLan Issues

Thanks for your reply. Sorry, my mistake I wanted to ask for 'sh run int po5' instead of 'sh int'. By the way, based on your logs, it looks like the problem is that the channel members and port-channel interface configuration are not consistent. In order for the port-channel to work properly, the members need to have the same configuration, as well as the port-channel interface.

I would suggest to try the following, as you're using vlan 1 only:

conf t

int ra gi0/3 - 4

switchport mode access

switchport access vlan 1

int po5

switchport mode access

switchport access vlan 1

Let me know if this helps. If not, please provide me with the following:
sh run int gi0/3
sh run int gi0/4
sh run int po5
New Member

Re: 2960 LACP and VLan Issues

You are the man!!  Thanks!

I will need to do the same for port 1 and port 2 is that ok?

Silver

Re: 2960 LACP and VLan Issues

Yes, you need to configure the same settings (like same vlan) for both member ports, gi0/3 and gi0/4 if you are using those. That's why I was using 'int ra' in my example, which means 'interface range' so that you can configure multiple ports at the same time.

New Member

Re: 2960 LACP and VLan Issues

Cisco 2960 -> PORT-CHANNEL -> Apple Xserver? is this right?

New Member

Re: 2960 LACP and VLan Issues

What do you mean by this:

Cisco 2960 -> PORT-CHANNEL -> Apple Xserver

New Member

Re: 2960 LACP and VLan Issues

The layout is as follows:

Xserve -> 2 ports are link aggregated, or bonded in OS -> Cisco

4895
Views
0
Helpful
8
Replies
CreatePlease login to create content