Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2960 no internet access from VLAN

I have a 2960-S running the lastest software for testing on my bench:

[code]

Switch Ports Model              SW Version            SW Image                

------ ----- -----              ----------            ----------              

*    1 24    WS-C2960-24-S      15.0(1)SE2            C2960-LANLITEK9-M  

[/code]

I have set up VLAN 2 on 192.168.2.0/24 with the switch as the DHCP server.  The switch is connected to an RV082 router which is at 192.168.1.65/27.  Once I figure out what I doing I'll eventually shift that to 192.168.1.0/24 or something similar.  So I have my switch acting as the DHCP server for VLAN 2 but I can't figure out how to get it to access the internet.

I found this example to set up the DHCP server:

[code]

###################################

this works to get vlan 2 to serve ips

conf t

no ip dhcp pool LAN

ip dhcp pool LAN_2

network 192.168.2.0 255.255.255.0

domain-name lan_2.com

default-router 192.168.2.1

dns-server 192.168.1.65 (your DNS server IP)

lease 7


interface vlan 2

ip add 192.168.2.1 255.255.255.0

no ip route-cache

ip tcp adjust-mss 1460


ip dhcp snooping

ip dhcp-server 192.168.2.1

####################################

[/code]

I tried this which isn't a recognized CLI command: (maybe cuz of the lanlite software?)

[code]

ip route 0.0.0.0 0.0.0.0 x.x.x.x ( where x.x.x.x is next device connecting interface)

[/code]

and then this:

[code]

ip default-gateway 192.168.1.65

[/code]

Any pointers would be appreciated.

The RV082 doesn't support trunks AFIK and I'm pretty much a newb at this stuff.  TIA.  I guess I should get a real router and I most likely will but I'd like to get this working if possible before taking the next plunge.

7 REPLIES
Bronze

2960 no internet access from VLAN

Maybe configure vlan 1 on switch with ip address in same subnet as the router and use a routing protocol like rip.

Hope this helps

Eugen

New Member

Re: 2960 no internet access from VLAN

The default gateway you are using is not in vlan 2. Try changing the ip address on the router interface to an ip in the same subnet as vlan 2. Then change the default gateway to that ip address. I am not sure what commands the lan lite does not have compared to ip base but try IP default-network commond and see if that will work in place of the default route.

Sent from Cisco Technical Support iPhone App

New Member

2960 no internet access from VLAN

Hi viningele,

As Michael and eugen stated you need an interface in the same subnet as the router.

Since it's a lanlite image you cannot enable unicast routing on the switch as you could if you had a lanbase image. This would be the reason you were unable to create your static route.

Now since the router can't use 802.1q trunks your only real option is to use a flat vlan on the same subnet as the router if you want to be able to access the internet from any devices connected to the switch.

HTH

New Member

Re: 2960 no internet access from VLAN

So basically with the LANLite image I'm SOL. The intent was an isolated guest network using waps with multiple vlan capability connected to the 2960.

I do have a UC520 and a CE 500 on the shelf too so I'm not completely sol. If i had regular 2960 i could make it work with RV082 though.

Another idea, the Rv082 supports setting their 8 physical ports to a single vlan 1-8 so would it plausible to set a port on the 2960 to just vlan 2 and wire it to a port on the RV082 set up as vlan 2.

Sent from Cisco Technical Support iPad App

Bronze

2960 no internet access from VLAN

The trunk link allows you to forward multiple vlans across that link. I don't know if you can configure vlans on the router, if your router does not support trunking, but has vlan 1 as default. You need to change vlans on the switch to match the vlan on the router and have the same subnet for that vlan on switch and router.

Hope this helps

Eugen

New Member

2960 no internet access from VLAN

The router does support vlans just not trunks.  I just don't know if assigning a physical port on the RV082 to vlan 2 is merely an internal tag used for isolation or if tags coming in on the physical port would also be recognized.  I'll give it a shot when I get a chance otherwise I'll pull out the UC500 or CE520.

New Member

2960 no internet access from VLAN

Hi viningele,

Without trunks there would be no tagging involved, in other words your catalyst switch should be connected using an access port and not a trunk port.

It would also appear the rv082 will allow your vlans to access the internet but no inter-vlan routing is done so this would work if you have 2 networks that don't need to speak to each other but yet both need internet access.

They explain the behaviour in the following document (page 88 at the bottom of the page)

http://www.cisco.com/en/US/docs/routers/csbr/rv0xx/administration/guide/rv0xx_AG_78-19576.pdf

In response to the other comment yes if you had a lanbase license on the 2960 you could activate unicast routing using the following command;

sdm prefer lanbase-routing

Followed by a reload

HTH

2178
Views
0
Helpful
7
Replies
CreatePlease login to create content