Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2960 only passing 1 VLAN using trunk to router

Hi

I have a remote office with a 2960 24 port switch connected to 2 2600 routers (redundancy). I'm using sub-interfaces on the routes configured for .1Q encapsulation to trunk 2 VLAN's from the switch to the routers.

1 of the routers only seems to see 1 of the VLANs. Here's the config of the router

interface FastEthernet0/0

no ip address

no ip redirects

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1

ip helper-address 10.90.200.65

ip helper-address 10.90.202.65

no ip redirects

shutdown

standby 1 ip 10.90.173.1

standby 1 priority 200

standby 1 preempt delay minimum 240

standby 1 track Serial0/0

!

interface FastEthernet0/0.2

encapsulation dot1Q 26

ip address 10.90.26.3 255.255.255.0

no ip redirects

standby 10 ip 10.90.26.1

standby 10 priority 150

fa0/0.1 VLAN 1 can't even ping it's HSRP neighbor nothing in it's arp cache either.

11 REPLIES
New Member

Re: 2960 only passing 1 VLAN using trunk to router

Whats the IP address on FA 0/0.1?

You only have the HSRP address configured

New Member

Re: 2960 only passing 1 VLAN using trunk to router

Also FA 0/0.1 is shutdown

New Member

Re: 2960 only passing 1 VLAN using trunk to router

Yeah I had it shut down so it doesn't mess with the other router. I didn't realize I left out the interface address! thanks I'm going to give it a try right now.

New Member

Re: 2960 only passing 1 VLAN using trunk to router

I put in the address for fa0/0.1 and turned up the port but still wasn't able to ping across to the other router's interface nor anything on that VLAN.

New Member

Re: 2960 only passing 1 VLAN using trunk to router

Are the switchport configured as dot1q trunks

New Member

Re: 2960 only passing 1 VLAN using trunk to router

The switch only supports .1Q encapsulation so here is the config on the ports connected to the routers

interface FastEthernet0/15

description trunk to rtr1

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

interface FastEthernet0/24

description trunk to rtr2

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

port 0/15 is connected to the working router and 0/24 is the one not working.

New Member

Re: 2960 only passing 1 VLAN using trunk to router

I would also change from vlan 1 to another

vlan.

Check that you have configured the vlans on the switch

!

vlan database

vlan 1

vlan 26

vlan x

exit

!

New Member

Re: 2960 only passing 1 VLAN using trunk to router

Yeah I was planning to but I inherited this network and it's on my to do list. It shouldn't be a show stopper though because it is working on the other router.

New Member

Re: 2960 only passing 1 VLAN using trunk to router

for the interface FastEthernet0/0.1

change encapsulation dot1q 1

to

encapsulation dot1g 1 native

That should fix you all up :)

This will allow the trunk to form :)

on a side bar the switch has to be configured as a trunk on the other end you have to have the vlans in the database and if you change the native vlan on the switch side you wil have to create another subinterface on the router with that vlan specified as native :)

New Member

Re: 2960 only passing 1 VLAN using trunk to router

I tried that but it doesn't take. I was concerned from the beginning that I'm running Version 12.1(20) and it might be sort of buggy or different. My working router is running Version 12.3(6f) and I do have the native in there. I haven't seen anything in the 12.1 notes that indicates this would be a problem though.

Blue

Re: 2960 only passing 1 VLAN using trunk to router

This is getting confusing.

Why dont you post the switch config as well as the router configs. And make sure you post the configs that SHOULD be there (ie get rid of "shutdowns"

Thanks

294
Views
0
Helpful
11
Replies
CreatePlease login to create content