Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2960 POE acting as a dhcp server

                   I have a 2960 POE 24 switch acting as a DHCP server

for a WLC 4402 and six Aironet APs. I cant get the APs to aquire

an address. At least when I check the switch by doing a sh dhcp

lease it shows nothing. Here is the commands I used to set it up
on the switch.

ip dhcp excluded-address 192.168.50.1 255.255.255.0
!
ip dhcp pool wireless
   network 192.168.50.0 255.255.255.0
   domain-name newtonma.gov
   default-router 192.168.50.1
   lease 4
!

Here is an example of one of the interfaces

interface FastEthernet0/1
switchport trunk native vlan 10
switchport mode trunk
!

The Vlan for wireless

interface Vlan10
ip address 192.168.50.1 255.255.255.0
ip helper-address 192.168.50.1
no ip route-cache

Any help would be appreciated

1 ACCEPTED SOLUTION

Accepted Solutions

2960 POE acting as a dhcp server

Hi

You can remove the helper address as the DHCP server is on the switch itself. A helper address is only needed when the DHCP server is another device than the one the default gateway sits on.

The interface example you gave above, is that the interface to one of the Access Points or to the WLC?

Assuming the Access Points are not in Flex Connect mode, they only need to be access ports (i.e not trunks) as the traffic is tunneled back to the WLC.

The config for each AP would be:

#interface fa0/1

#switchport mode access

#switchport access vlan 10

The config for the WLC would be:

#interface fa0/10

#switchport mode trunk

I would leave the Native Vlan as 1 (i.e remove the command) or at least change it to something other than Vlan10.

The DHCP excluded address could be causing an issue as there is no need for a subnet mask if you simply want to exclude a single address.

#ip dhcp excluded-address 192.168.50.1

5 REPLIES

2960 POE acting as a dhcp server

Hi

You can remove the helper address as the DHCP server is on the switch itself. A helper address is only needed when the DHCP server is another device than the one the default gateway sits on.

The interface example you gave above, is that the interface to one of the Access Points or to the WLC?

Assuming the Access Points are not in Flex Connect mode, they only need to be access ports (i.e not trunks) as the traffic is tunneled back to the WLC.

The config for each AP would be:

#interface fa0/1

#switchport mode access

#switchport access vlan 10

The config for the WLC would be:

#interface fa0/10

#switchport mode trunk

I would leave the Native Vlan as 1 (i.e remove the command) or at least change it to something other than Vlan10.

The DHCP excluded address could be causing an issue as there is no need for a subnet mask if you simply want to exclude a single address.

#ip dhcp excluded-address 192.168.50.1

New Member

2960 POE acting as a dhcp server

I tried your recommended changes but stil nothing.

I use the sh dhcp lease command to check.

Any ideas?

2960 POE acting as a dhcp server

Could you post the full config from the switch?

Its fine to blank out or remove anything sensitive like usernames, passwords or device names etc, I just need the commands themselves.

Thanks

New Member

2960 POE acting as a dhcp server

All set. I was using the wrong command to verify

sh ip dhcp binding

All six APs are there.  Thanks for your help devil

2960 POE acting as a dhcp server

Glad it's fixed!

I did read your reply but didn't pickup on the command you were using, teach me to skim read!! :)

592
Views
0
Helpful
5
Replies
CreatePlease to create content