Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2960 Port Security

Hi All

I'm having a bit of a dilema configuring some 2960 switch ports for port security.

Each Port must only see one legal device connected to it and shutdown should someone connect an illegal device.

I have configured the port accordingly. But if I have the switchport port-security max set to 1, nothing works and if I set it to, 2 everything works including illegal devices ..

I cannot see for the life of me whatI am doing wrong .. can any one advise ?

interface FastEthernet0/14

switchport access vlan 2

switchport mode access

switchport port-security

switchport port-security max 2

switchport port-security mac-address xxxx.xxxx.xxxx

speed 10

duplex full

spanning-tree portfast

spanning-tree bpduguard enable

3 REPLIES

Re: 2960 Port Security

The default is 1 address, so I don't think you need the statement. Here's an example of ours.

switchport port-security

switchport port-security violation restrict

switchport port-security mac-address 0000.2222.4444

Hope that helps

New Member

Re: 2960 Port Security

Hello Collin

Thats worked a treat, I just removed the max setting and it all worked. Why I didn't think of that I just don't know ..

Thanks for your time

Mike

Re: 2960 Port Security

Glad it helped!

185
Views
0
Helpful
3
Replies