Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2960 Switch with DHCP configured

Hi,

we have an issue with a single device picking up DHCP.  PCs on the vLAN are picking up DHCP addresses fine, however another device does not.  If I disable the Cisco DHCP on that vLAN and use an alternative DHCP source, (I downloaded a freebe DHCP server app for my laptop) it works fine.

The DHCP pool is set-up

ip dhcp pool vlan1

   network 192.168.50.0 255.255.255.0

   domain-name Fred.co.uk

   dns-server 192.168.0.150 192.168.0.250

   default-router 192.168.50.254

   lease 3

ip dhcp excluded-address 192.168.50.1 192.168.50.50

ip dhcp excluded-address 192.168.50.60 192.168.50.254

and ports are set up as:-

interface FastEthernet0/2

switchport mode access

spanning-tree portfast

and vLAN 1 as

interface Vlan1

description STORE

ip address 192.168.50.253 255.255.255.0

no ip route-cache

7 REPLIES
New Member

2960 Switch with DHCP configured

Continued...

I scratching my head on this one, any help is much appreciated

VIP Purple

2960 Switch with DHCP configured

There are only nine addresses available in the pool is that enough?

DHCP-debugging could also give some hints: "deb ip dhcp server events"

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

New Member

2960 Switch with DHCP configured

thanks Karsten.Iwen

yes, 9 is plenty of addesses we are only using this for a couple of devices.

On this device, running "SHO IP DHCP BIND" lists only 2 devices.  I can see the device is connected fine, for example I can see the Mac address of the device with "Sho MAc Address-Table"

I will try the DHCP debugging now

New Member

2960 Switch with DHCP configured

I added the DEB IP DHCP SERVER EVENTS command and can see activity if I release and renew the IP on a PC fine.

Restarting the FalconXT device we have there is no DHCP activity at all.  When using the alternative DHCP server from my PC it picks up an address immediatly

Switch#

*Mar  1 00:06:24.416: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to down

*Mar  1 00:06:25.422: %LINK-3-UPDOWN: Interface FastEthernet0/9, changed state to down

*Mar  1 00:06:32.167: %LINK-3-UPDOWN: Interface FastEthernet0/9, changed state to up

*Mar  1 00:06:32.167: DHCPD: interface FastEthernet0/9 coming up

*Mar  1 00:06:33.174: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to up

*Mar  1 00:06:49.741: DHCPD: checking for expired leases.

Switch#

Switch#

*Mar  1 00:08:49.748: DHCPD: checking for expired leases.

Purple

2960 Switch with DHCP configured

Hi,

So when releasing/renewing on the device you see no output in debug ip dhcp server event on the switch ?

On which port is this device connected? post the output of sh interface x/x switchport for this interface

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Hall of Fame Super Gold

Re: 2960 Switch with DHCP configured

   lease 3

Lease is 3 days????  And you have 8 allowed IP address?  (Personally, I don't see the logic or insanity for this.  If it's only 8 allowable IP addresses and lease time is 3 days, I'd configure the DHCP to be static.) 

Post the output to the command "sh ip dhcp bind".

2960 Switch with DHCP configured

Try Giving this command

ip dhcp-server 192.168.50.253

ip dhcp snooping

interface Vlan1

ip helper-address 192.168.50.253

Jawad

Jawad
626
Views
0
Helpful
7
Replies
CreatePlease to create content